Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 3 von 3

Thema: WinCC 7.3 Mehrplatz-Projekt, Server OS, User angeblich mit zu wenig Rechten

  1. #1
    Registriert seit
    09.01.2012
    Beiträge
    61
    Danke
    20
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    ich richte gerade mein erstes WinCC (NICHT flexible!!!) 7.3 Mehrplatz-Projekt ein. Die Projektierung scheint so weit zu stehen, und ich konnte meinen Server auch erfolgreich von meiner ES aus via Ethernet konfigurieren und laden. Will ich die Runtime allerdings öffnen und starten, so meldet mir die Runtime:
    ---------------------------
    SIMATIC WinCC RT
    ---------------------------
    Das Projekt konnte nicht geöffnet werden. Fehler: Zugriff verweigert
    ---------------------------
    OK
    ---------------------------
    Öffne ich stattdessen den WinCC-Explorer und möchte das selbe Projekt öffnen, bekomme ich die Meldung
    ---------------------------
    WinCC-Projekt öffnen
    ---------------------------
    Der Anwender besitzt nicht die Rechte, um diese Aktion durchzuführen!
    Bitte prüfen Sie die Zuordnung des aktuellen Benutzers zu den Benutzergruppen in Windows.
    ---------------------------
    OK
    ---------------------------
    Der aktuell angemeldete User heißt "admin" und ist mit einem Kennwort versehen. Er ist Mitglied der folgenden Gruppen:

    • Administratoren
    • Hauptbenutzer
    • SIMATIC HMI
    • SQLServerMSSQLUser$Computername$WINCC


    Dies waren die Gruppen, die ich den diversen Siemens Dokus entnehmen konnte, die man einstellen soll. Ferner habe ich zum Testen auch die folgenden Gruppen mal mit drin gehabt:

    • Distributed COM-Benutzer
    • Netzwerkkonfigurations-Operatoren
    • Siemens TIA_Engineer
    • SIMATIC HMI CS
    • SIMATIC HMI VIEWER
    • SIMATIC NET
    • SQLServer2005SQLBrowserUser$Computername
    • SQLServerMSSQLServerADHelperUser$Computername
    • SQLServerSQLAgentUser$Computername$WINCC


    Die Meldungen bleiben mit und ohne dieser zweiten Liste an Gruppen gleich.


    Der SQL-Server ist auf hybride Authentifizierung gestellt (Windows- und SQL-Login), wie es hier gefordert wurde. Um das abzukürzen: Ich bin alle Punkte auf dieser Seite durchgegangen und konnte überall "abgehakt" dran schreiben.
    Ich habe ebenfalls was für mich zutreffend klang aus diesem Dokument durchgearbeitet, auch wenn ich keine konkrete Fehlernummer an die Hand bekommen habe.

    Zuletzt habe ich soeben auch noch die Zugriffsrechte für den Projekt-Ordner geprüft (in den ja von der ES aus das Projekt via STEP7 erfolgreich rein kopiert wurde), und dort zusätzlich zu "jeder", "Administrator" und "admin" noch ein paar weitere einschlägige Benutzer mit Vollzugriff aufgenommen (SIMATIC*, SQL*, und ein paar andere noch). Leider auch ohne Änderung. Es bleiben die o.g. Meldungen, und ich kann die Runtime nicht starten oder öffnen. (Auf der ES allerdings kann ich beides!)

    Der PC ist ein vorkonfigurierter Siemens IPC, ich selbst habe nur WinCC inkl. aller Abhängigkeiten und Teamviewer darauf installiert. (Die Firewall ist aus, die IP fest vergeben und ein gültiges Gateway und DNS sind eingetragen. Die Station ist ebenfalls konfiguriert, ich sehe den PC auch von meiner ES aus via "Erreichbare Teilnehmer" und kann ja auch online laden.)

    Ich komme nicht mehr weiter. Wenn das Laden inkl. der Projektdaten funktioniert, dachte ich eigentlich schon in ziemlich trockenen Tüchern zu sein. Was kann ich noch prüfen?


    Vielen Dank schon mal!
    Geändert von dariyos (15.06.2016 um 11:42 Uhr)
    Zitieren Zitieren WinCC 7.3 Mehrplatz-Projekt, Server OS, User angeblich mit zu wenig Rechten  

  2. #2
    Registriert seit
    23.07.2009
    Ort
    Österreich
    Beiträge
    2.367
    Danke
    457
    Erhielt 696 Danke für 521 Beiträge

    Standard

    Computernamen nach Installation von WinCC geändert?

    Du könntest eventuell auch noch mal versuchen das SIMATIC-Security-Control drüber laufen zu lassen.
    If at first you don't succeed, you're not Van Damme!
    ... or maybe using TIA!

  3. #3
    Medium ist offline Benutzer
    Themenstarter
    Registriert seit
    09.01.2012
    Beiträge
    61
    Danke
    20
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo!

    Danke für deine Antwort. Den Namen habe ich nicht mehr geändert, den sollte man ja spätestens nach der MSSQL Installation tunlichst nicht mehr anfassen, so wie ich das gelesen habe. Das Security Control habe ich während meiner Versuche bestimmt 5 oder 6 Mal ran gelassen. Leider alles nichts.

    Ich habe den PC mittlerweile auch mittels Restore-DVD komplett neu aufgesetzt. Jetzt habe ich neuerdings Probleme mit dem SQL Server, der mir mit dem Error 18456 State 1 den Login verweigert. Leider schon im Management Studio, sodass ich überhaupt nicht dran komme. (Der User ist Mitglied aller 4 SQL* Gruppen.) Ich habe mein Projekt allerdings übertragen bekommen, und beim Öffnen davon meckert er jetzt immerhin auch "nur" das Problem mit dem SQL Server an. (Ich hoffe, dass das nach der Prüfung der Rechte kommt, und das jetzt geht.)

    Ich habe just in diesem Moment den SQL Server Installer noch mal drüber gejagt. Mal horchen was es jetzt gibt.

    (3min später): Leider das selbe Problem. Ich brech zusammen... Im Anhang mal ein Screenshot von der Benutzerverwaltung und dem Fehler beim Versuch mich mit dem SQL Management Studio zu verbinden. Ich bin kein MSSQL Virtuoso, und hatte bisher meist mit MySQL/MariaDB zu tun. Google spuckt zum "State 1" aus, dass dies wohl ein interner Fehler sein solle, und man das CSS kontaktieren solle. Was auch immer das ist! Vor allem lief der SQL Server in der vorigen Installation des PCs problemlos und ich konnte mich auch im Studio ohne Murren anmelden. Ich habe die selbe DVD zur Installation benutzt, und alle Einstellungen wie beim ersten Mal gehabt.
    So langsam fragt mein Kunde was nun mit seinem Leitsystem ist . Hat das schon mal jemand gehabt oder weiss was hier zu tun ist?
    Angehängte Grafiken Angehängte Grafiken

Ähnliche Themen

  1. Antworten: 0
    Letzter Beitrag: 26.01.2016, 08:37
  2. Antworten: 2
    Letzter Beitrag: 05.06.2015, 15:49
  3. Angeblich zu wenig Powertags
    Von Rodewijn im Forum HMI
    Antworten: 0
    Letzter Beitrag: 23.01.2013, 10:34
  4. Antworten: 0
    Letzter Beitrag: 24.08.2012, 14:08
  5. WinCC Einzel-/Mehrplatz System
    Von franzlurch im Forum HMI
    Antworten: 2
    Letzter Beitrag: 21.07.2008, 10:03

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •