Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: TIA HMI TP1200 vs. IPC677D 15"

  1. #1
    Registriert seit
    11.06.2015
    Beiträge
    11
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Frage


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo werte Kollegen,
    ich hoffe ich finde Rat bei euch.

    Folgende Umgebung aktuell:
    TIA V13 SP1
    TouchPanel TP1200


    Mit Hilfe des Panels soll eine Rezeptgebundene Dosierung realisiert werden. Die Rezeptdaten erhalte ich per XML, die per VBS eingelesen werden. Nach erfolgter Dosierung werden die Rezeptdaten wieder per XML und VBS weitergegeben.

    Jedes Rezept hat maximal 20 Komponenten die verarbeitet werden können.
    Jede Komponente besitzt 26 Teilinformationen (Produktnummer etc.), für die ich eine UDT angelegt habe. Somit habe ich 20 Powertags, mit jeweils 26 Teilinformationen. (ca 160 Bytes pro Powertag). Diese werden "Zyklisch im Betrieb - 5s" aufgerufen.
    Nun habe ich auf einem Bild, aus jeder Komponente jeweils 6 Informationen angezeigt. Trotz der geringen aktualisierungsrate, leidet die Performance des Panels so stark darunter, dass es immer wieder zu Ablauffehlern der eigentlichen Bedienung kommt, da das TP einfach zu langsam auf die Steuerungsvariablen reagiert.

    Meine Frage ist nun, ob die Performance durch einen Austausch des TP HMI durch ein IPC HMI gesteigert werden kann? Rein rechnerisch möchte ich auf diesem Bild ca. 4kb Informationen anzeigen lassen. Das sollte für Profinet/Ethernet doch kein Problem darstellen, oder? Also führe ich das auf die schwache Leistung des Panels zurück...


    Zitieren Zitieren TIA HMI TP1200 vs. IPC677D 15"  

  2. #2
    Registriert seit
    25.02.2016
    Beiträge
    225
    Danke
    11
    Erhielt 42 Danke für 39 Beiträge

    Standard

    Hallo Florian,

    das könnte aber auch noch andere Gründe haben über wie viele Switche ist das Panel angebunden?
    Ist alles auf 100Mbit Full gestellt.
    Welche CPU hast du?
    Sind die Variablen die also die 4Kb Infos Zusammen in einen DB gespeichert oder ist das ganze sehr verstreut.
    Ruft du jede Variable einzeln auf oder über Array Variable.

    Was "treibt" dein TP sonst noch so? hast du andere Variablen auf Erfassungsart Zyklisch fortlaufend oder alle anderen nur bei Verwendung.
    Welche anderen Aktualisierungszyklen verwendest du? Meine Erfahrung umso weniger desto besser.

    MFG TIA

    PS: EVTL noch weitere Test wenn die Runtime auf deinen PG läuft ist sie dann Flüssig oder hargt es dann auch?

  3. #3
    Florian,R. ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    11.06.2015
    Beiträge
    11
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,

    vielen Dank für deine Antwort.

    das ganze ist noch im kompletten Testaufbau.
    CPU ist ne 317er, es hängt ein Switch dazwischen, die Übertragungsrate ist auch auf 100Mbit Full, die Leitungslänge beträgt gesamt ca 5m??
    Die Daten sind in einem DB angelegt, und dieser ist mit UDTs strukturiert. Also die Infos müssen nicht erst zusammengesammelt werden, sondern können von Anfang bis Ende einmal durchgerattert werden.
    Wie gesagt, es ist kein Array, aber eine HMI-UDT Struktur. Sprich es ist ein Powertag mit den einzelnen Variablen... und insgesamt sind es 20 Komponenten/ ergo 20 Powertags.
    Zyklisch fortlaufend habe ich 3 Variablen die zur Skriptsteuerung und Bedienung notwendig sind. Also das Touchpanel muss prinzipiell nicht wirklich was leisten (meiner Meinung nach)
    Ansonsten zw. 500ms und 5s. Aber alle nur auf Zyklisch im Betrieb, und davon sind nur sehr wenige auf meinem Bild...
    in den 4kB Informationen stecken die Restlichen Infos die auf dem Bild aufgerufen werden und im Hintergrund laufen schon mit drin... Und die sind großzügig berechnet...

    Man erkennt es auch an der Uhrzeit. Alle 5s ca (Aktualisierungsintervall der 20 Komponenten) stockt die Uhrzeit und "springt" eine Sekunde. In der Simulation am PC tut sie das nicht... Also das MUSS die Leistung des HMIs sein. Ich kann mir das nicht anders erklären.

  4. #4
    Registriert seit
    25.02.2016
    Beiträge
    225
    Danke
    11
    Erhielt 42 Danke für 39 Beiträge

    Standard

    Hallo Florian,

    danke für deine Antwort das sieht wohl wirklich nach einem Performance Problem am Panel aus.
    Bitte informier mich wenn du das Panel getauscht hast ob deine Probleme behoben sind. Danke!

  5. #5
    Florian,R. ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    11.06.2015
    Beiträge
    11
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    So, Update meinerseits.

    Hatte hier noch ein TP1500 rumliegen. Mit diesem habe ich weniger Probleme. Einerseits habe ich noch etwas mit mit Flanken SPS-Seitig optimiert, welche aber auf dem kleinerem TP nicht sehr viel brachten. Dann habe ich das
    größere TP verwendet, und dort wurden meine Probleme weniger, bzw. nun funzt es. Auch kann ich meinen Datenblock statt auf 5s Zyklisch, auf 1s Zyklisch stellen, ohne Probleme.
    Welchen Fehler ich jetzt aber noch habe, ist dass mein Skript beim Daten schreiben an die SPS Probleme kriegt, wenn ich gleichzeitig "Online" im Step 7 auf die SPS kugge... Also konkret gesagt schmeißt er mir dann Konvertierungsfehler hin...
    Hat dafür wer ne Erklärung? Kann doch nicht sein dass durch "doppeltes kuggen" die SPS oder das HMI so krass ins stottern kommen??

Ähnliche Themen

  1. TIA Kurvenanzeige in TIA WinCC TP1200
    Von dentech im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 14.02.2016, 21:51
  2. Antworten: 3
    Letzter Beitrag: 06.02.2015, 21:10
  3. TIA VB-Skripte TP1200 TIA V13
    Von Turi im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 13.08.2014, 08:44
  4. TIA - Mehre identische TP1200
    Von Loipe im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 07.04.2013, 20:45
  5. Antworten: 1
    Letzter Beitrag: 04.12.2012, 21:33

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •