Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 12

Thema: Problem OP17 oder 315 2DP

  1. #1
    Registriert seit
    02.06.2005
    Beiträge
    300
    Danke
    23
    Erhielt 6 Danke für 6 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Jungens
    mal wieder ein kleines Problem.
    Habe ein OP 17 Konfiguriert mit protool 6.0.
    Cpu 315 2DP programmiere ich mit IBH Software
    Verbindung steht.
    Über den K-Tasten 1-16 möchte ich Motoren ein und ausschalten. Mal ganz einfach.
    K-Tasten habe ich auf DB 100 DW 30 gelegt.
    In S7 habe ich einfach einen Eltako programmiert. Zur Anzeige die LED angesteuert. Funktioniert von K1-K15 K16 mit DBX 30.7 absolut nicht.
    Wo kann hier der Fehler liegen?
    Wenn ich den DBX30.7 einmal anstosse bleibt er gesetzt und geht nicht wieder zurück. Habe schon einiges getan aber null Chance
    Von euch jemand eine Idee

    sonnige Grüße
    Wilhelm
    Zitieren Zitieren Problem OP17 oder 315 2DP  

  2. #2
    Registriert seit
    29.01.2005
    Beiträge
    277
    Danke
    4
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Hallo!

    Schau einmal nach ob Du beim Drücken der Taste im Protool "Bit setzen" angewählt hast. Richtig währe hier "Bit setzen bei Tastendruck", damit dieses beim Loslassen der Taste wieder zurückgesetzt wird. Eventuell ist dort das Problem...

    Viele Grüße, Tobias
    Ein Experte ist ein Mensch, den man in letzter Minute hinzuzieht,
    um einen Mitschuldigen zu haben.

  3. #3
    Wilhelm ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    02.06.2005
    Beiträge
    300
    Danke
    23
    Erhielt 6 Danke für 6 Beiträge

    Standard

    Danke Lefrog
    nein sind absolut alle gleich belegt......
    Nur warum geht das mit sämtlich einzelnen DBXen nur mit dem dusseligen letzten nicht

    sonnige Grüße
    Wilhelm

  4. #4
    Registriert seit
    29.01.2005
    Beiträge
    277
    Danke
    4
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Hallo!

    Habe mir das eben mal angeschaut, die Ansteuerung der K-Tasten passiert ja bei dem OP17 über einen Bereichszeiger Funktionstastatur.
    Die Länge dieses Bereichszeigers sollte bei 16 Tasten 2 Worte sein. Hiebei besetzen die ersten 8 Tasten das zweite Wort, die zweiten 8 Tasten das erste Wort.
    Wenn das so funktioniert, nur die Taste K16 (...bei Dir DB100.DBX30.7) Probleme macht, dann denke ich das dieses Phänomen eventuell aus der Steuerung kommen kann. Guck mal über die Referenzdaten in der S7 ob eventuell DB100.DBX30.7 auch anderweitig beschrieben wird.

    Tritt dieses Phänomen immer reproduzierbar auf?

    Viele Grüße, Tobias
    Ein Experte ist ein Mensch, den man in letzter Minute hinzuzieht,
    um einen Mitschuldigen zu haben.

  5. #5
    Wilhelm ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    02.06.2005
    Beiträge
    300
    Danke
    23
    Erhielt 6 Danke für 6 Beiträge

    Standard

    Danke Lefrog auch diese imformatiom wird mir nicht weiterhelfen habe die Variablen weit getrennt. Dieser DBX 30.7 wird echt nirgendwo aufgerufen .
    Stehe auf dem so genannten Schlauch habe auch keine Erklärung dafür..
    Auch wenn ich ihn drehe DW 30 Dw 50 gleiches Problem
    Warum bleibt das letzte Bit gesetzt obwohl ich es nur taste die anderen funktionieren
    Stehe vor einem bitteren Rätsel

    sonnige Grüße
    Wilhelm

  6. #6
    Unreg Gast

    Standard

    Vielleicht Tastatur - Sammelbit ?

  7. #7
    Registriert seit
    02.02.2006
    Ort
    Hessen
    Beiträge
    429
    Danke
    16
    Erhielt 28 Danke für 22 Beiträge

    Standard

    Zitat Zitat von Unreg
    Vielleicht Tastatur - Sammelbit ?
    Hallo,

    wenn K16 auch noch funktionieren soll, muß der Bereichszeiger Funktionstasten länger sein als 2 Byte. Dann landet das Tastatur-Sammelbit woanders und stört nicht weiter. Allerdings belegt diese Methode auch mehr Platz im DB.
    mfG Werner
    Hoch lebe die Suchfunktion!
    Zitieren Zitieren Aber sicher  

  8. #8
    Wilhelm ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    02.06.2005
    Beiträge
    300
    Danke
    23
    Erhielt 6 Danke für 6 Beiträge

    Standard

    Klar habe doch ein ganzes Wort angelegt
    16 Bits muss doch funktionieren

  9. #9
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.752
    Danke
    323
    Erhielt 1.526 Danke für 1.286 Beiträge

    Standard

    Zitat Zitat von Wilhelm
    Klar habe doch ein ganzes Wort angelegt
    16 Bits muss doch funktionieren
    Gut keine Ahnung das letzt Siemens OP ist > 2 Jahre her,
    aber oben steht das du MEHR als 2 Byte (1 Wort) benötigst, wegen irgend einen Tastatur Sammelbit.
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  10. #10
    Registriert seit
    29.01.2005
    Beiträge
    277
    Danke
    4
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo!

    Wenn ich das richtig verstanden habe dann benötigen 16 Tasten 16Bit = 1 Wort. Nun wird aber noch ein Sammelbit benötigt, welches hinten dran hängt. Damit bleiben nur noch 15Bit für die Funktionstasten übrig, so dass das dritte Byte oder das zweite Wort benötigt wird - je nachdem in welchen Größenordnungen das eingestellt werden kann.

    Viele Grüße, Tobias
    Ein Experte ist ein Mensch, den man in letzter Minute hinzuzieht,
    um einen Mitschuldigen zu haben.

Ähnliche Themen

  1. OP17 an Profibus mit 2 CPU´s Problem!
    Von Christian_1989 im Forum HMI
    Antworten: 10
    Letzter Beitrag: 12.03.2011, 01:19
  2. Op17
    Von Wilhelm im Forum HMI
    Antworten: 4
    Letzter Beitrag: 31.01.2008, 22:19
  3. Antworten: 4
    Letzter Beitrag: 10.01.2006, 11:45
  4. OP17 DP
    Von Anonymous im Forum HMI
    Antworten: 4
    Letzter Beitrag: 14.10.2004, 09:57
  5. op17
    Von holle im Forum HMI
    Antworten: 2
    Letzter Beitrag: 30.03.2004, 22:53

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •