Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 8 von 9 ErsteErste ... 6789 LetzteLetzte
Ergebnis 71 bis 80 von 86

Thema: OP17 an PC und S5 100U Anschließen

  1. #71
    Registriert seit
    20.06.2003
    Ort
    Sauerland.NRW.Deutschland
    Beiträge
    4.862
    Danke
    78
    Erhielt 805 Danke für 548 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    länge des db
    Angehängte Grafiken Angehängte Grafiken
    .
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download

    Meine Definition von TIA: Total Inakzeptable Applikation

  2. #72
    Andy258 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    30.08.2006
    Beiträge
    221
    Danke
    12
    Erhielt 5 Danke für 5 Beiträge

    Standard

    Hab ich gemacht, ergab aber immer noch keine Änderung.

    Gruß
    Andreas

  3. #73
    Registriert seit
    30.03.2005
    Beiträge
    2.096
    Danke
    0
    Erhielt 673 Danke für 541 Beiträge

    Standard

    Welche CPU hast Du eigentlich? S5-100U mit CPU 100, 102 oder 103?

    Gruß Kai

  4. #74
    Registriert seit
    30.03.2005
    Beiträge
    2.096
    Danke
    0
    Erhielt 673 Danke für 541 Beiträge

    Standard

    Zitat Zitat von volker Beitrag anzeigen
    ohne den kommunikations-fb kann das ag keine kommunikation mit dem ag aufbauen.

    wenn du eine 100u hast, spiele das programm op17g1 ein
    wenn du eine 102u oder 103u hast, spiele das programm op17g2 ein
    Ich würde sagen, dass das so nicht ganz richtig ist.

    Laut Siemens gilt folgendes:

    Gruppe 1:

    AG 100U (CPU 100, CPU 102)

    Gruppe 2:

    AG 100U (CPU 103)

    Außerdem fehlt mir in Deinen beiden Programmbeispielen noch der Anlauf des Standard-FB im OB21/OB22:

    Gruppe1:

    OB21 / OB22

    :A DB 51
    :L KF 1
    :T DW 40

    Gruppe 2:

    OB21 / OB22

    :A DB 51
    :L KF 1
    :T DW 64

    Gruß Kai

  5. #75
    Registriert seit
    30.03.2005
    Beiträge
    2.096
    Danke
    0
    Erhielt 673 Danke für 541 Beiträge

    Standard

    Zitat Zitat von volker Beitrag anzeigen
    im op muss natürlich auch ein programm sein mit dem systembereichszeiger auf db53
    Das muss natürlich heißen:

    "im op muss natürlich auch ein programm sein mit dem systembereichszeiger auf db51"

    Gruß Kai

  6. #76
    Andy258 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    30.08.2006
    Beiträge
    221
    Danke
    12
    Erhielt 5 Danke für 5 Beiträge

    Standard

    Ich habe die 100U /100.
    Und was sollte ich da jetzt dann ändern, damit das funktioniert???

  7. #77
    Registriert seit
    30.03.2005
    Beiträge
    2.096
    Danke
    0
    Erhielt 673 Danke für 541 Beiträge

    Standard

    Die S5-100U CPU100 gehört zur Gruppe 1.

    Du brauchst also von Volker das Programm OP17G1 und erstellst noch zusätzlich einen OB21 (Anlauf AG bei manuellem Einschalten) und einen OB22 (Anlauf AG bei Spannungswiederkehr) mit folgendem Inhalt:

    OB21 / OB22

    :A DB 51
    :L KF 1
    :T DW 40

    Gruß Kai

  8. #78
    Registriert seit
    30.03.2005
    Beiträge
    2.096
    Danke
    0
    Erhielt 673 Danke für 541 Beiträge

    Standard

    Und im OP muss Dein Bereichszeiger für den Schnittstellenbereich natürlich die Adressen DB51 DW0 und die Länge (Worte) 255 haben (siehe Bild).

    Gruß Kai
    Angehängte Grafiken Angehängte Grafiken

  9. #79
    Registriert seit
    20.06.2003
    Ort
    Sauerland.NRW.Deutschland
    Beiträge
    4.862
    Danke
    78
    Erhielt 805 Danke für 548 Beiträge

    Standard

    ebend.
    in den progs die ich pepostet habe ist alles nötige drin.

    der ob21/22 ist nicht wirklich wichtig. der verursacht 'nur' einen neustart des op. macht es aber sowiso wenn keine verbinding zustande kommt.
    .
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download

    Meine Definition von TIA: Total Inakzeptable Applikation

  10. #80
    Andy258 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    30.08.2006
    Beiträge
    221
    Danke
    12
    Erhielt 5 Danke für 5 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Und an was kann es dann noch liegen, dass es nicht funktioniert??

Ähnliche Themen

  1. S0 an SPS anschließen
    Von roberthaidi im Forum Simatic
    Antworten: 25
    Letzter Beitrag: 07.06.2013, 07:34
  2. OP177B an S5 anschließen
    Von rkoe1 im Forum HMI
    Antworten: 2
    Letzter Beitrag: 12.03.2009, 12:22
  3. Vss+ Vss- Gnd anschließen
    Von Anaconda55 im Forum Elektronik
    Antworten: 49
    Letzter Beitrag: 28.10.2008, 12:39
  4. Lichtschranke an SPS anschließen
    Von caiptoncirk im Forum Elektronik
    Antworten: 15
    Letzter Beitrag: 08.05.2008, 09:05
  5. TP anschließen
    Von Anonymous im Forum HMI
    Antworten: 2
    Letzter Beitrag: 07.06.2005, 06:24

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •