Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 4 von 4

Thema: Probs mit Messageboxen unter WSH

  1. #1
    Registriert seit
    12.12.2004
    Beiträge
    55
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo liebes Forum

    ich habe eine Windows Scripting Host Datei geschrieben, die alle 2 Minuten in ein Log File schreibt, ob ein Programm läuft oder nicht. Sollte das Programm nicht laufen, da wird zusätzlich noch ein Fehler per Msgbox ausgegeben.
    Dabei ist mir aufgefallen, daß die Messagebox den Programmablauf so lange stoppt bis ich auf ok gedrückt habe. Gibt es noch eine andere Möglichkeit eine Meldung einfach auszugeben, ohne daß das Programm stoppt ??

    Vielen Dank
    Gruß Steffen
    Zitieren Zitieren Probs mit Messageboxen unter WSH  

  2. #2
    Registriert seit
    04.02.2007
    Beiträge
    2.544
    Danke
    167
    Erhielt 731 Danke für 528 Beiträge

    Standard

    Probier mal ob es mit Echo geht, (hab´s noch nicht probiert)

    wsript.echo "test"


    EDITH sagt !
    Nee geht auch nicht !

    EDIT2 sagt !
    Ruf ein zweites Script auf, das nur zur Aufgabe hat , die Anzeige zu machen !
    Geändert von jabba (19.06.2007 um 07:26 Uhr)

  3. Folgender Benutzer sagt Danke zu jabba für den nützlichen Beitrag:

    steffen21m (04.07.2007)

  4. #3
    Registriert seit
    24.05.2006
    Beiträge
    234
    Danke
    14
    Erhielt 77 Danke für 57 Beiträge

    Standard

    Um Scripte laufen zu lassen gibt es bei Windows zwei verschiedene Script-Hosts:

    WSCRIPT.EXE: Ist als "Windows"-Scripting Host vorgesehen (inkl Messageboxen bei "echo")
    und
    CSCRIPT.EXE: ist für die Kommandozeile vorgesehen (liefert die "echos" als blanke Textausgabe und wartet nicht auf Bestätigung)

    Welcher der beiden der Standard-Interpreter ist, kann über Cscript auf der Kommandozeile eingestellt werden. Hierzu einfach mal CScript.exe in einer Kommandozeile aufrufen, da sieht man dann die möglichen Parameter.

    Im Programm wird aber trotzdem immer wscript.echo "test" geschrieben.

  5. Folgender Benutzer sagt Danke zu hovonlo für den nützlichen Beitrag:

    steffen21m (04.07.2007)

  6. #4
    Registriert seit
    12.12.2004
    Beiträge
    55
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Danke für eure schnellen Antworten ...
    Habe alles so umgesetzt und es funzt

    Vielen vielen Dank

    Gruß Steffen

Ähnliche Themen

  1. Probs mit Profinet
    Von multixy im Forum Feldbusse
    Antworten: 7
    Letzter Beitrag: 09.10.2011, 10:38
  2. Profibus Probs mit ET200s (IM151-1)
    Von multixy im Forum Feldbusse
    Antworten: 22
    Letzter Beitrag: 03.09.2011, 15:52
  3. if then else unter awl ??
    Von prinz1978 im Forum Programmierstrategien
    Antworten: 14
    Letzter Beitrag: 23.07.2008, 15:25
  4. Easy Motion Control probs
    Von maniac im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 16.08.2007, 19:56
  5. cp440 und Kom-Probs
    Von floppy im Forum Feldbusse
    Antworten: 5
    Letzter Beitrag: 23.05.2007, 20:56

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •