Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: C#.net mit AGLink

  1. #1
    Registriert seit
    23.09.2005
    Beiträge
    17
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo miteinander,
    ich hoffe ich blamiere mich nicht zu sehr. Aber ich komme einfach nicht mehr weiter. Mein Ziel ist es mit C# und AGLink Daten aus einer S7 auszulesen. Mit Excel in VBA habe ich es schon hinbekommen. Die Einstellungen(beide Dlls in den System32 Ordner kopieren), die im Handbuch beschrieben sind, habe ich schon gemacht. Doch leider bekomme ich beim Aufrufen von PLCConnect immer die Rückmeldung „-1048573 Ungültige SPS Nummer“. Das Beispielprojekt im DotNet Ordner liefert die gleiche Fehlermeldung.
    Im Voraus vielen Dank
    Kobold
    Zitieren Zitieren C#.net mit AGLink  

  2. #2
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.235
    Danke
    640
    Erhielt 955 Danke für 769 Beiträge

    Standard

    Bei Aglink 4.x ist es wichtig, dass die Parameterdateien, z.B. AGLink40CfgDev0000.xml bei Device 0, gefunden werden. Wo liegen denn diese?
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

  3. #3
    Kobold ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    23.09.2005
    Beiträge
    17
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,

    zu erst einmal vielen Dank für die schnelle Antwort. Ich hab die "AGLink40CfgDev0000.xml" in den Debug-, in den System- und in den System32- Ordner gelegt. Aber alles ohne Erfolg. Immer der gleiche Fehler.

    Gruß
    Kobold

  4. #4
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.235
    Danke
    640
    Erhielt 955 Danke für 769 Beiträge

    Standard

    Da gibt es noch ein paar Möglichkeiten . Z.B. das Programm-Verzeichnis des Visual-Studios. Liegt die AGlink40.DLL im Debug-Verzeichnis? Liegt die XML im Debug-Verzeichnis? Ist das Arbeitsverzeichnis auch entsprechend eingestellt?
    Läuft das Programm bei Direktaufruf (=Doppelklick auf EXE) wenn in dessen Verzeichnis die DLLs und die XML-Dateien stehen?
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

  5. Folgender Benutzer sagt Danke zu Rainer Hönle für den nützlichen Beitrag:

    Kobold (10.10.2008)

  6. #5
    Kobold ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    23.09.2005
    Beiträge
    17
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    nochmals vielen Dank für die schnellen Antworten!
    Ich hatte ein anderes Problem, ich habe vergessen die iStdPlcNo richtig einzustellen. Jetzt funktioniert es .
    Ich habe jetzt allerdings noch eine weitere Frage. Ist es in der Demoversion in .Net nicht möglich auf den Diagnosepuffer zuzugreifen?
    Gruß
    Kobold
    Geändert von Kobold (21.10.2008 um 08:53 Uhr)

Ähnliche Themen

  1. SPS-->via BSEND-->AGlink
    Von amtek im Forum Hochsprachen - OPC
    Antworten: 1
    Letzter Beitrag: 01.06.2011, 11:49
  2. AGLink Qos
    Von ToSchum im Forum Programmierstrategien
    Antworten: 1
    Letzter Beitrag: 05.05.2011, 19:07
  3. S7-1200 aglink
    Von Matze001 im Forum HMI
    Antworten: 3
    Letzter Beitrag: 25.09.2010, 13:45
  4. Accon AGLink 4 und .net?
    Von mpexx im Forum Hochsprachen - OPC
    Antworten: 2
    Letzter Beitrag: 25.06.2008, 12:08
  5. AGLink mit C#
    Von raCotS im Forum Hochsprachen - OPC
    Antworten: 3
    Letzter Beitrag: 29.05.2008, 09:24

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •