Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 14

Thema: Frage zu Libnodave und Hardware

  1. #1
    Registriert seit
    29.03.2008
    Beiträge
    5
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich weis es ist ein leidiges thema und wurde auch schon oft besprochen...

    Bezüglich Libnodave wollte ich hier mal die Basics abklopfen, bzw. abklopfen lassen!!!

    Welche Hardware brauche ich seitens der S7?
    MPI und dann auf Com, oder kann ich vom Lean der S7 auch über TCP/IP (Ethernet)
    connecten. Wie sollten diese dann konfiguriert werden, und worauf sollte man achten...

    Ich denke einbindung von Libnodave und Nutzung, stellt glaube ich nach jetziger Sicht ein kleiners Problem dar.
    .dll Einbinden, Verbindung erstellen und dann sollte es funktionieren...

    Jedoch wenn der Verbindungsaufbau nicht funktionieren sollt, wie kann ich dann eine Fehlersuch am besten durchführen ob die Konfiguration korrekt ist....

    Wäre super wenn sich jemand hier kurz zeit nehmen kann und mir die Frage bzw. die informationen geben kann.

    mfg
    Zitieren Zitieren Frage zu Libnodave und Hardware  

  2. #2
    Registriert seit
    19.06.2005
    Ort
    in Bayern ganz oben
    Beiträge
    1.360
    Danke
    188
    Erhielt 372 Danke für 290 Beiträge

    Standard

    Hallo,

    Zitat Zitat von FC001 Beitrag anzeigen
    Welche Hardware brauche ich seitens der S7?
    MPI und dann auf Com, oder kann ich vom Lean der S7 auch über TCP/IP (Ethernet) connecten.
    Beides ist möglich.

    Zitat Zitat von FC001 Beitrag anzeigen
    Wie sollten diese dann konfiguriert werden, und worauf sollte man achten...
    Mit was willst Du programmieren? Delphi, C, VB, VBA (Excel, ...), ...?

    Ich finde die Beispiele eigentlich sehr schön Dokumentiert, an dieser stelle ein großes Lob an den Ersteller.

    Gruss Daniel
    Geändert von dalbi (18.07.2009 um 17:24 Uhr)
    Erfahrung ist eine nützliche Sache. Leider macht man sie immer erst kurz nachdem man sie brauchte...

    OSCAT.lib Step 7

    Open Source Community for Automation Technolgy

    SPS-Forum Chat (Mibbit) | SPS-Forum Chat (MIRC)

  3. #3
    FC001 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    29.03.2008
    Beiträge
    5
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    programmieren will ich das ganze in C#.

    Mir geht das um die konfiguration um beiden aufeinander abzustimmen.

    Gibt es Hardwareseitig etwas zu beachten?

  4. #4
    Registriert seit
    19.06.2005
    Ort
    in Bayern ganz oben
    Beiträge
    1.360
    Danke
    188
    Erhielt 372 Danke für 290 Beiträge

    Standard

    Zitat Zitat von FC001 Beitrag anzeigen
    programmieren will ich das ganze in C#.

    Mir geht das um die konfiguration um beiden aufeinander abzustimmen.

    Gibt es Hardwareseitig etwas zu beachten?
    Hallo,

    wie bereits geschrieben sind beide varianten möglich. Ich würde allerdings Ethernet bevorzugen wobei es über einen MPI-Adapter auch funktioniert.

    Mit C kenne ich mich leider überhaupt nicht aus, daher kann ich Dir auch nichts dazu sagen wie es unter C funktioniert.
    In der ZIP Datei sind allerdings viele fertige (+Quellcode) Beispiele dazu vorhanden.

    Gruss Daniel
    Erfahrung ist eine nützliche Sache. Leider macht man sie immer erst kurz nachdem man sie brauchte...

    OSCAT.lib Step 7

    Open Source Community for Automation Technolgy

    SPS-Forum Chat (Mibbit) | SPS-Forum Chat (MIRC)

  5. #5
    FC001 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    29.03.2008
    Beiträge
    5
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    brauch ich bei MPI einen speziellen Devicenetstecker, oder kann ich den ganz normalen MPI/USB Adapter von Siemens nehmen???

    Gibt es spezielle Gründe warum du ethernet bevorzugen würdest?

  6. #6
    Registriert seit
    19.06.2005
    Ort
    in Bayern ganz oben
    Beiträge
    1.360
    Danke
    188
    Erhielt 372 Danke für 290 Beiträge

    Standard

    Hallo,

    nein, eigentlich nur wegen der Geschwindigkeit ist bei größeren Datenmengen interessant. Der USB Adapter funktioniert natürlich auch.

    Gruss Daniel
    Erfahrung ist eine nützliche Sache. Leider macht man sie immer erst kurz nachdem man sie brauchte...

    OSCAT.lib Step 7

    Open Source Community for Automation Technolgy

    SPS-Forum Chat (Mibbit) | SPS-Forum Chat (MIRC)

  7. #7
    FC001 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    29.03.2008
    Beiträge
    5
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    werde mmich erstmal ran machen und loslegen, sollte ich fragen habe komme ich wieder....

    Danke erstmal..

  8. #8
    Registriert seit
    03.09.2008
    Beiträge
    48
    Danke
    7
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Geschwindigkeit ist erst ab einer 400er interessant darunter ist diese wohl leich da Ethernet bei der CP über den MPI Rückwandbus läuft. Ergo auch nur MPI geschwindigkeit. Bei einer 400er EthernetCP hast du dann schon 15-20 fache Kommleistung.

    Son 10kByte Block bei ner 300er dauert dann schon so 2sec.

    Gruß Key

  9. #9
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.224
    Danke
    630
    Erhielt 955 Danke für 769 Beiträge

    Standard

    Zitat Zitat von Key Beitrag anzeigen
    Geschwindigkeit ist erst ab einer 400er interessant darunter ist diese wohl leich da Ethernet bei der CP über den MPI Rückwandbus läuft. Ergo auch nur MPI geschwindigkeit. Bei einer 400er EthernetCP hast du dann schon 15-20 fache Kommleistung.

    Son 10kByte Block bei ner 300er dauert dann schon so 2sec.

    Gruß Key
    Da spielen noch andere Faktoren mit. Das MPI-Protokoll unterscheidet sich vom IE-Protokoll. Bei IE fallen einige Ping-Pong-Spiele weg, die ebenfalls Zeit kosten. Die gleichen Bitrate bedeutet noch lange nicht den gleichen Datendurchsatz. Auf einer CP arbeitet ein eigener Prozessor, MPI wird in der Regel vom CPU-Prozessor mitgemacht. Bei 300er mit PN ist der Durchsatz (bei kleinen Zykluszeiten) deutlich größer als über eine separate CP etc.
    Performance in der Kommunikation ist allerdings ein abendfüllendes Thema.
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

  10. #10
    Registriert seit
    11.06.2004
    Beiträge
    100
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo da hätte ich auch noch eine Frage an die Spezialisten

    Ich nutze Libnodave mit Excel und einer 315 2DP/PN hier funktioniert die Verbindung optimal (TCP/IP).
    Nun möchte ich auch eine 315 2DP mit CP343-1 IT mit Libnodave und Excel ansprechen allerdings kann ich in diesem Fall keine Verbindung aufbauen(TCP/IP).
    Kann mir da jemand weiterhelfen?
    Zitieren Zitieren PN oder CP was mache ich falsch  

Ähnliche Themen

  1. Hardware Frage zu SM331/322 64
    Von babylon05 im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 21.11.2010, 18:24
  2. Antworten: 2
    Letzter Beitrag: 25.03.2010, 21:18
  3. Hardware Frage
    Von MarioDisketti im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 15.08.2008, 14:24
  4. Frage zur Hardware
    Von ralfm im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 17.03.2005, 14:31
  5. Hardware-Zusammenstellungs-Frage -> S7
    Von Nachbar im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 10.11.2003, 12:02

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •