Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: Libnodave mit C7 626

  1. #1
    Registriert seit
    27.05.2006
    Beiträge
    188
    Danke
    0
    Erhielt 9 Danke für 9 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    habe gerade probiert mich über IHB Link mit eine C7 626 zu verbinden. Geht nicht! Eine Verbindung zu S7 315 mit gleichem Link funktioniert problemlos. Es ist ein Programm zu Datenerfassung wo Libnodave benutzt wird. Habe selber geschrieben. Funktioniert Libnodave mit C7 überhaupt?

    Viele Grüße
    Pikador
    Zitieren Zitieren Libnodave mit C7 626  

  2. #2
    Registriert seit
    07.10.2008
    Beiträge
    78
    Danke
    1
    Erhielt 15 Danke für 15 Beiträge

    Standard

    Könnte es sein, das die MPI Adresse deines Adapters auf der gleichen Adresse wie z.B. das integrierte OP steht ?

  3. #3
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard

    Zitat Zitat von Pikador Beitrag anzeigen
    Funktioniert Libnodave mit C7 überhaupt?
    Ja.

    Kommst du mit der IBH Software auf die Steuerung?
    Kannst du den Teilnehmer suchen und wird dieser gefunden?
    Wenn ja, dann bei dem Testprogramm von zottel nur die Adresse und Baudrate übergeben und das flutscht.
    Wenn du selber etwas geschrieben hast, schau im Debug Modus welche Meldung du beim Verbindungsaufbau zurückbekommst.


    bike
    Geändert von bike (13.04.2010 um 10:51 Uhr)

  4. #4
    Pikador ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    27.05.2006
    Beiträge
    188
    Danke
    0
    Erhielt 9 Danke für 9 Beiträge

    Standard

    Hallo,

    mit IBH Software kriege ich die Verbindung, auch mit Step 7.
    Mit meinem Programm aber nicht. Wenn ich den IBH link auf eine 315 CPU umstecke habe ich sofort die Verbindung. Nur an der C7 nicht.

  5. #5
    Pikador ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    27.05.2006
    Beiträge
    188
    Danke
    0
    Erhielt 9 Danke für 9 Beiträge

    Standard

    Die MPI Adresse von dem Linki ist 0.

  6. #6
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard

    Zitat Zitat von Pikador Beitrag anzeigen
    Hallo,

    mit IBH Software kriege ich die Verbindung, auch mit Step 7.
    Mit meinem Programm aber nicht. Wenn ich den IBH link auf eine 315 CPU umstecke habe ich sofort die Verbindung. Nur an der C7 nicht.
    Du bekommst die Verbindung zu C7 mit dem Adapter aus Step7 und mit der IBH Software?
    Oder nur zu der 315 er?
    Wenn du auf die C7 kommst mit Step7, versuch das Testprogramm das bei libnodave dabei ist.

    bike

  7. #7
    Pikador ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    27.05.2006
    Beiträge
    188
    Danke
    0
    Erhielt 9 Danke für 9 Beiträge

    Standard

    Zu 315 funktioniert die Verbindung mit Step 7 und IBH Link und auch mit Libnodave und IBH Link.
    Zu C7 funktioniert die Verbindung mit Step 7 und IBH Link, nicht aber mit Libnodave und IBH Link.

    Mit dem Test Programm bekomme ich volgende Meldung:

    openSocketw.c: bind Socket error: No error
    openSocketw.c: Connected to host: 10.81.215.65
    ConnectPLC
    trying next ID:
    Couldn't connect to PLC.

    Jedes mal wird gleiche IBH Link benutzt. Ich habe es an 3 C7 Steuerungen
    ausprobiert.

    Viele Grüße

  8. #8
    Pikador ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    27.05.2006
    Beiträge
    188
    Danke
    0
    Erhielt 9 Danke für 9 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Habe festgestellt, dass die Funktion connectPLC() mir eine -5 liefert. Was kann es sein?

Ähnliche Themen

  1. Antworten: 0
    Letzter Beitrag: 09.09.2010, 00:27
  2. ÄÖnderungen am libnodave.net.cs File von libnodave
    Von Jochen Kühner im Forum Hochsprachen - OPC
    Antworten: 5
    Letzter Beitrag: 12.05.2010, 16:56
  3. LibNoDave unter VB.Net ohne libnodave.net.dll
    Von Earny im Forum Hochsprachen - OPC
    Antworten: 2
    Letzter Beitrag: 09.03.2010, 18:57
  4. libnodave: Woher kommt die "libnodave.net.dll"?
    Von Thomas_v2.1 im Forum Hochsprachen - OPC
    Antworten: 2
    Letzter Beitrag: 10.11.2008, 12:07
  5. VB.Net und Libnodave
    Von oliverlorenz im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 07.05.2008, 10:54

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •