Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: Aglink und NetLinkPro Family mit Routing...

  1. #1
    Registriert seit
    17.06.2004
    Ort
    Offenau
    Beiträge
    3.746
    Danke
    209
    Erhielt 421 Danke für 338 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Bin gerade dabei diesen Adapter in LibNoDave zu implementieren, und dabei ist mir aufgefallen das mit AGLink Routing mit diesem Adapter nicht funktioniert.

    Ich denke das Problem liegt im 3ten Telegramm zum Netlink, Step 7 sendet da im 4 Byte 86 bei Routing und 82 bei nicht Routing. AGLink sendet immer 82...

    Falls jemand von Deltalogic zusieht...

    Mfg.
    ---------------------------------------------
    Jochen Kühner
    https://github.com/jogibear9988/DotN...ToolBoxLibrary - Bibliothek zur Kommunikation mit PLCs und zum öffnen von Step 5/7 Projekten
    Zitieren Zitieren Aglink und NetLinkPro Family mit Routing...  

  2. #2
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.224
    Danke
    630
    Erhielt 955 Danke für 769 Beiträge

    Standard

    Sicher schau ich zu
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

  3. #3
    Registriert seit
    17.06.2004
    Ort
    Offenau
    Beiträge
    3.746
    Danke
    209
    Erhielt 421 Danke für 338 Beiträge

    Standard

    Zitat Zitat von Rainer Hönle Beitrag anzeigen
    Sicher schau ich zu
    So hab Ichs ja gemeint, solltet Ihr mal prüfen, bei mir ging's jedenfalls nicht...
    ---------------------------------------------
    Jochen Kühner
    https://github.com/jogibear9988/DotN...ToolBoxLibrary - Bibliothek zur Kommunikation mit PLCs und zum öffnen von Step 5/7 Projekten

  4. #4
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.224
    Danke
    630
    Erhielt 955 Danke für 769 Beiträge

    Standard

    Zitat Zitat von Jochen Kühner Beitrag anzeigen
    So hab Ichs ja gemeint, solltet Ihr mal prüfen, bei mir ging's jedenfalls nicht...
    Selbstverständlich werde ich das prüfen. Wie war denn der genaue Aufbau (welche SPS hingen wie zusammen und wurden über welchen Weg angesprochen)? Woher kommen die Daten der S7-Software, d.h. mit welchem Adapter wurden die ermittelt?
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

  5. #5
    Registriert seit
    17.06.2004
    Ort
    Offenau
    Beiträge
    3.746
    Danke
    209
    Erhielt 421 Danke für 338 Beiträge

    Standard

    Netlink an 315er CPU diese ist per LAN mit einer 400er Verbunden.

    Über Step 7 bin Ich auf die 400er gekommen, über die AcconAgLink Config Software nicht!

    Daten habe Ich mit Wireshark aufgezeichnet.

    Die ersten 2 Telegramme an den NL waren mit Step 7 und Aglink identisch, beim dritten war dann ein Byte unterschiedlich...
    ---------------------------------------------
    Jochen Kühner
    https://github.com/jogibear9988/DotN...ToolBoxLibrary - Bibliothek zur Kommunikation mit PLCs und zum öffnen von Step 5/7 Projekten

  6. Folgender Benutzer sagt Danke zu Jochen Kühner für den nützlichen Beitrag:

    Rainer Hönle (18.06.2010)

  7. #6
    Registriert seit
    17.06.2004
    Ort
    Offenau
    Beiträge
    3.746
    Danke
    209
    Erhielt 421 Danke für 338 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Denke Ich habe das Problem gefunden... War mein Fehler, um auf eine CPU zu Routen über einen CPU wenn Ich mit AGLink auf dem MPI Bus bin muss Ich nicht die MPI Adresse der CPU, sondern des CPs angeben... Dann funktionierts...
    ---------------------------------------------
    Jochen Kühner
    https://github.com/jogibear9988/DotN...ToolBoxLibrary - Bibliothek zur Kommunikation mit PLCs und zum öffnen von Step 5/7 Projekten
    Zitieren Zitieren Sorry...  

Ähnliche Themen

  1. Antworten: 1
    Letzter Beitrag: 10.08.2011, 09:53
  2. Antworten: 6
    Letzter Beitrag: 27.05.2011, 07:51
  3. Accon-NetlinkPro
    Von Ralle im Forum Simatic
    Antworten: 18
    Letzter Beitrag: 01.09.2010, 20:32
  4. Routing über TCP/IP mit Aglink
    Von Jochen Kühner im Forum Hochsprachen - OPC
    Antworten: 0
    Letzter Beitrag: 16.06.2010, 08:33
  5. Libnodave und NetlinkPro
    Von Ralle im Forum Hochsprachen - OPC
    Antworten: 14
    Letzter Beitrag: 02.03.2007, 11:16

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •