Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 3 ErsteErste 123 LetzteLetzte
Ergebnis 11 bis 20 von 22

Thema: Debug-Infos von LibNoDave deaktivieren?

  1. #11
    muhmann ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    09.07.2010
    Beiträge
    14
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Danke Jochen.

    Aber was mich stutzig macht, meine Dateien sind mit deinen absolut identisch. Mit dem Unterschied, dass ich anstatt VS 9.0, 10.0 benutze und das auch entsprechend als Pfad eingetragen habe. Ich kann die Dateien dennoch nicht erstellen

    Edit:
    Ok, hat sich erledigt. Jetzt funktioniert es. Man muss die Visual Studio Eingabeaufforderung benutzen, erst dann funktioniert es.
    Geändert von muhmann (01.09.2010 um 20:10 Uhr)

  2. #12
    Registriert seit
    17.06.2004
    Ort
    Offenau
    Beiträge
    3.745
    Danke
    209
    Erhielt 421 Danke für 338 Beiträge

    Standard

    Zitat Zitat von muhmann Beitrag anzeigen
    Danke Jochen.

    Aber was mich stutzig macht, meine Dateien sind mit deinen absolut identisch. Mit dem Unterschied, dass ich anstatt VS 9.0, 10.0 benutze und das auch entsprechend als Pfad eingetragen habe. Ich kann die Dateien dennoch nicht erstellen

    Edit:
    Ok, hat sich erledigt. Jetzt funktioniert es. Man muss die Visual Studio Eingabeaufforderung benutzen, erst dann funktioniert es.
    Entweder das, oder du rufst "vcvarsall.bat" von VS2010 auf!
    ---------------------------------------------
    Jochen Kühner
    https://github.com/jogibear9988/DotN...ToolBoxLibrary - Bibliothek zur Kommunikation mit PLCs und zum öffnen von Step 5/7 Projekten

  3. #13
    muhmann ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    09.07.2010
    Beiträge
    14
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Lustigerweise hatte ich bereits vcvarsall.bat ausgeführt. Sogar mehrfach. Hat dennoch nicht funktioniert, nur in der VS Eingabeaufforderung funktionierte es. Womöglich ist bei der Installation von VS etwas schiefgelaufen, so dass er nicht alle Umgebungsvariablen korrekt setzen konnte, oder sowas in der Art

  4. #14
    Registriert seit
    08.09.2009
    Beiträge
    14
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,

    Beschäftige mich gerade mit diesem Thema und habe jetzt die Quellcodes von Jochen übernommen.

    Allerdings erhalte ich beim ausführen von vcwinmake2.bat folgende Meldung:

    MAKEFILE.VC(81) : fatal error U1034: Syntaxfehler: Trennzeichen fehlt
    Stop.
    Weis da jemand rat? Ich kenne mich mit der Syntax von dem Makefile nicht aus.
    Zitieren Zitieren Syntax Error  

  5. #15
    Registriert seit
    17.06.2004
    Ort
    Offenau
    Beiträge
    3.745
    Danke
    209
    Erhielt 421 Danke für 338 Beiträge

    Standard

    Bei den Makefiles sind auch Tabs enthalten, diese sind wichtig...

    Häng dir mal mein makefile hier an...
    Angehängte Dateien Angehängte Dateien
    ---------------------------------------------
    Jochen Kühner
    https://github.com/jogibear9988/DotN...ToolBoxLibrary - Bibliothek zur Kommunikation mit PLCs und zum öffnen von Step 5/7 Projekten

  6. #16
    Registriert seit
    08.09.2009
    Beiträge
    14
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke das hat mich ein kleines Stück weitergebracht.

    Ich komme jetzt allerdings auf diese Ausgabe.

    vcwinmake2.bat
    "C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin\cl" -I"C:\Pro
    gram Files (x86)\Microsoft Visual Studio 9.0\VC\include" -I"C:\Program Files (x8
    6)\Microsoft SDKs\Windows\v7.0A\include" -c -DBCCWIN -DDAVE_LITTLE_ENDIAN -TC -D
    DOEXPORT nodave.c
    NMAKE : fatal error U1077: ""C:\Program Files (x86)\Microsoft Visual Studio 9.0\
    VC\bin\cl.EXE"": Rückgabe-Code "0xc0000135"
    Stop.
    vcwinmake1.bat gibt mir allerdings auch dieses aus:
    G:\Downloads\libnodave\libnodave>"G:\Program Files (x86)\Microsoft Visual Studio
    10.0\VC\vcvarsall.bat"
    Setting environment for using Microsoft Visual Studio 2010 x86 tools.
    \PKWARE\pkzipc";C:\Program Files (x86)\Microsoft SQL Server\100\Tools\Binn\;C:\P
    rogram Files\Microsoft SQL Server\100\Tools\Binn\;C:\Program Files\Microsoft SQL
    Server\100\DTS\Binn\" was unexpected at this time.
    Was stimmt jetzt schon wieder nicht?

  7. #17
    Registriert seit
    17.06.2004
    Ort
    Offenau
    Beiträge
    3.745
    Danke
    209
    Erhielt 421 Danke für 338 Beiträge

    Standard

    Zitat Zitat von Ragnaroek18 Beitrag anzeigen
    Danke das hat mich ein kleines Stück weitergebracht.

    Ich komme jetzt allerdings auf diese Ausgabe.

    vcwinmake2.bat


    vcwinmake1.bat gibt mir allerdings auch dieses aus:


    Was stimmt jetzt schon wieder nicht?
    Du musst halt mal sehen, ob die Pfade in dem Makefile überhaupt zu denen auf deinem System passen.
    ---------------------------------------------
    Jochen Kühner
    https://github.com/jogibear9988/DotN...ToolBoxLibrary - Bibliothek zur Kommunikation mit PLCs und zum öffnen von Step 5/7 Projekten

  8. #18
    Registriert seit
    08.09.2009
    Beiträge
    14
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard

    VCPATH=d:\programme\microsoft visual C++ Toolkit 2003
    SDKPATH=d:\programme\microsoft platform sdk

    VCPATH=G:\Program Files (x86)\Microsoft Visual Studio 10.0\VC
    SDKPATH=C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0A
    Also die letzten beiden Zeilen passen zu meinem System, habe ich angepasst.
    Allerdings kann ich für die ersten beiden Zeilen keine passenden Einträge finden.

    Muss ich die noch installieren?

  9. #19
    Registriert seit
    08.09.2009
    Beiträge
    14
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Scheint auch nicht zu funktionieren. Bekomme immer noch den gleichen Fehler.

    Hab jetzt in einem anderen Forum gelesen:

    I got this error when I am using a 32 bit lib.
    I resolved this by setting the environment variable "lib" to point to a 64 bit lib dir as below.
    C:\Program Files\Microsoft SDKs\Windows\v6.0A\Lib\x64
    set lib=C:\Program Files\Microsoft SDKs\Windows\v6.0A\Lib\x64;your/other/lib
    hope this helps.
    Ich benutze auch ein win7 64 Bit. Wo muss ich dann den oben genannten Befehl einfügen um es auszuprobieren?

    In den gleichen Forum wurde auch betont das vcvarsall.bat vorher ausgeführt werden muss. Aber das habe ich ja mit vcwinmake1.bat erledigt.

  10. #20
    Registriert seit
    17.06.2004
    Ort
    Offenau
    Beiträge
    3.745
    Danke
    209
    Erhielt 421 Danke für 338 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Unter Win64 hab Ich keine Erfahrung. Willst du den eine 64Bit Lib oder 32 Bit?

    Bei

    VCPATH=G:\Program Files (x86)\Microsoft Visual Studio 10.0\VC
    SDKPATH=C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0A

    sind nur die letzten 2 Interessant, die ersten werden davon überschrieben (hab die nur nicht rausgelöscht!)
    ---------------------------------------------
    Jochen Kühner
    https://github.com/jogibear9988/DotN...ToolBoxLibrary - Bibliothek zur Kommunikation mit PLCs und zum öffnen von Step 5/7 Projekten

Ähnliche Themen

  1. SCL gibt Fehler wegen debug info aus
    Von Bensen83 im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 22.01.2017, 22:32
  2. Antworten: 11
    Letzter Beitrag: 23.04.2009, 12:42
  3. SCL Debug
    Von Rose im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 03.07.2008, 10:23
  4. Schreibweise SCL Debug Info...
    Von AndreK im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 19.03.2008, 08:43
  5. Antworten: 0
    Letzter Beitrag: 27.01.2005, 16:27

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •