Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: LibNoDave und Verbindung zu IBH-SoftSps in VMware

  1. #1
    Registriert seit
    20.05.2009
    Beiträge
    32
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich habe folgendes Szenario:

    Win7 Professional 64bit Rechner
    Darauf in VMware ein WinXP-Prof. 32bit mit IBH-SoftSps

    Ich möchte nun mit LibNoDave über TCP/IP eine Kommunikation zur SoftSps vom Host (Win7) zum Guest (WinXP mit SoftSps) herstellen.

    Wenn ich es richtig verstanden habe, muss ich ISOonTCP auswählen. Folgende Ausgabe kommt von testISO_TCP.exe:

    .5\win>testiso_tcp -w -d 192.168.1.101
    openSocketw.c: enter OpenSocket
    openSocketw.c: 1
    openSocketw.c: 2 6600
    openSocketw.c: peer:192.168.1.101=1694607552
    openSocketw.c: 6
    openSocketw.c: 7
    openSocketw.c: socket is 156
    openSocketw.c: setsockopt No error 0
    openSocketw.c: 8
    openSocketw.c: bind Socket error: No error
    openSocketw.c: Connected to host: 192.168.1.101
    send packet: :
    0:0x03,0x00,0x00,0x16,0x11,0xE0,0x00,0x00,0x00,0x01,0x00,0xC1,0x02,0x01,0x00,0xC
    2,
    10:0x02,0x01,0x02,0xC0,0x01,0x09,
    timeout in ReadISOPacket.
    IF1 daveConnectPLC() step 1. got packet: :
    IF1 error in daveConnectPLC() step 1. retrying...timeout in ReadISOPacket.
    IF1 daveConnectPLC() step 1. got packet: :
    IF1 error in daveConnectPLC() step 1. retrying...timeout in ReadISOPacket.
    IF1 daveConnectPLC() step 1. got packet: :
    IF1 error in daveConnectPLC() step 1. retrying...Couldn't connect to PLC.
    Please make sure you use the -2 option with a CP243 but not with CPs 343 or 443
    .

    Und dazu passend die Aufzeichnung der Pakete auf dem WinXP-System mit der Soft-SPS:



    Wie man sieht, wird die Verbindung zurückgesetzt. Hat jemand eine Idee woran das liegen könnte? Oder mache ich grundsätzlich was falsch?

    Danke für Eure Hinweise....
    Wenn die Klügeren immer nachgeben, geschieht nur das, was die Dummen wollen
    Zitieren Zitieren LibNoDave und Verbindung zu IBH-SoftSps in VMware  

  2. #2
    Registriert seit
    20.12.2007
    Beiträge
    23
    Danke
    0
    Erhielt 10 Danke für 9 Beiträge

    Standard

    Ich habe das gerade probiert, bei mir funktioniert die Verbindung einwandfrei.

    Die CP343-Emulation muss in der SoftSPS aktiviert sein. Außerdem musst du sicherstellen, dass der Port 102 nicht bereits von einem anderen Programm auf deinem Rechner belegt ist. Das kannst du beispielsweise mit dem Tool "tcpview.exe" von sysinternals.com herausfinden.

    Gruß
    dj999

  3. Folgender Benutzer sagt Danke zu dj999 für den nützlichen Beitrag:

    Manni01 (31.01.2011)

  4. #3
    Registriert seit
    20.05.2009
    Beiträge
    32
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Besten Dank für den Tipp! Nun geht's. Und jetzt, wo ich es mir richtig überlege, hatte ich das Problem schon einmal vor 2 Jahren:

    Der Port 102 wird frecherweise von einem Siemens Prozess belegt:

    C:\Programme\Gemeinsame Dateien\Siemens\S7IEPG\s7oiehsx.exe
    "SIMATIC IEPG Help Service"

    Lösung:
    Soft-SPS beenden
    Den Siemens-Dienst beenden
    Soft-SPS wieder starten

    Weiß jemand wozu dieser Dienst benötigt wird, bzw. warum der Port 102 belegt?
    Wenn die Klügeren immer nachgeben, geschieht nur das, was die Dummen wollen
    Zitieren Zitieren Funkioniert!  

  5. #4
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.224
    Danke
    630
    Erhielt 955 Danke für 769 Beiträge

    Standard

    Zitat Zitat von Manni01 Beitrag anzeigen
    Weiß jemand wozu dieser Dienst benötigt wird, bzw. warum der Port 102 belegt?
    1. Siemens-Gebot: Du sollst keine andere SoftSPS haben neben WinAC
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

  6. #5
    Registriert seit
    29.03.2004
    Beiträge
    5.735
    Danke
    143
    Erhielt 1.685 Danke für 1.225 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Rainer Hönle Beitrag anzeigen
    1. Siemens-Gebot: Du sollst keine andere SoftSPS haben neben WinAC
    Und seit der Step 7 5.5 ist der Dienst sogar noch penetranter geworden. Wenn ich bei mir den Dienst stoppe, startet Step 7 garnicht mehr - keine Fehlermeldung, nix.
    Nachdem Step 7 gestartet ist kann man ihn aber ohne Probleme beenden.

Ähnliche Themen

  1. Mit VMware keine Ethernet Verbindung
    Von ChristianP im Forum Simatic
    Antworten: 15
    Letzter Beitrag: 10.10.2011, 08:24
  2. Libnodave + Verbindung CPU
    Von Proxy im Forum Hochsprachen - OPC
    Antworten: 1
    Letzter Beitrag: 19.03.2011, 18:04
  3. VMware player ohne VMware Workstation.
    Von JesperMP im Forum PC- und Netzwerktechnik
    Antworten: 5
    Letzter Beitrag: 11.12.2010, 10:40
  4. LibNoDave und SoftSPS
    Von GvOdin im Forum Hochsprachen - OPC
    Antworten: 2
    Letzter Beitrag: 26.01.2007, 07:10
  5. libnodave und softSPS
    Von renid55 im Forum Hochsprachen - OPC
    Antworten: 12
    Letzter Beitrag: 16.11.2005, 23:02

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •