Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 3 123 LetzteLetzte
Ergebnis 1 bis 10 von 23

Thema: CP343-1 Lean Verbindung zu PC

  1. #1
    Registriert seit
    19.06.2003
    Ort
    Im Staub ...
    Beiträge
    337
    Danke
    115
    Erhielt 26 Danke für 23 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hi,

    habe hier eine S7 315-2DP mit einer CP343-1 Lean.
    Die Lean hat über Ethernet Verbindung zu einem PC.
    Sie ist auf aktiven Verbindungaufbau eingestellt, der PC (Socket-Verbindung) auf passiven Verbindungsaufbau.
    Alles funktioniert soweit.

    Unsere Informatiker wollen, dass alle IP Adressen per DHCP bezogen werden.
    Wenn ich in den Objekteigenschaften der Lean 'IP-Adresse von einem DHCP-Server beziehen' einstelle, kommt die Meldung ... (siehe Bild).

    Was muss ich einstellen, um das ganze per DHCP geregelt zu bekommen?

    Danke für Eure Hilfe.

    Gruß
    Angehängte Grafiken Angehängte Grafiken
    • Dateityp: jpg B1.JPG (15,0 KB, 154x aufgerufen)
    Zitieren Zitieren CP343-1 Lean Verbindung zu PC  

  2. #2
    Registriert seit
    23.04.2009
    Ort
    Allgäu
    Beiträge
    3.042
    Danke
    241
    Erhielt 863 Danke für 617 Beiträge

    Standard

    Zitat Zitat von ssound1de Beitrag anzeigen
    Unsere Informatiker wollen, dass alle IP Adressen per DHCP bezogen werden.
    Das wird so nicht gehen.
    Gruß
    Paule
    ----------------------------------------------------------------------------
    > manchmal verliert man und manchmal gewinnen die anderen <

  3. #3
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    Zitat Zitat von Paule Beitrag anzeigen
    Das wird so nicht gehen.
    und ist zudem auch noch nicht praktikabel...

    erklär ihnen (den informatikerinnen), dass das DHCP-gehabe in einer produktiven umgebung nichts zu suchen hat. es geht um zugriffszeiten und sichere identifikation der einzelnen geräte...
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  4. Folgender Benutzer sagt Danke zu vierlagig für den nützlichen Beitrag:

    ssound1de (11.07.2011)

  5. #4
    Avatar von ssound1de
    ssound1de ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    19.06.2003
    Ort
    Im Staub ...
    Beiträge
    337
    Danke
    115
    Erhielt 26 Danke für 23 Beiträge

    Standard

    Sorry - hab noch was vergessen.
    Die IP-Adressen sollen zwar per DHCP bezogen werden, werden aber von der Informatik für die Lean und den PC reserviert, so dass an das jeweilige Gerät immer dieselbe IP vergeben wird.

    Ursache liegt scheinbar darin, dass Geräte mit fester IP (also ohne DHCP-Vergabe) keinen Eintrag in der Client-Liste des Servers hinterlassen.
    Da bei uns gerade diverse neue Geräte installiert werden, gab es IP-Adressen Konflikte (könnte natürlich auch in Zukunft wieder passieren).
    Oder erzählen die Informatiker hier Grütze?

    Keine Chance für DHCP bei der Lean?
    Die Funktion wird ja angeboten ...
    Geändert von ssound1de (07.07.2011 um 09:04 Uhr)

  6. #5
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    Zitat Zitat von ssound1de Beitrag anzeigen
    Sorry - hab noch was vergessen.
    Die IP-Adressen sollen zwar per DHCP bezogen werden, werden aber von der Informatik für die Lean und den PC reserviert, so dass an das jeweilige Gerät immer dieselbe IP vergeben wird.

    Ursache liegt scheinbar darin, dass Geräte mit fester IP (also ohne DHCP-Vergabe) keinen Eintrag in der Client-Liste des Servers hinterlassen.
    Da bei uns gerade diverse neue Geräte installiert werden, gab es IP-Adressen Konflikte (könnte natürlich auch in Zukunft wieder passieren).
    Oder erzählen die Informatiker hier Grütze?

    Keine Chance für DHCP bei der Lean?
    Die Funktion wird ja angeboten ...
    DHCP bei Lean funktioniert. Die bekommt halt bei einem neuen release wieder die selbe reservierte IP-Adresse. Ist in der HardwareConfig alles richtig eingetragen?
    Was funzt denn nicht?

  7. #6
    Registriert seit
    01.11.2010
    Ort
    Linker Niederrhein
    Beiträge
    52
    Danke
    4
    Erhielt 13 Danke für 11 Beiträge

    Standard



    Wie der Fehler schon beschreibt liegt es nicht an der Karte sondern an den Verbindungen !
    Du hast Iso on TCP Verbindungen projektiert mit festen IP Adressen und soweit ich es richtig verstanden habe gehen diese Verbindungen mit DHCP nicht ueberein, du musst diese umprojektieren zu ISO-Transport oder S7Verbindungen da diese dann ueber die MAC Adresse bzw. der eindeutigen Symbolik auf die Geraete eindeutig zugreifen.

    Groetjes

    Roland

  8. #7
    Avatar von ssound1de
    ssound1de ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    19.06.2003
    Ort
    Im Staub ...
    Beiträge
    337
    Danke
    115
    Erhielt 26 Danke für 23 Beiträge

    Standard

    Zitat Zitat von S7Roland Beitrag anzeigen


    Wie der Fehler schon beschreibt liegt es nicht an der Karte sondern an den Verbindungen !
    Du hast Iso on TCP Verbindungen projektiert mit festen IP Adressen und soweit ich es richtig verstanden habe gehen diese Verbindungen mit DHCP nicht ueberein, du musst diese umprojektieren zu ISO-Transport oder S7Verbindungen da diese dann ueber die MAC Adresse bzw. der eindeutigen Symbolik auf die Geraete eindeutig zugreifen.

    Groetjes

    Roland
    Nicht ganz ...
    Hab die Projektierung mal angehängt.
    Bild 1+2 zeigt die in der CPU projektierte Verbindung.
    Bild 3-5 die Projektierung des Lean.

    Wenn ich jetzt in Bild 3 auf DHCP umstelle, kommt die besagte Meldung.
    Angehängte Grafiken Angehängte Grafiken
    • Dateityp: jpg B1.JPG (25,9 KB, 132x aufgerufen)
    • Dateityp: jpg B2.JPG (21,0 KB, 128x aufgerufen)
    • Dateityp: jpg B3.JPG (26,7 KB, 47x aufgerufen)
    • Dateityp: jpg B4.JPG (28,0 KB, 45x aufgerufen)
    • Dateityp: jpg B5.JPG (26,3 KB, 45x aufgerufen)

  9. #8
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    Hmm...

    Fest zugewiesene IP-Adresse in der Config --->und dann auf DHCP?
    müßte die feste IP nicht rausfliegen?

  10. #9
    Avatar von ssound1de
    ssound1de ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    19.06.2003
    Ort
    Im Staub ...
    Beiträge
    337
    Danke
    115
    Erhielt 26 Danke für 23 Beiträge

    Standard

    Zitat Zitat von Verpolt Beitrag anzeigen
    Hmm...

    Fest zugewiesene IP-Adresse in der Config --->und dann auf DHCP?
    müßte die feste IP nicht rausfliegen?
    Wäre logisch ... passiert aber nicht.
    Wenn man die IP dann aus den entsprechenden Dialogen wenigstens löschen könnte - geht aber nicht.

  11. #10
    Registriert seit
    01.11.2010
    Ort
    Linker Niederrhein
    Beiträge
    52
    Danke
    4
    Erhielt 13 Danke für 11 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren


    siehe da TCP Verbindung



    feste IP Adressen

    Das geht so nicht und deshalb die Fehlermeldung!

    Ich habe auch eine Lean Karte (so nen Driss ) und kann Dir im Moment noch keine Loesung anbieten, aber ich wuerede es so probieren das ich mal ein neues Test Projekt anlege und damit versuchen erst alles auf DHCP einstellen und dann erst die Verbindungen in NetPro anlegen ?!

    Groetjes

    siehe Anhaenge
    Angehängte Grafiken Angehängte Grafiken
    Geändert von S7Roland (08.07.2011 um 11:57 Uhr) Grund: erweiterung

Ähnliche Themen

  1. Verbindung zu S7 CPU 314 CP343-1 Lean
    Von ditj_vitja im Forum Simatic
    Antworten: 12
    Letzter Beitrag: 17.09.2010, 16:40
  2. CP343-1 lean CP343-1 Lean
    Von M.R. im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 04.06.2010, 11:46
  3. Cp343-1 lean
    Von franzlurch im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 14.10.2008, 14:01
  4. Verbindung mit CP343-1 Lean
    Von Stoni im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 01.10.2008, 09:04
  5. CP343 Lean an S7 300 CPU
    Von Jochen Kühner im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 23.03.2007, 01:08

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •