Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 12

Thema: Verbindungsabbau mit NETLink PRO

  1. #1
    Registriert seit
    23.03.2011
    Beiträge
    23
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    habe siemensplctoolboxlib-83035 aus dem Netz heruntergeladen.
    Die Bibo bzw. die Projekte funktionieren gut.

    Mein Problem ist der Verbindungsabbau mit einem Netlink PRO Gerät.
    Das Trennen funktioniert mal und wieder nicht.

    Hat jemand damit schon Erfahrungen.
    Zitieren Zitieren Verbindungsabbau mit NETLink PRO  

  2. #2
    Registriert seit
    17.06.2004
    Ort
    Offenau
    Beiträge
    3.746
    Danke
    209
    Erhielt 421 Danke für 338 Beiträge

    Standard

    Was geht denn genau nicht? Woher weist du das der NL noch verbunden ist? Neuste Netlink Treiber? FW des Netlink aktuell?
    ---------------------------------------------
    Jochen Kühner
    https://github.com/jogibear9988/DotN...ToolBoxLibrary - Bibliothek zur Kommunikation mit PLCs und zum öffnen von Step 5/7 Projekten

  3. #3
    thompo ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    23.03.2011
    Beiträge
    23
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Wenn ich mich nach dem trennen wieder verbinden wil geht das halt nicht.
    Auf dem NETLink PRO ist die FW 1.56

    Und die LED (Connect) gejt halt auch nicht nach dem trennen aus.

  4. #4
    Registriert seit
    17.06.2004
    Ort
    Offenau
    Beiträge
    3.746
    Danke
    209
    Erhielt 421 Danke für 338 Beiträge

    Standard

    Zitat Zitat von thompo Beitrag anzeigen
    Wenn ich mich nach dem trennen wieder verbinden wil geht das halt nicht.
    Auf dem NETLink PRO ist die FW 1.56

    Und die LED (Connect) gejt halt auch nicht nach dem trennen aus.
    Hast du es mal auch mit den Beispielprogrammen bei libnodave probiert, ob es ein problem meiner dll ist, oder ob es an libnodave liegt?

    Gibt es das Problem auch wenn du S7Online mit dem Netlink Pro benutzt?
    ---------------------------------------------
    Jochen Kühner
    https://github.com/jogibear9988/DotN...ToolBoxLibrary - Bibliothek zur Kommunikation mit PLCs und zum öffnen von Step 5/7 Projekten

  5. #5
    thompo ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    23.03.2011
    Beiträge
    23
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Das Excel VB Beispielprogramm für libnodave funktioniert. Da klappt das mit dem Verbindungsabbau.

  6. #6
    Registriert seit
    17.06.2004
    Ort
    Offenau
    Beiträge
    3.746
    Danke
    209
    Erhielt 421 Danke für 338 Beiträge

    Standard

    Zitat Zitat von thompo Beitrag anzeigen
    Das Excel VB Beispielprogramm für libnodave funktioniert. Da klappt das mit dem Verbindungsabbau.
    Zeig mal deinen Code der nicht richtig geht...
    ---------------------------------------------
    Jochen Kühner
    https://github.com/jogibear9988/DotN...ToolBoxLibrary - Bibliothek zur Kommunikation mit PLCs und zum öffnen von Step 5/7 Projekten

  7. #7
    thompo ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    23.03.2011
    Beiträge
    23
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von Jochen Kühner Beitrag anzeigen
    Zeig mal deinen Code der nicht richtig geht...
    ich nutze die Dispose Funktion aus ihrem Projekt:

    public void Dispose()
    {
    DP("Dispose start!");
    Connected = false;
    if (_NeedDispose)
    {
    _NeedDispose = false;
    if (_dc != null)
    {
    _dc.disconnectPLC();
    //Thread.Sleep(2000);
    DP("Dispose disconnectPLC fertig!");
    _dc = null;
    }
    if (_di != null)
    {
    _di.disconnectAdapter();
    //Thread.Sleep(2000);
    DP("Dispose disconnectAdapter fertig!");
    _di = null;
    }
    switch (_configuration.ConnectionType)
    {
    case 1:
    case 2:
    case 3:
    case 4:
    case 10:
    libnodave.closePort(_fds.rfd);
    break;
    case 50:
    libnodave.closeS7online(_fds.rfd);
    break;
    case 122:
    case 123:
    case 124:
    case 223:
    case 224:
    case 230:
    case 231:
    //Thread.Sleep(10000);
    libnodave.closeSocket(_fds.rfd);
    DP("Dispose closeSocket fertig!");
    break;
    }
    }
    DP("Dispose end!");
    }

  8. #8
    Registriert seit
    17.06.2004
    Ort
    Offenau
    Beiträge
    3.746
    Danke
    209
    Erhielt 421 Danke für 338 Beiträge

    Standard

    Meinen Code hab Ich....
    Zeig mal etwas von deinem, vielleicht ist da was falsch (dort wo du Ihn aufrufst!)

    Funktioniert der abbau in meinen Configurations Fenster, wenn du auf Test Verbindung klickst?
    ---------------------------------------------
    Jochen Kühner
    https://github.com/jogibear9988/DotN...ToolBoxLibrary - Bibliothek zur Kommunikation mit PLCs und zum öffnen von Step 5/7 Projekten

  9. #9
    thompo ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    23.03.2011
    Beiträge
    23
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von Jochen Kühner Beitrag anzeigen
    Meinen Code hab Ich....
    Zeig mal etwas von deinem, vielleicht ist da was falsch (dort wo du Ihn aufrufst!)

    Funktioniert der abbau in meinen Configurations Fenster, wenn du auf Test Verbindung klickst?
    Die Verbindung wird bei deinem Verbindungstest aufgebaut aber nicht wieder abgebaut.

  10. #10
    Registriert seit
    17.06.2004
    Ort
    Offenau
    Beiträge
    3.746
    Danke
    209
    Erhielt 421 Danke für 338 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hmmm... Das ist mir jetzt nicht klar... Kannst du mir eine Wireshark Aufzeichnung von meinem Aufbau und Abbau (der nicht funktioniert) zukommen lassen, und eine Aufzeichnung von libnodave über Excel (da wos geht).

    Und funkt es denn mit S7Online und Nutzung des Netlink Treibers?
    ---------------------------------------------
    Jochen Kühner
    https://github.com/jogibear9988/DotN...ToolBoxLibrary - Bibliothek zur Kommunikation mit PLCs und zum öffnen von Step 5/7 Projekten
    Zitieren Zitieren Hmmm....  

Ähnliche Themen

  1. Antworten: 1
    Letzter Beitrag: 04.07.2008, 15:04
  2. Verbindungsabbau OP270
    Von randy77 im Forum HMI
    Antworten: 8
    Letzter Beitrag: 02.02.2008, 17:31
  3. Netlink und OP3
    Von Chi im Forum HMI
    Antworten: 7
    Letzter Beitrag: 24.04.2007, 14:17
  4. Antworten: 8
    Letzter Beitrag: 19.09.2006, 12:50
  5. Die neue NetLink-Generation: NetLink-PRO und NetLink-USB
    Von Gerhard Bäurle im Forum Werbung und Produktneuheiten
    Antworten: 17
    Letzter Beitrag: 28.02.2006, 07:46

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •