Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 12

Thema: LibnoDave an Vipa über GreenCable

  1. #1
    Registriert seit
    17.03.2011
    Ort
    im Wald
    Beiträge
    284
    Danke
    11
    Erhielt 36 Danke für 35 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    und ein riesiges Respekt, Lob und Dankeschön an "Zottel" für LibNoDave.

    Aber nun mein Problem. Ich versuche mit LibNoDave einen globalen Datenbaustein einer Vipa-CPU 214 DPM an MPI²-Port über das Vipa Green-Cable an COM1 eines PCs zu lesen.

    Meine Einstellungen für LibNoDave sind, MPI-Speed: 187,5 kBit's und Protocol: MPI-Protocol (Step7 Version). Damit, bekomme ich mit dem Demo-Programm die meisten Rückmeldungen.
    (Mit Rückmeldungen meine ich, ich starte es mit Delphi aus der Entwicklungsumgebung und bekomme somit ja das "NoDaveDemo.exe"-Fenster. Denke, die interressanteste Zeile ist "result of exchange: -10". Ist bestimmt ein Fehlercode, aber welcher ?).

    Kennt jemand bessere Einstellungen, bzw. hat jemand überhaupt schon einmal so etwas am laufen gehabt und wenn mit welchen Einstellungen ???

    Gruß, Voxe

    PS: Sollte die Antwort auf meine Frage sein: läuft nicht mit Vipa und GreenCable (einem geschenktem Gaul, schaut man nicht ins Maul), dann ist LibNoDave immer noch ein wertvolles Produkt. Mit Siemens-Hardware funktioniert es ja.
    Zitieren Zitieren LibnoDave an Vipa über GreenCable  

  2. #2
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard

    Also zunächst bin ich begeistert, welche Kommnikationswege es gibt und immer wieder erfunden werden.

    Wenn ich das "green cable" richtig verstehe ist eine Art serielle Kommunikation.
    Daher wird dir MPI wohl nicht helfen.

    Ich würde ein Programm wie Sermon verwenden um zu sehen was geschickt und was geantwortet wird.

    Hast du schon einmal versucht mit einer Standard MPI Verbindung zu dem Teil aufzunehmen?
    Denn MPI sollte ja fehlerfrei funktionieren.


    bike

  3. #3
    Registriert seit
    20.10.2003
    Ort
    Biberach
    Beiträge
    5.068
    Danke
    959
    Erhielt 1.459 Danke für 922 Beiträge

    Standard

    Zitat Zitat von bike Beitrag anzeigen
    ...
    Wenn ich das "green cable" richtig verstehe ist eine Art serielle Kommunikation.
    Daher wird dir MPI wohl nicht helfen.
    ...
    ich kenne mich da im Detail auch nicht aus, aber:

    Beim PC-Adapter nimmt Siemens die RS232-Daten und
    setzt sie ins MPI-Protokoll für die MPI-Schnittstelle um.

    VIPA spendiert der Steuerung auch eine RS232 und
    und mit dem Green Cable als spezielles RS232-Kabel
    läuft die "MPI"-Kommunikation.

    Das hat den Sinn, die wesentlich teureren PC-Adapter
    zu umgehen.

    So wie ich das verstanden habe, ist das für den PC
    und damit auch libnodave das selbe, ob über Green
    Cable oder den seriellen PC-Adpater kommuniziert
    wird.
    Beste Grüße Gerhard Bäurle
    _________________________________________________________________
    Hardware: the parts of a computer that can be kicked. – Jeff Pesis

  4. #4
    Registriert seit
    20.10.2003
    Ort
    Biberach
    Beiträge
    5.068
    Danke
    959
    Erhielt 1.459 Danke für 922 Beiträge

    Standard

    Zitat Zitat von Voxe Beitrag anzeigen
    Meine Einstellungen für LibNoDave sind, MPI-Speed: 187,5 kBit's und Protocol: MPI-Protocol (Step7 Version). Damit, bekomme ich mit dem Demo-Programm die meisten Rückmeldungen.
    Wo stellst Du das denn ein? 187,5 kBits ist eine Geschwindigkeit
    des MPI-Bus, den hast aber gar nicht.

    Kann es sein, dass Du in libnodave mit der falschen Schnittstelle
    arbeitest?

    Nachtrag:

    http://spsforum.com/showthread.php/3650-Libnodave-amp-VIPA-SPS-über-Green-Cable?p=20448#post20448
    Geändert von Gerhard Bäurle (25.01.2012 um 21:55 Uhr)
    Beste Grüße Gerhard Bäurle
    _________________________________________________________________
    Hardware: the parts of a computer that can be kicked. – Jeff Pesis

  5. #5
    Avatar von Voxe
    Voxe ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    17.03.2011
    Ort
    im Wald
    Beiträge
    284
    Danke
    11
    Erhielt 36 Danke für 35 Beiträge

    Standard

    Hallo Gerhard,

    erstmal danke, für den Link, den hatte ich nicht gefunden. Leider, hört das Thema da auf, wo mein Problem evtl. gelöst wird.

    Hier die Antwort auf die Frage der Art und Ort der Einstellungen. Bilder sagen mehr wie Worte. Ich mache dies in dem Delphi-Demo-Projekt. Da, in dem einem Bild, ein COM-Port eingestellt werden kann, ist wohl die Umsetzung auf seriell implementiert worden. Habe auch in der Komponente (im Quelltext) gesehen, das die MPI-Speeds den richtigen Baud-Raten zugeordnet werden.

    In dem anderem Bild, sieht man den Kommunikationsverlauf. Ich deute dies, das die Kommunikation aufgebaut wurde (zumindest PC-seitig) und dann die Vipa nicht sinnvoll antwortet. Verstelle ich z.B. den Com-Port oder die Speed, kommt in diesem Fenster nix. Auch Änderungen im Protocl-Feld, mit MPI-Werten bringt nix in diesem Fenster.

    Programmieren kann ich die Vipa mit meinem Green-Cable, mit oben erwähnten Einstellungen. Also Hardware ist ok.

    Gruß, Voxe

    PS: Mache mit S7/Vipa nur in meiner Freizeit herum, muss also nicht laufen, wäre aber schön. Muss ich evtl. noch etwas in der Vipa einstellen ?
    Angehängte Grafiken Angehängte Grafiken

  6. #6
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard

    Mir ist nicht bekannt, dass der Weg über den Treiber von Vipa eingestellt werden kann.
    Denn das muss erfolgen, da ja der Treiber zwischen Programm und Hardware hängt.
    Man müsste im Quellcode einmal nachschauen, ob und wie das zu realisieren ist.


    bike

  7. #7
    Registriert seit
    20.10.2003
    Ort
    Biberach
    Beiträge
    5.068
    Danke
    959
    Erhielt 1.459 Danke für 922 Beiträge

    Standard

    Zitat Zitat von bike Beitrag anzeigen
    Mir ist nicht bekannt, dass der Weg über den Treiber von Vipa eingestellt werden kann...
    Wie ich oben schon geschrieben haben, gibt es
    KEINEN speziellen Treiber von VIPA.
    Beste Grüße Gerhard Bäurle
    _________________________________________________________________
    Hardware: the parts of a computer that can be kicked. – Jeff Pesis

  8. #8
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard

    Zitat Zitat von Gerhard Bäurle Beitrag anzeigen
    Wie ich oben schon geschrieben haben, gibt es
    KEINEN speziellen Treiber von VIPA.
    Das habe ich gelesen.
    Doch das Bild das die EInstellungen anzeigt, kenne ich nicht.
    Ich kann mein MPI nicht über COM1 ansprechen.
    Daher die Vermutung, dass da etwas zusatzlich notwendig ist.
    Wer also macht die Wandlung RS232 <-> MPI?


    bike

  9. #9
    Registriert seit
    20.10.2003
    Ort
    Biberach
    Beiträge
    5.068
    Danke
    959
    Erhielt 1.459 Danke für 922 Beiträge

    Standard

    Zitat Zitat von bike Beitrag anzeigen
    ...
    Wer also macht die Wandlung RS232 <-> MPI?
    Niemand, die soll auch nicht benötigt werden. Siehe 1. Absatz letzter Satz:

    http://spsforum.com/showthread.php/3...0448#post20448
    Beste Grüße Gerhard Bäurle
    _________________________________________________________________
    Hardware: the parts of a computer that can be kicked. – Jeff Pesis

  10. #10
    Registriert seit
    20.10.2003
    Ort
    Biberach
    Beiträge
    5.068
    Danke
    959
    Erhielt 1.459 Danke für 922 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Vielleicht kann Longbow etwas dazu sagen.
    Beste Grüße Gerhard Bäurle
    _________________________________________________________________
    Hardware: the parts of a computer that can be kicked. – Jeff Pesis

Ähnliche Themen

  1. Vipa CPU314ST/DPM + TP + libnodave
    Von Otto im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 17.11.2010, 18:56
  2. Antworten: 0
    Letzter Beitrag: 09.09.2010, 00:27
  3. VB.Net Visu auf Vipa SPS über Libnodave
    Von Turbman im Forum HMI
    Antworten: 32
    Letzter Beitrag: 25.07.2007, 17:36
  4. LibnoDave AS551 und VIPA CPU 243
    Von PeterEF im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 17.07.2007, 07:52
  5. Libnodave & VIPA-SPS über Green-Cable ?
    Von CarstenN im Forum Sonstige Steuerungen
    Antworten: 17
    Letzter Beitrag: 28.06.2005, 23:13

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •