Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 10 von 10

Thema: Problem libnodave über Ethernet

  1. #1
    Registriert seit
    05.09.2005
    Beiträge
    43
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    habe da mal eine Frage und hoffe, dass mir jemand helfen kann.

    Ist es möglich mit libnodave auch mit SPSen (CPs) zu kommunizieren die keine IP-Adressen sondern nur Mac-Adressen haben?

    Da Ethernet ja Macadressen verwendet muss Libnodave sie ja irgendwo herhaben. Ich denke mal aus einem ARP-Request mit der eingegebenen IP-Adresse?

    Gibt es die möglichkeit gleich mit der Macadresse zu initialisieren?

    vielen Dank im voraus

    Gruß
    Zitieren Zitieren Problem libnodave über Ethernet  

  2. #2
    Registriert seit
    25.07.2005
    Ort
    Vogelsbergkreis
    Beiträge
    1.717
    Danke
    48
    Erhielt 68 Danke für 60 Beiträge

    Standard

    Zitat Zitat von Tupo13
    Hallo,

    habe da mal eine Frage und hoffe, dass mir jemand helfen kann.

    Ist es möglich mit libnodave auch mit SPSen (CPs) zu kommunizieren die keine IP-Adressen sondern nur Mac-Adressen haben?

    Da Ethernet ja Macadressen verwendet muss Libnodave sie ja irgendwo herhaben. Ich denke mal aus einem ARP-Request mit der eingegebenen IP-Adresse?

    Gibt es die möglichkeit gleich mit der Macadresse zu initialisieren?

    vielen Dank im voraus

    Gruß
    Du meinst Baugruppen die nur das reine ISO-Protokoll unterstützen? Das geht soweit ich informiert bin nicht mit libnodave, denn die lib braucht ISO over TCP!
    Zitieren Zitieren Re: Problem libnodave über Ethernet  

  3. #3
    Tupo13 ist offline Benutzer
    Themenstarter
    Registriert seit
    05.09.2005
    Beiträge
    43
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Genau das meine ich

    -danke für deine schnelle Antwort

  4. #4
    Registriert seit
    12.04.2005
    Beiträge
    27
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hallo,

    um mit dem ISO-Protokoll zu kommunizieren benötigt man einen betriebssystemabhängigen Treiber für eben dieses Protokoll.

    Aus kompatibilitätsgründen (alle paar Monate/Jahre neues Betriebssystem) ist es daher ratsam das mit einer seperaten Hardware zu lösen.
    Also ein Ethernet-Gateway welches das ISO-Protokoll auf TCP umsetzt. Damit können dann alle üblichen Softwarelösungen auf CP's mit ISO-Protokoll zugreifen. Im Internet lassen sich einige Anbieter solcher Geräte finden.

  5. #5
    Registriert seit
    19.06.2003
    Beiträge
    2.200
    Danke
    85
    Erhielt 259 Danke für 175 Beiträge

    Standard

    Das hat schon einer gefragt, vor 6-7 Wochen. Er hat mir auch Aufzeichnungen von Ethereal geschickt und ich war schon angefangen, aber er hat dann nicht mehr nachgefragt und so ist es eingeschlafen...
    Erstens: ARP nützt dir da gar nix. Wenn pures ISO realisiert würde, müßtest du die MAC-Adresse statt der IP-Adresse angeben.
    Zweitens: Ich hatte keine Lust mehr, weil das eh nur für ein paar uralte CPs relevant zu sein scheint, die nix anderes können.
    Ich habe keinen CP, nur eine unvollständige Simulation unter Linux. Also ist meine einzige Chance:
    1. Das Senden eines solchen Pakets zu implementieren und gucken, ob es so aussieht wie in Ethereal. Ich habe das unter Windows mal so gemacht. Irgendwo gabs in den header files vvon winsock auch mal das Wort ISO, aber ich habe lieber das ganze Paket "selbst gebaut" und den Versand des "rohen" Paketes durch eine Bibliothek namens winpcap machen lasssen, die zu Ethereal gehört.
    2. Den Empfang unter Linux implementieren oder die CP-Simulation nach Windows portieren.
    3. Nachdem Senden und Empfang in beideen Richtungen "ordentlich" aussieht, es einem CP-Besitzer zum Testen zuschicken.
    4. Korrigieren, wieder zuschicken
    Die Schritte 2 -4 (a4-4?) wären halt noch zu tun, aber lohnt sich das?

  6. #6
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.224
    Danke
    630
    Erhielt 955 Danke für 769 Beiträge

    Standard

    Zitat Zitat von Zottel
    Die Schritte 2 -4 (a4-4?) wären halt noch zu tun, aber lohnt sich das?
    Ich glaube nicht. Auch bei ACCON-AGLink verwenden wir nur RFC1006 und nicht das reine ISO-Protokoll. Dieses wird auch von den neuen Baugruppen nicht mehr unterstützt, ist nicht routingfähig, benötigt einen zum OS passenden Packetdriver etc. Wenn jemand eine solche Lösung unbedingt benötigt, gibt es (zumindest für Windows) so etwas bei Inat.
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

  7. #7
    Tupo13 ist offline Benutzer
    Themenstarter
    Registriert seit
    05.09.2005
    Beiträge
    43
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    @ Zottel

    Ich hatte keine Lust mehr, weil das eh nur für ein paar uralte CPs relevant zu sein scheint, die nix anderes können.
    Na ja eigentlich kann man das bei jeder Siemens SPS einstellen.

    Ob sich das lohnt, weiß ich nicht, wollte nur in meinem Programm in dem ich libnodave benutze auch diese Möglichkeit der Kommunikation einbeziehen. Da es wohl einige Arbeit für dich macht wird es sich wohl nicht lohnen.


    Danke für eure schnellen Antworten
    Gruß

  8. #8
    Registriert seit
    19.06.2003
    Beiträge
    2.200
    Danke
    85
    Erhielt 259 Danke für 175 Beiträge

    Standard

    Zitat Zitat von Tupo13
    Na ja eigentlich kann man das bei jeder Siemens SPS einstellen.
    Ich kann mir aber schwer vorstellen, daß es jemand einstellen will, auf Geräten auf denen er auch TCP/IP nutzen kann.

  9. #9
    Registriert seit
    12.04.2005
    Beiträge
    27
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Das wäre auch unnötig.
    Etwas anderes zur Implementierung:
    Soviel ich weiss, wird bei ISO das Protokoll ISO 8073 direkt über Ethernet verwendet, also ohne IP.
    Gibt es da bei neueren Windowssystemen (z.B. XP mit SP 2) nicht Probleme bei der Raw-Socket Programmierung? (Sicherheitseinstellungen)
    So eine Implementierung wäre dann nur unter Linux machbar und verfügbar.

  10. #10
    Registriert seit
    19.06.2003
    Beiträge
    2.200
    Danke
    85
    Erhielt 259 Danke für 175 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von bimota
    Gibt es da bei neueren Windowssystemen (z.B. XP mit SP 2) nicht Probleme bei der Raw-Socket Programmierung? (Sicherheitseinstellungen)
    Die winpcap-Bibliothek tat es bei mir auf win2k Sp4. Ich war als Administrator eingeloogt.
    Ich sage voraus es funktioniert genau dann wenn auch Ethereal funktioniert.
    Ohne XP zu kennen, soweit ich weiß bedeutet dort eine Anmeldung als Administrator nicht mehr, daß man automatisch mit allen Rechten arbeitet. Einige muß man sich erst selbst einräumen.

Ähnliche Themen

  1. NetLink PRO Ethernet und libnodave
    Von tflueckiger im Forum Hochsprachen - OPC
    Antworten: 65
    Letzter Beitrag: 28.03.2012, 07:14
  2. Antworten: 0
    Letzter Beitrag: 09.09.2010, 00:27
  3. Antworten: 0
    Letzter Beitrag: 08.01.2010, 16:34
  4. Problem Profibus-Verknüpfung über Ethernet
    Von Feng im Forum Feldbusse
    Antworten: 6
    Letzter Beitrag: 27.07.2008, 17:32
  5. schon wieder Ethernet/Libnodave
    Von leo im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 04.07.2006, 08:46

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •