Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 20 von 20

Thema: IBH Soft SPS und Accon AG-Link

  1. #11
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.235
    Danke
    634
    Erhielt 955 Danke für 769 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Und was sagt der gute alte Onkel wireshark?
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

  2. #12
    Registriert seit
    10.05.2008
    Beiträge
    31
    Danke
    2
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Ich habe jetzt auf dem Testsystem nachgeschaut, dort war der Dienst deaktiviert.
    Wenn ich den Dienst darauf starte und dann die Soft SPS starte funktioniert die Verbindung auch nicht mehr.
    Von daher haben wir (eher gesagt Sie ) schonmal 1 Problem beseitigt.
    Allerdings muss noch irgendwas sein da ich immer noch keine Verbindung zur Soft SPS an der Anlage bekomme.

    Ich habe auf dem Anlagenrechner mal Wireshark installiert und nach Port 102 gefiltert.
    Ich kann außer der Anfrage an die Soft SPS keine anderen Aktivitäten auf Port 102 finden.
    Auf jeden Fall ist sichergestellt daß die Anfrage den Rechner korrekt auf Port 102 erreicht.

  3. #13
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.235
    Danke
    634
    Erhielt 955 Danke für 769 Beiträge

    Standard

    Und von wem wird sie wie beantwortet? Nur dass die Anfrage reinkommt bedeutet nicht, dass Sie auch der gewünschte Empfänger erhält. Denn ist überhaupt sichergestellt, dass Port 102 von der IBH-SoftSPS belegt ist? Dazu einfach einmal tcpview von sysinternals.com verwenden und nachschauen. Ist der Siemens-Dienst immer noch inaktiv und auf manuell?
    Zusätzlich mal das wireshark-Log einstellen, dann schau ich mir das auch an.
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

  4. #14
    Registriert seit
    10.05.2008
    Beiträge
    31
    Danke
    2
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Habe das gezippte wireshark log schonmal hochgeladen.
    TCPView habe ich gerade nicht hier und der Download gestaltet sich hier etwas schwierig,
    werde ich nachreichen.
    Angehängte Dateien Angehängte Dateien
    • Dateityp: zip PLC.zip (140,5 KB, 4x aufgerufen)

  5. #15
    Registriert seit
    10.05.2008
    Beiträge
    31
    Danke
    2
    Erhielt 1 Danke für 1 Beitrag

    Standard

    So hier die Informationen aus TCPView.
    Der Port 102 wird derzeit von keinem Programm verwendet.
    Die Soft SPS hört die Ports 710 und 1099 ab.

    tcpview.jpg
    Angehängte Grafiken Angehängte Grafiken

  6. #16
    Registriert seit
    10.05.2008
    Beiträge
    31
    Danke
    2
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Ich glaube ich habe die Mögliche Ursache gefunden.
    Auf dem Testsystem läuft eine zusätzliche Anwendung die "X43.NET.exe"
    Das Icon sieht aus wie das Icon der Soft SPS mit den Buchstaben "CP" im Bild.
    Ich denke dass diese Anwendung eine CP Baugruppe simuliert,
    warum die Anwendung an der Anlage nicht läuft muß ich mal prüfen.

  7. #17
    Registriert seit
    10.05.2008
    Beiträge
    31
    Danke
    2
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Ich glaube ich habe die Mögliche Ursache gefunden.
    Auf dem Testsystem läuft eine zusätzliche Anwendung die "X43.NET.exe"
    Das Icon sieht aus wie das Icon der Soft SPS mit den Buchstaben "CP" im Bild.
    Ich denke dass diese Anwendung eine CP Baugruppe simuliert,
    warum die Anwendung an der Anlage nicht läuft muß ich mal prüfen.

  8. #18
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.235
    Danke
    634
    Erhielt 955 Danke für 769 Beiträge

    Standard

    Laut log wir zwar versucht, auf dem Port 102 eine Verbindung zu öffnen, dies wird aber immer abgelehnt.
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

  9. Folgender Benutzer sagt Danke zu Rainer Hönle für den nützlichen Beitrag:

    bitrider (02.06.2012)

  10. #19
    Registriert seit
    10.05.2008
    Beiträge
    31
    Danke
    2
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Ich habe gestern noch eine ganze Weile rumexperimentiert,
    es lag wirklich an der X43net.exe die an der Anlage nicht lief.
    Man muss die x43net.dll in der Konfigdatei (PLC43.ini) einbinden,
    das bewirkt dass beim Starten der Soft SPS die x43net.exe mitgestartet wird.
    Ist alles irgendwie schlecht dokumentiert selbst Google/Bing kennen diese Datei nicht.
    Nachdem die Anwendung auf dem Anlagenrechner ausgeführt wird, funktioniert
    auch der Verbindungsaufbau. "Echte" Daten abzurufen habe ich bisher noch nicht getestet,
    werde ich nächste Woche machen.

    Ohne Ihre Hilfe hätte ich den Fehler wahrscheinlich nicht finden können,
    denn erst durch Ihren Tipp die Ports mit TCPView zu überprüfen wurde ich auf diese Anwendung aufmerksam.

    Vielen Dank nochmal und schönes Wochenende.
    Geändert von bitrider (02.06.2012 um 09:49 Uhr)

  11. #20
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.235
    Danke
    634
    Erhielt 955 Danke für 769 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Wir unterstützen doch gerne. Ebenfalls noch ein schönes Wochenende.
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

Ähnliche Themen

  1. Anbindung von S7-HMI-Geräten an die S5 SPS: IBH Link S5 ++
    Von IBHsoftec GmbH im Forum Werbung und Produktneuheiten
    Antworten: 1
    Letzter Beitrag: 27.04.2017, 17:08
  2. IBH Net für IBH Link S7 Plus frisst Systemleistung
    Von vierlagig im Forum PC- und Netzwerktechnik
    Antworten: 2
    Letzter Beitrag: 30.08.2011, 17:16
  3. Übertragungsgeschwindigkeit mit Libnodave und IBH Link
    Von Pikador im Forum Hochsprachen - OPC
    Antworten: 14
    Letzter Beitrag: 18.03.2010, 21:57
  4. IBH Link und initAdapter() mit Libnodave
    Von Pikador im Forum Hochsprachen - OPC
    Antworten: 2
    Letzter Beitrag: 10.03.2010, 21:48
  5. WinCC 7.0 und IBH Link
    Von cindy im Forum HMI
    Antworten: 1
    Letzter Beitrag: 17.06.2009, 10:20

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •