Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 3 von 3 ErsteErste 123
Ergebnis 21 bis 25 von 25

Thema: S7-300 Webserver

  1. #21
    Hetzer ist offline Benutzer
    Themenstarter
    Registriert seit
    27.09.2013
    Beiträge
    67
    Danke
    11
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Code:
    <!DOCTYPE html>
    <html>
    <head> 
    <title>Home Steuerung</title> 
    </head>	
    <body>
    
    <img src="SIEMENS_Logo.PNG" alt="SIEMENS" width="213" height="35" align="right">
    
    <!-- AWP_In_Variable Name='"WS1"' -->
    <!-- AWP_In_Variable Name='"WS2"' -->
    <!-- AWP_In_Variable Name='"WS3"' -->
    <!-- AWP_In_Variable Name='"WZ1"' -->
    <!-- AWP_In_Variable Name='"WZ2"' -->
    <!-- AWP_In_Variable Name='"WZ3"' -->
    <!-- AWP_In_Variable Name='"WZ4"' -->
    <!-- AWP_In_Variable Name='"WZ5"' -->
     
    <h1>Home Steuerung</h1> 
    
    
    <h2>Steuerungs- und Zustandstabelle</h2> 
    
    <table style="text-align: left; width: 748px;" border="1"
     cellpadding="2" cellspacing="2">
      <tbody>
        <tr>
          <td style="width: 227px;"><h3>Ger&auml;t:</h3></td>
          <td style="width: 98px;"><h3>Zustand:</h3></td>
          <td style="width: 397px;"><h3>Steuern:</h3></td>
        </tr>
        <tr>
          <td style="width: 227px;">Licht Arbeitszimmer</td>
          <td style="width: 98px;"><!-- AWP_Enum_Def Name='"Alarm"' Values='0:"Aus",1:"Ein"' -->
    <!-- AWP_Enum_Ref Name= '"WZ1"' Enum='"Alarm"' --></td>
          <td style="width: 397px;"><form method="post">
    <input type="hidden" name='"WS1"' value="0" />
    <input type="checkbox" name='"WS1"' value="1" />
    <input type="submit" value="Wert absenden" style="height: 30px; width: 200px" />                  
    </form></td>
        </tr>
        <tr>
          <td style="width: 227px;">Licht Schlafzimmer</td>
          <td style="width: 98px;">:="WZ2":</td>
          <td style="width: 397px;"><form method="post">
    <input type="hidden" name='"WS2"' value="0" />
    <input type="checkbox" name='"WS2"' value="1" />
    <input type="submit" value="Wert absenden" style="height: 30px; width: 200px" />                  
    </form></td>
        </tr>
        <tr>
          <td style="width: 227px;">Heizung</td>
          <td style="width: 98px;">:="WZ3":</td>
          <td style="width: 397px;"><form method="post">
    <input type="hidden" name='"WS3"' value="0" />
    <input type="checkbox" name='"WS3"' value="1" />
    <input type="submit" value="Wert absenden" style="height: 30px; width: 200px" />                  
    </form></td>
        </tr>
        <tr>
          <td style="width: 227px;">Computer</td>
          <td style="width: 98px;">:="WZ4":</td>
          <td style="width: 397px;"></td>
        </tr>
        <tr>
          <td style="width: 227px;">Monitore</td>
          <td style="width: 98px;">:="WZ5":</td>
          <td style="width: 397px;"></td>
        </tr>
       
      </tbody>
    </table>
    
    </body>
    </html>
    es geht irgendwie nicht ich hab bestimmt irgendwo ein fehler...

  2. #22
    Registriert seit
    29.03.2004
    Beiträge
    5.739
    Danke
    143
    Erhielt 1.686 Danke für 1.225 Beiträge

    Standard

    Du brauchst eine AWP_Enum_Def und eine AWP_Enum_Ref. Das brauchst du nur einmal am besten am Anfang des HTML-Dokuments zu definieren.
    Verkürzt:

    <!-- AWP_Enum_Def Name='eAusEinText' Values='0:"Aus",1:"Ein"' -->

    <!-- AWP_In_Variable Name='"WS1"' -->
    <!-- AWP_In_Variable Name='"WS2"' -->

    <!-- AWP_Enum_Ref Name='"WS1"' Enum='eAusEinText' -->
    <!-- AWP_Enum_Ref Name='"WS2"' Enum='eAusEinText' -->

    Danach wird überall wo du den Wert von WS1, WS2 usw. ausgeben lässt, anstelle von 0/1 der Wert aus der Enum eingesetzt, also Aus/Ein.

  3. Folgender Benutzer sagt Danke zu Thomas_v2.1 für den nützlichen Beitrag:

    Hetzer (29.09.2013)

  4. #23
    Hetzer ist offline Benutzer
    Themenstarter
    Registriert seit
    27.09.2013
    Beiträge
    67
    Danke
    11
    Erhielt 0 Danke für 0 Beiträge

    Standard

    ok funktioniert
    geht das wenn man z.b. WS1 ein 1 signal bekommt das dann eine mail an eine bestimmte adresse geschickt wird?

  5. #24
    Registriert seit
    29.03.2004
    Beiträge
    5.739
    Danke
    143
    Erhielt 1.686 Danke für 1.225 Beiträge

    Standard

    Zitat Zitat von Hetzer Beitrag anzeigen
    geht das wenn man z.b. WS1 ein 1 signal bekommt das dann eine mail an eine bestimmte adresse geschickt wird?
    Direkt von der SPS aus geht das nur wenn du dort einen entsprechenden CP (z.B. 343-1 Advanced IT) hast.
    Ansonsten bräuchtest du einen anderen Rechner der immer mitläuft, Daten von der SPS abfragt und ggf. eine Email verschickt.

  6. Folgender Benutzer sagt Danke zu Thomas_v2.1 für den nützlichen Beitrag:

    Hetzer (29.09.2013)

  7. #25
    Hetzer ist offline Benutzer
    Themenstarter
    Registriert seit
    27.09.2013
    Beiträge
    67
    Danke
    11
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    brauch man die extra cp oder kann es die CPU317-2PN/DP auch?

Ähnliche Themen

  1. Webserver mit S7-300?
    Von c-teg74 im Forum Simatic
    Antworten: 30
    Letzter Beitrag: 24.11.2016, 14:31
  2. Webserver S7 1200
    Von emilio20 im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 06.01.2013, 12:05
  3. Befehle Webserver
    Von STgeronimo im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 16.12.2012, 22:24
  4. Webserver s7-1200
    Von Oeder im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 17.10.2012, 08:53
  5. Antworten: 3
    Letzter Beitrag: 28.11.2011, 19:21

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •