Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 2 von 2

Thema: S5-95U und libnodave-0.8.4.5 über AS511 Kommunikationsfehler

  1. #1
    Registriert seit
    30.03.2014
    Beiträge
    5
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich habe eine S5-95U über einen Horter-Adapter und einen RS232-USB-Adapter mit Chipsatz Prolific PL2302 an die USB-Buchse meines Ubuntu-12.04-x64-PCs angeschlossen. Drei Adern der Leitung sind beschaltet. Als Gast läuft im vmplayer eine Windows-VM mit der S5-Programmiersoftware. Die Schnittstelle /dev/ttyUSB0 wird als COM1 in die VM importiert. Das funktioniert seit langem stabil. Versuche ich jetzt dagegen libnodave-0.8.4.5 mit z.B. ./testAS511 -s -d /dev/ttyUSB0 einzusetzen, entspricht die sierielle Kommunikation nicht dem zu erwartenden Protokoll und bricht mit einer Fehlermeldung ab:

    Code:
    uk@ird:~/sps/libnodave-0.8.4.5$ sudo ./testAS511 -s -d /dev/ttyUSB0
    ConnectPLC
    IF1 daveReqTrans 24
    I send: 
    0:0x02,
    2got: 
    0:0x02,
    IF1 daveReqTrans 24 *** no DLE,ACK before send.
    IF1 *** Error in Exchange.ReqTrans request.
    IF1 *** Error in ImageAddr.Exchange sequence.
    Couldn't connect to PLC.
     Please try again. You may also try the option -2 for some adapters.
    Beim eigentlichen Ziel, einen Raspberry Pi einzusetzen, weicht die Kommunikation zwar bei einigen Versuchen ab, endet aber auch mit einer Fehlermeldung. Für den Raspberry bin ich nach der Anleitung hier im Forum von scrolllkock vorgegangen. Die abweichende Kommunikation:

    Code:
    pi@raspberrypi ~/sps/libnodave-0.8.4.5 $ ./testAS511 -s -d /dev/ttyUSB0
    ConnectPLC
    IF1 daveReqTrans 24
    I send: 
    0:0x02,
    2got: 
    0:0x10,0x06,
    I send: 
    0:0x18,
    readSingle 1 chars. 1st 02
    I send: 
    0:0x10,0x06,
    1got: 
    0:0x16,0x06,
    IF1 daveReqTrans 24 *** no accept0 from plc.
    IF1 *** Error in Exchange.ReqTrans request.
    IF1 *** Error in ImageAddr.Exchange sequence.
    Couldn't connect to PLC.
     Please try again. You may also try the option -2 for some adapters.
    Die Option -2 behebt den Fehler nicht. Hat jemand einen sachdienlichen Hinweis für mich oder hat eine solche oder ähnliche Konfiguration in Betrieb?
    Geändert von krueuw (04.10.2014 um 11:22 Uhr)
    Zitieren Zitieren S5-95U und libnodave-0.8.4.5 über AS511 Kommunikationsfehler  

  2. #2
    krueuw ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    30.03.2014
    Beiträge
    5
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich habe eine S5-95U über einen Horter-Adapter und einen RS232-USB-Adapter mit Chipsatz Prolific PL2302 an die USB-Buchse meines Ubuntu-12.04-x64-PCs angeschlossen. Drei Adern der Leitung sind beschaltet. Als Gast läuft im vmplayer eine Windows-VM mit der S5-Programmiersoftware. Die Schnittstelle /dev/ttyUSB0 wird als COM1 in die VM importiert. Das funktioniert seit langem stabil. Versuche ich jetzt dagegen libnodave-0.8.4.5 mit z.B. ./testAS511 -s -d /dev/ttyUSB0 einzusetzen, entspricht die sierielle Kommunikation nicht dem zu erwartenden Protokoll und bricht mit einer Fehlermeldung ab:

    Code:
    uk@ird:~/sps/libnodave-0.8.4.5$ sudo ./testAS511 -s -d /dev/ttyUSB0
    ConnectPLC
    IF1 daveReqTrans 24
    I send: 
    0:0x02,
    2got: 
    0:0x02,
    IF1 daveReqTrans 24 *** no DLE,ACK before send.
    IF1 *** Error in Exchange.ReqTrans request.
    IF1 *** Error in ImageAddr.Exchange sequence.
    Couldn't connect to PLC.
     Please try again. You may also try the option -2 for some adapters.
    Beim eigentlichen Ziel, einen Raspberry Pi einzusetzen, weicht die Kommunikation zwar bei einigen Versuchen ab, endet aber auch mit einer Fehlermeldung. Für den Raspberry bin ich nach der Anleitung hier im Forum von scrolllkock vorgegangen. Die abweichende Kommunikation:

    Code:
    pi@raspberrypi ~/sps/libnodave-0.8.4.5 $ ./testAS511 -s -d /dev/ttyUSB0
    ConnectPLC
    IF1 daveReqTrans 24
    I send: 
    0:0x02,
    2got: 
    0:0x10,0x06,
    I send: 
    0:0x18,
    readSingle 1 chars. 1st 02
    I send: 
    0:0x10,0x06,
    1got: 
    0:0x16,0x06,
    IF1 daveReqTrans 24 *** no accept0 from plc.
    IF1 *** Error in Exchange.ReqTrans request.
    IF1 *** Error in ImageAddr.Exchange sequence.
    Couldn't connect to PLC.
     Please try again. You may also try the option -2 for some adapters.
    Die Option -2 behebt den Fehler nicht. Hat jemand einen sachdienlichen Hinweis für mich oder hat eine solche oder ähnliche Konfiguration in Betrieb?
    Zitieren Zitieren S5-95U und libnodave-0.8.4.5 über AS511 Kommunikationsfehler  

Ähnliche Themen

  1. Libnodave S5 PG-Schnittstelle Kommunikationsfehler
    Von RobinHood im Forum Hochsprachen - OPC
    Antworten: 10
    Letzter Beitrag: 20.11.2013, 15:41
  2. S5 Kommunikation AS511, libnodave
    Von cidex im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 22.11.2008, 09:13
  3. Libnodave as511 Verbindung
    Von saurugst im Forum Hochsprachen - OPC
    Antworten: 0
    Letzter Beitrag: 21.12.2007, 09:49
  4. libnodave und AS511
    Von Ralle im Forum Hochsprachen - OPC
    Antworten: 8
    Letzter Beitrag: 20.02.2007, 00:41
  5. Libnodave für AS511?
    Von hera2006 im Forum Hochsprachen - OPC
    Antworten: 0
    Letzter Beitrag: 14.01.2007, 21:14

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •