Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Results 1 to 7 of 7

Thread: S7 1500 OPC UA Zugriff mit datafeed OPC UA Client

  1. #1
    Join Date
    19.02.2005
    Posts
    218
    Danke
    12
    Erhielt 8 Danke für 6 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Guten Morgen.
    Kann mir mal jemand auf die Sprünge helfen:
    Ich habe den Auftrag bekommen eine Verbindung zu testen, da ein Kunde nicht darauf zugreifen kann. Habe vorher nie mit UA sondern nur mir DA gearbeitet.
    Folgendes Szenario:
    Der SPS-Programmierer hat in seiner SPS (1500er vermutlich) Das OPC UA aktiviert und meint der DB 2000 sei darüber erreichbar. Von diesem Baustein habe ich einen Screenshot.
    Ich kann von meinem Arbeitsplatz die IP-Adresse erreichen.
    Also habe ich den Matricon OPC-Client gestartet un diese Adresse angegeben:
    opc.tcp://192.168.1.3:4840
    Bei OPC UA hatte ich nun erwartet, dass ich einen Baum bekomme, in dem alle Daten zugreifbar sind. Aber ich bekomme nur ein Subscription 1 - > Root mit ns=0;i=84; angezeigt.
    Muss ich jetzt alle Daten aus dem DB2000 manuell eingeben um sie zu sehen?
    Wie mache ich das? Ich kann doch nur eine NodeID eingeben? Wie hängt die mit der Datenbaustein-Nummer und dem Offset zusammen?
    Gibt es ein Howto dafür?

    Ich habe im Moment keine Ahnung, wo ich anfangen soll.
    Gruß,
    Aksels
    Linux is like a Wigwam: no Windows, no Gates and Apache inside.
    Reply With Quote Reply With Quote S7 1500 OPC UA Zugriff mit datafeed OPC UA Client  

  2. #2
    Join Date
    19.08.2010
    Posts
    312
    Danke
    10
    Erhielt 70 Danke für 65 Beiträge

    Default

    Hast du mal versucht mit UA Expert zu versuchen drauf zuzugreifen. Da findest du auch die NodeID usw. am einfachten.

    https://www.unified-automation.com/p.../uaexpert.html
    Gruß

    blackpeat

  3. #3
    Aksels is offline Erfahrener Benutzer
    Themenstarter
    Join Date
    19.02.2005
    Posts
    218
    Danke
    12
    Erhielt 8 Danke für 6 Beiträge

    Default

    Sieht genauso leer aus.....
    OPCUA1.JPG
    Linux is like a Wigwam: no Windows, no Gates and Apache inside.

  4. #4
    Join Date
    19.08.2010
    Posts
    312
    Danke
    10
    Erhielt 70 Danke für 65 Beiträge

    Default

    Hm das sieht wirklich so aus als würde im OPC UA auf der SPS keine Sachen freigegeben sind. Normalerweise ist unter AdressSpace Links die SPS zu sehen mit den freigegebenen Sachen. Was mich etwas wundert das die SPS gar nicht zu sehen ist.

    So sieht es bei mir aus.

    OPC_UA.jpg
    Gruß

    blackpeat

  5. #5
    Join Date
    19.07.2018
    Posts
    3
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Default

    Hallo,

    ich habe mich schon mal mit OPC Ua Server von Beckhoff beschäftigt. Ich habe eine Frage, ob Du die Zertifkatsaustausch für beiden Server und Client gemacht hast.
    Hierzu ist eine kurze Beschreibung für Zertifkatsaustausch bei Beckhoff-SPS.

    https://infosys.beckhoff.com/index.p...195-3.html&id=

    Gruß

  6. #6
    Join Date
    27.10.2009
    Posts
    332
    Danke
    0
    Erhielt 66 Danke für 56 Beiträge

    Default

    Hallo,

    wenn du schon drauf bist und den "Objects" Knoten sehen kannst, dann kann es an den Zertifikaten eigentlich nicht mehr liegen (denn du bist ja schon drin .
    Wenn du den Einstiegsknoten in die SPS nicht sehen kannst oder dadrunter nichts mehr kommt, ist die S7 vermutlich falsch konfiguriert und der DB2000 ist doch nicht freigegeben oder er hat keinen symbolischen Namen oder im DB haben die Variablen keinen Namen, oder im DB sind nur wieder UDTs drin und die sind aber nicht freigegeben. Oder ganz einfach, der Kollege hat das "freigegeben" aber dann nicht wieder in die SPS geladen...

    Theoretisch kannst du aich selber wieder "NodeIDs eingeben/anlegen (rechte Maustaste im UaExpert) aber dann musst du natürlich 100% exakt wissen wie die bei Siemens aufgebaut sind und das alles genauso eingeben (Siemens-Handbuch). Daher sollte "browsen" und draufklicken natürlich die bevorzugte Lösung sein, alles andere ist viel zu mühsam...

  7. #7
    Aksels is offline Erfahrener Benutzer
    Themenstarter
    Join Date
    19.02.2005
    Posts
    218
    Danke
    12
    Erhielt 8 Danke für 6 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Guten Morgen.
    Noch eine kleine Rückmeldung.
    Hauptlösung waren ersteinmal korrekte Zugangsdaten. Bei einer Anlage war es ohne Benutzer und Kennwort. Bei einer anderen war das Passwort fehlerhaft.
    UA-Expert hat mir übrigens am besten gefallen. Ließ sich schnell zur Mitarbeit bewegen.
    Gruß,
    Aksels
    Linux is like a Wigwam: no Windows, no Gates and Apache inside.

Similar Threads

  1. TIA S7-1500 CPU nur als OPC Client
    By Marcelh. in forum Simatic
    Replies: 33
    Last Post: 01.03.2019, 17:29
  2. Replies: 1
    Last Post: 20.11.2018, 13:03
  3. Replies: 12
    Last Post: 03.05.2016, 08:42
  4. Replies: 1
    Last Post: 08.02.2010, 14:15
  5. Replies: 1
    Last Post: 07.12.2005, 19:12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •