Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Results 1 to 5 of 5

Thread: F-Prozessdaten Antriebe

  1. #1
    Join Date
    06.11.2008
    Location
    Steinhagen
    Posts
    1,196
    Danke
    236
    Erhielt 202 Danke für 175 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Moin Zusammen,

    ich stehe gerade etwas auf dem Schlauch. Es geht um sichere Prozessdaten von/zu einem Antrieb (SEW Movidrive modular (F-Karte = CSS31A)). Partner ist eine 1515F-2 PN.

    Jetzt ist es so, dass ich über Profisafe eine Überwachungsfunktion aktivieren (false) oder deaktivieren (true) kann. Die Rückmeldung ist entweder true (Überwachung aktiv + ok) oder false (Überwachung deaktiviert oder nicht ok).
    Wie kann ich die Überwachungsfunktion stoßfrei aktivieren/deaktivieren?

    Deaktivieren (0->1):
    - wenn ich deaktiviere, kann ich mit dem Bit zum deaktivieren (true) und der Rückmeldung (false) erkennen, dass die Sicherheitsfunktion nicht ausgelöst hat, sondern ich diese bewusst deaktiviert habe.

    Aktivieren (1->0):
    - wenn ich aktiviere, habe ich eine kurze Zeit ein false auf dem Aktivierungsbit und die Rückmeldung ist false, bis Rückgemeldet wurde, dass die Sicherheitsfunktion aktiviert wurde.


    Code:
    Deaktivieren
    ###################
                           ______
    Aktivierungsbit:  ____|
                      00001111111
    
                      ______
    Rückmeldebit:           |____
                      11111110000
    
    OR:               11111111111
    
    
    
    Aktivieren
    ###################
                      ____
    Aktivierungsbit:      |______
                      11111000000
    
                             ____
    Rückmeldebit:     ______|
                      00000011111
    
    OR:               11111011111

    Dadurch ergibt sich beim aktivieren ein kurzer Augenblick, den ich als Fehler interpretieren muss. Eigentlich will ich nicht über jede Abfrage eine Zeit drüber legen.
    Wie löst ihr das Problem oder denke ich wieder zu verquer???


    VG

    MFreiberger
    _____________________________________________
    Zwei Aussagen, die man nicht ungeprüft hinnehmen sollte:
    - "Das machen wir schon immer so!"
    - "Das machen die Anderen auch so!"
    Reply With Quote Reply With Quote F-Prozessdaten Antriebe  

  2. #2
    MFreiberger is offline Erfahrener Benutzer
    Themenstarter
    Join Date
    06.11.2008
    Location
    Steinhagen
    Posts
    1,196
    Danke
    236
    Erhielt 202 Danke für 175 Beiträge

    Default

    Moin,

    keine Lösungen?
    keine TimerAlternativen?
    Frage unverständlich?
    ...?

    VG

    MFreiberger
    _____________________________________________
    Zwei Aussagen, die man nicht ungeprüft hinnehmen sollte:
    - "Das machen wir schon immer so!"
    - "Das machen die Anderen auch so!"

  3. #3
    Join Date
    17.07.2009
    Location
    Am Rande der Ostalb
    Posts
    8,244
    Danke
    1,639
    Erhielt 2,068 Danke für 1,533 Beiträge

    Default

    Quote Originally Posted by MFreiberger View Post
    Moin Zusammen,

    ich stehe gerade etwas auf dem Schlauch. Es geht um sichere Prozessdaten von/zu einem Antrieb (SEW Movidrive modular (F-Karte = CSS31A)). Partner ist eine 1515F-2 PN.

    Jetzt ist es so, dass ich über Profisafe eine Überwachungsfunktion aktivieren (false) oder deaktivieren (true) kann. Die Rückmeldung ist entweder true (Überwachung aktiv + ok) oder false (Überwachung deaktiviert oder nicht ok).
    Wie kann ich die Überwachungsfunktion stoßfrei aktivieren/deaktivieren?

    Deaktivieren (0->1):
    - wenn ich deaktiviere, kann ich mit dem Bit zum deaktivieren (true) und der Rückmeldung (false) erkennen, dass die Sicherheitsfunktion nicht ausgelöst hat, sondern ich diese bewusst deaktiviert habe.

    Aktivieren (1->0):
    - wenn ich aktiviere, habe ich eine kurze Zeit ein false auf dem Aktivierungsbit und die Rückmeldung ist false, bis Rückgemeldet wurde, dass die Sicherheitsfunktion aktiviert wurde.


    Code:
    Deaktivieren
    ###################
                           ______
    Aktivierungsbit:  ____|
                      00001111111
    
                      ______
    Rückmeldebit:           |____
                      11111110000
    
    OR:               11111111111
    
    
    
    Aktivieren
    ###################
                      ____
    Aktivierungsbit:      |______
                      11111000000
    
                             ____
    Rückmeldebit:     ______|
                      00000011111
    
    OR:               11111011111

    Dadurch ergibt sich beim aktivieren ein kurzer Augenblick, den ich als Fehler interpretieren muss. Eigentlich will ich nicht über jede Abfrage eine Zeit drüber legen.
    Wie löst ihr das Problem oder denke ich wieder zu verquer???


    VG

    MFreiberger
    Zeiten für Rückmeldungen sind doch ganz normal.
    Hast du ja auch quasi an jedem Siemens F-FB

  4. #4
    Join Date
    21.02.2018
    Posts
    65
    Danke
    28
    Erhielt 2 Danke für 2 Beiträge

    Default

    Ich vermute mal es geht hier um die Aktivierung von Sicherheitsfunktionen wie SLS oder ähnliches?

    Wir arbeiten hier auch mit Verzögerungszeiten

  5. #5
    Join Date
    17.07.2009
    Location
    Am Rande der Ostalb
    Posts
    8,244
    Danke
    1,639
    Erhielt 2,068 Danke für 1,533 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Quote Originally Posted by lenovo View Post
    Ich vermute mal es geht hier um die Aktivierung von Sicherheitsfunktionen wie SLS oder ähnliches?

    Wir arbeiten hier auch mit Verzögerungszeiten
    Geht ja letztlich nicht anders.
    Der Antrieb braucht ja letztlich auch eine gewisse Zeit um die Funktion zu aktivieren.

Similar Threads

  1. Prozessdaten Archivieren
    By JFKjo in forum HMI
    Replies: 2
    Last Post: 22.06.2015, 12:43
  2. Sonstiges Prozessdaten Sinumerik
    By C7633 in forum Simatic
    Replies: 0
    Last Post: 04.07.2013, 13:37
  3. Prozessdaten mitschreiben
    By UKemni in forum CODESYS und IEC61131
    Replies: 9
    Last Post: 27.06.2011, 08:44
  4. Prozessdaten speichern in S7 ?
    By derAndere in forum Simatic
    Replies: 4
    Last Post: 20.10.2010, 17:08
  5. Antriebe synchronisieren
    By ssound1de in forum Antriebstechnik
    Replies: 1
    Last Post: 11.10.2010, 13:09

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •