Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: Unterschied Windows XP und Windows 7 XP Mode

  1. #1
    Registriert seit
    23.02.2007
    Ort
    Hamburg
    Beiträge
    695
    Danke
    198
    Erhielt 84 Danke für 74 Beiträge

    Unglücklich


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Nabend,

    habe heute nach langem probieren mit erschrecken festgestellt, dass eine Software welche unter Windows XP einwandfrei läuft, bei einer Funktion im Windows 7 XP Mode "herumzickt".

    Es handelt sich um die Visualisierungssoftware von Schneider Electric Vijeo Designer 5.1 SP1. Das Programm lief bisher einwandfrei im Windows 7 XP Mode und hat alles wie unter Windows XP getan. Heute habe ich versucht Variablen aus einem SPS Projekt einzubinden, doch leider findet die Software von keinem SPS Projekt (egal welches Vorlagenformat) irgendeine Variable. Es erscheint zwar das Auswahlfenster ohne Fehlermeldung, jedoch ohne Variablen...

    Teste ich die gleichen Files auf meinem alten XP Rechner so werden mir die Variablen angezeigt.
    (Habe mehrere Versionen der Software getestet und auch auf zwei verschiedenen Virtual PC VMs)


    Hat jemand eine Idee was der Unterschied zwischen Windows XP und dem Windows 7 XP Mode ausmacht, welcher diesen Bug hervorruft? Bzw, was sind die grundsätzlichen Unterschiede?
    War bisher von den virtuellen Maschinen sehr begeistert, aber nun bekomme ich etwas bedenken :/
    Siemens: Step7, WinCC Flexible, Logo
    Schneider: PL7, Unity Pro, Vijeo Look, Vijeo Designer, XBTL1000, Premium, M340, Twido, Zelio
    Moeller: Galileo, EASY
    B&R: Automation Studio 3.0
    Zitieren Zitieren Unterschied Windows XP und Windows 7 XP Mode  

  2. #2
    Registriert seit
    01.10.2007
    Ort
    Waiblingen
    Beiträge
    3.317
    Danke
    767
    Erhielt 536 Danke für 419 Beiträge

    Standard

    Zitat Zitat von eYe Beitrag anzeigen
    ... und auch auf zwei verschiedenen Virtual PC VMs
    ...
    War bisher von den virtuellen Maschinen sehr begeistert, aber nun bekomme ich etwas bedenken :/
    darf ich das so verstehen, dass es sowohl im XP-Modus (der ja auf VirtualPC basieren soll) als auch innerhalb VirtualPC auf Win7 als Host nicht funktioniert?

  3. #3
    Registriert seit
    17.06.2004
    Ort
    Offenau
    Beiträge
    3.758
    Danke
    209
    Erhielt 421 Danke für 338 Beiträge

    Standard

    Zitat Zitat von eYe Beitrag anzeigen
    Nabend,

    habe heute nach langem probieren mit erschrecken festgestellt, dass eine Software welche unter Windows XP einwandfrei läuft, bei einer Funktion im Windows 7 XP Mode "herumzickt".

    Es handelt sich um die Visualisierungssoftware von Schneider Electric Vijeo Designer 5.1 SP1. Das Programm lief bisher einwandfrei im Windows 7 XP Mode und hat alles wie unter Windows XP getan. Heute habe ich versucht Variablen aus einem SPS Projekt einzubinden, doch leider findet die Software von keinem SPS Projekt (egal welches Vorlagenformat) irgendeine Variable. Es erscheint zwar das Auswahlfenster ohne Fehlermeldung, jedoch ohne Variablen...

    Teste ich die gleichen Files auf meinem alten XP Rechner so werden mir die Variablen angezeigt.
    (Habe mehrere Versionen der Software getestet und auch auf zwei verschiedenen Virtual PC VMs)


    Hat jemand eine Idee was der Unterschied zwischen Windows XP und dem Windows 7 XP Mode ausmacht, welcher diesen Bug hervorruft? Bzw, was sind die grundsätzlichen Unterschiede?
    War bisher von den virtuellen Maschinen sehr begeistert, aber nun bekomme ich etwas bedenken :/
    Benutzt diese Software irgenwelche Hardwarenahen Treiber, denn da gibt es natürlich Unterschiede! Auch mit USB, COM Porst, usw... Also alles was halt Harwarenah ist! Es kann gehen (wenn es den Unterstützt wird) muss aber nicht!
    ---------------------------------------------
    Jochen Kühner
    https://github.com/jogibear9988/DotN...ToolBoxLibrary - Bibliothek zur Kommunikation mit PLCs und zum öffnen von Step 5/7 Projekten

  4. #4
    Registriert seit
    18.06.2010
    Beiträge
    29
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Also mutmasse:
    1. Hast du Win7 64Bit installiert.
    2. Ist XP das bessere OS für älter Software!

    Und 3. der Virtual PC VM von MS ist nicht die Tollest VM, meines Empfindens! Teste mal hier VirtualBox von SUN / Oracle oder wenn möglich gar von VMWare, wenns Virtuell laufen soll!

  5. #5
    Avatar von eYe
    eYe ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    23.02.2007
    Ort
    Hamburg
    Beiträge
    695
    Danke
    198
    Erhielt 84 Danke für 74 Beiträge

    Standard

    Zitat Zitat von Perfektionist Beitrag anzeigen
    darf ich das so verstehen, dass es sowohl im XP-Modus (der ja auf VirtualPC basieren soll) als auch innerhalb VirtualPC auf Win7 als Host nicht funktioniert?
    Auf Win7 kann ich es gar nicht erst installieren, im XP Mode läuft das Programm bis auf die eine Funktion der Variablenintegration.

    @Jochen Kühner
    Ich benutze zum Programmieren nur die Ethernetverbindung, daher sind Hardwarenahe Treiber für mich eigentlich nicht relevant.

    @Potenzial
    Habe es auch mit VMWare getestet, gleiches Ergebnis. Programm läuft aber Variablenintegration funktioniert nicht.


    Habe bisher für alles eine Lösung gefunden, aber hier habe ich nichtmal einen Ansatz für die Lösung...
    Siemens: Step7, WinCC Flexible, Logo
    Schneider: PL7, Unity Pro, Vijeo Look, Vijeo Designer, XBTL1000, Premium, M340, Twido, Zelio
    Moeller: Galileo, EASY
    B&R: Automation Studio 3.0

  6. #6
    Registriert seit
    17.06.2004
    Ort
    Offenau
    Beiträge
    3.758
    Danke
    209
    Erhielt 421 Danke für 338 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von eYe Beitrag anzeigen
    Auf Win7 kann ich es gar nicht erst installieren, im XP Mode läuft das Programm bis auf die eine Funktion der Variablenintegration.

    @Jochen Kühner
    Ich benutze zum Programmieren nur die Ethernetverbindung, daher sind Hardwarenahe Treiber für mich eigentlich nicht relevant.

    @Potenzial
    Habe es auch mit VMWare getestet, gleiches Ergebnis. Programm läuft aber Variablenintegration funktioniert nicht.


    Habe bisher für alles eine Lösung gefunden, aber hier habe ich nichtmal einen Ansatz für die Lösung...
    Läuft den dein Netzwerk in der VM?? Geht auch die Loopback verbindung, dh.h. kannst du 127.0.0.1 anpingen?
    ---------------------------------------------
    Jochen Kühner
    https://github.com/jogibear9988/DotN...ToolBoxLibrary - Bibliothek zur Kommunikation mit PLCs und zum öffnen von Step 5/7 Projekten

Ähnliche Themen

  1. Step 5 mit XP-Mode auf Windows 7 Ultimate
    Von youfyouk im Forum Simatic
    Antworten: 19
    Letzter Beitrag: 29.01.2015, 15:17
  2. B&R AS 3.0.8.0 und Windows 7
    Von Anaconda55 im Forum Sonstige Steuerungen
    Antworten: 18
    Letzter Beitrag: 16.10.2012, 13:36
  3. Homing Mode und Profile Position Mode in CANopen
    Von senmeis im Forum Feldbusse
    Antworten: 2
    Letzter Beitrag: 10.06.2011, 09:32
  4. Windows XP --> Windows XP embedded
    Von Hitschkock im Forum PC- und Netzwerktechnik
    Antworten: 5
    Letzter Beitrag: 31.01.2011, 21:38
  5. Upgrade Windows 2000 auf Windows XP
    Von seeba im Forum PC- und Netzwerktechnik
    Antworten: 9
    Letzter Beitrag: 12.08.2005, 08:03

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •