Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 13

Thema: Switch stört Kommunikation

  1. #1
    Registriert seit
    31.08.2006
    Ort
    OH
    Beiträge
    273
    Danke
    69
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich möchte mit einer externen Steuerung per ModBus TCP kommunizieren. Bei der Inbetriebnahme konnte aber keine Verbindung aufgebaut werden, obwohl die Steuerung "anpingbar" ist und sich alle Teilnehmer im selben IP-Nummernkreis befinden. Nach langer Sucherei ist der Schuldige nun gefunden. Sofern die Kommunikation über den managed Switch läuft geht nichts, stelle ich eine Verbindung direkt her ist alles toll. Auch ein kleiner 8 Port Switch funktioniert.

    Der Administrator schiebt die Schuld auf die "billige" Hardware des Steuerungsanbieters. Das stelle ich aber in Frage. Es ist mMn die Unfähigkeit hier eine Lösung herbei zu führen.

    Kann mir vielleicht einer von euch erklären, was ich machen könnte bzw. dem überforderten Admin vorschlagen könnte damit ich zum Ziel komme? So bin ich total hilflos. Das ärgert mich enorm das der Admin hier zu dumm ist Hilfestellung zu leisten und es sich so ganz einfach macht.

    P.S. Switch wechseln kommt hier nicht in Frage. Da hängt eine ganze Produktion dran. Geschwindigkeit auf 100 MBit Vollduplex brachte auch kein Ergebnis.
    Geändert von Deep Blue (27.06.2016 um 17:08 Uhr)
    Wahnsinn wohnt nur 1 Stockwerk unter dem Genie. Aber Genie ist nichts anderes, als kontrollierter Wahnsinn.
    Zitieren Zitieren Switch stört Kommunikation  

  2. #2
    Registriert seit
    23.07.2009
    Ort
    Österreich
    Beiträge
    2.272
    Danke
    439
    Erhielt 661 Danke für 498 Beiträge

    Standard

    Zitat Zitat von Deep Blue Beitrag anzeigen
    Der Administrator schiebt die Schuld auf die "billige" Hardware des Steuerungsanbieters.
    Dan kannst du den Admin ja fragen warum der "billige" unmanaged Switch etwas kann dass dein teuer Switch nicht kann....

    Da wird der dir Switch vom Admin irgendwas blockieren.
    Wäre allerdings hilfreich wenn du ein paar Informationen zu den verwendeten Komponenten (Steuerungen) nennen würdest, vielleicht über welche Ports ihr die Verbindung aufbauen wollt, etc...

    Dann kann dir vielleicht eher geholfen werden.
    If at first you don't succeed, you're not Van Damme!
    ... or maybe using TIA!

  3. #3
    Deep Blue ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    31.08.2006
    Ort
    OH
    Beiträge
    273
    Danke
    69
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Habe ich ihn gefragt. Aber da kam dann nur das er nichts blockt und es an der Steuerung des Anbieters liegen würde.

    Ich möchte keine Marke nennen. Es handelt sich aber um eine Steuerung eines namhaften Kälteanlagenbauers. Kommuniziert werden soll, wie schon erwähnt, über ModBus TCP über den Port 502. Als Versuchsaufbau benutze ich auf meinem Laptop die Software Baseblock ComTest Pro for Modbus Devices. Ping klappt, wenn mein Laptop direkt am Ethernet Port der Steuerung hängt ist auch alles ok. Leitung bis zum Patchfeld ist ok. Steckt diese im Switch und ich versuche über diesen aus dem Firmennetz zuzugreifen, bekomme ich keine Werte, obwohl Verbindung steht.

    P.S. ...und billig ist sowieso gut. Wenn der wüßte wie teuer die Anlage war. Aber das Spielt in der Administration bei uns eher eine untergeordnete Rolle.
    Wahnsinn wohnt nur 1 Stockwerk unter dem Genie. Aber Genie ist nichts anderes, als kontrollierter Wahnsinn.

  4. #4
    Registriert seit
    29.03.2004
    Beiträge
    5.600
    Danke
    141
    Erhielt 1.653 Danke für 1.203 Beiträge

    Standard

    Sind die Teilnehmer in unterschiedlichen Subnetzen? Hast du die Subnetzmaske mit der IT des Kunden abgeglichen? Vielleicht ist das Gerät von ihm nicht nur ein Switch sondern auch ein Router.

    Du könntest die vermeintlich "billige" Steuerungshardware als Fehlerursache ausschließen, wenn du anstelle der Steuerung mal eine PC/Notebook mit einem Modbus-TCP Server oder einem anderen Serverprogramm (ich verwende dazu gerne Hercules http://www.hw-group.com/products/hercules/index_de.html oder auch das Microsoft telnet Programm) was auf dem Modbus Port lauscht anschließt, und dann versuchst ob du dazu eine Verbindung aufgebaut bekommst. Von PC zu PC lässt sich die Verbindung einfacher diagnostizieren, bei der Steuerung müsstest du dich erst leitungstechnisch dazwischenhängen.

    Aber diese sogenannten "Admins" kenne ich auch. In der Branche nach meiner Erfahrung größtenteils Nichtsblicker unterwegs.
    Die Genialität einer Konstruktion liegt in ihrer Einfachheit – Kompliziert bauen kann jeder.

    (Sergei Pawlowitsch Koroljow, sowjetischer Konstrukteur von Raketen und Weltraumpionier)

  5. #5
    Deep Blue ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    31.08.2006
    Ort
    OH
    Beiträge
    273
    Danke
    69
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Zitat Zitat von Thomas_v2.1 Beitrag anzeigen
    Sind die Teilnehmer in unterschiedlichen Subnetzen?
    -> Nein, beide 255.255.255.0

    Hast du die Subnetzmaske mit der IT des Kunden abgeglichen?
    -> Ja, er nutzt auch noch den selben Standardgateway

    Vielleicht ist das Gerät von ihm nicht nur ein Switch sondern auch ein Router.
    -> Was wäre dann?

    Du könntest die vermeintlich "billige" Steuerungshardware als Fehlerursache ausschließen, wenn du anstelle der Steuerung mal eine PC/Notebook mit einem Modbus-TCP Server oder einem anderen Serverprogramm (ich verwende dazu gerne Hercules http://www.hw-group.com/products/hercules/index_de.html oder auch das Microsoft telnet Programm) was auf dem Modbus Port lauscht anschließt, und dann versuchst ob du dazu eine Verbindung aufgebaut bekommst. Von PC zu PC lässt sich die Verbindung einfacher diagnostizieren, bei der Steuerung müsstest du dich erst leitungstechnisch dazwischenhängen.
    Wie ich schon erwähnte habe ich vernünftige Werte, sobald ich den 48Port-Switch raus lasse und entweder direkt oder über einen kleinen 8Port-Switch gehe.
    Wahnsinn wohnt nur 1 Stockwerk unter dem Genie. Aber Genie ist nichts anderes, als kontrollierter Wahnsinn.

  6. #6
    Registriert seit
    13.09.2007
    Beiträge
    565
    Danke
    50
    Erhielt 65 Danke für 57 Beiträge

    Standard

    Moin
    Die gemanagten Switches sollten immer mit einer festen IP versehen werden. Ansonsten hören die auf alles und versuchen da Daten für sich zu finden. Multicast und die schöne IP Adresse 192.168.0.254 Daher aufpassen. Cisco ist so ein Teil. Sobald irgendwie die Adresse 192.168.0.254 auf taucht bricht das SYstem weg


    Sent from my iPhone using Tapatalk

  7. #7
    Registriert seit
    29.03.2004
    Beiträge
    5.600
    Danke
    141
    Erhielt 1.653 Danke für 1.203 Beiträge

    Standard

    Diese "Baumarktswitche" arbeiten normalerweilse nur auf Osi-Schicht 2. Das heißt sie achten nur auf die MAC-Adressen der Datenpakete, und die IP-Adresse ist dem Switch intern egal, um den Port auszuwählen an den er das Paket weiterleitet.

    Ist der Switch vom Kunden ein Router oder auch Layer 3 Switch, dann kommen in diesem auch die IP-Adressen und Subnetzmasken zum tragen.
    Wenn du bei deinen Teilnehmern von einem 255.255.255.0 Subnetz ausgehst, im Switch steht aber für den Port 255.255.255.128 und das eine Gerät eine IP hat z.B. 192.168.1.10 und das andere 192.168.1.200, dann würde da intern etwas geroutet werden müssen. Das siehst du von außerhalb aber nicht, außer dass deine Pakete nicht am gewünschten Teilnehmer ankommen.

    Vielleicht hat der Kunde auf seinem Switch auch Vlans eingerichtet, und auf dem Port zu deiner Steuerung wird das Vlan-Tag nicht entfernt, und deine Steuerung kommt damit dann nicht mehr klar. Aber das kannst du alles nur mutmaßen. Darum würde ich zwei PCs anschließen und wenn's damit nicht funktioniert, kannst du es dem "Admin" zeigen, ohne dass er sich mit für ihn exotischen Geräten rumärgern muss und es immer wieder auf das Gerät schieben kann.
    Die Genialität einer Konstruktion liegt in ihrer Einfachheit – Kompliziert bauen kann jeder.

    (Sergei Pawlowitsch Koroljow, sowjetischer Konstrukteur von Raketen und Weltraumpionier)

  8. #8
    Registriert seit
    19.02.2016
    Beiträge
    441
    Danke
    7
    Erhielt 53 Danke für 48 Beiträge

    Standard

    Zitat Zitat von Deep Blue Beitrag anzeigen
    Steckt diese im Switch und ich versuche über diesen aus dem Firmennetz zuzugreifen,
    Zitat Zitat von Thomas_v2.1 Beitrag anzeigen
    Vielleicht hat der Kunde auf seinem Switch auch Vlans eingerichtet, und auf dem Port zu deiner Steuerung wird das Vlan-Tag nicht entfernt, und deine Steuerung kommt damit dann nicht mehr klar.
    Das klingt ganz arg nach VLans...

    Häng mit der gleichen IP und SNM mal je einen PC/Laptop für die beiden Steuerungen an die jeweiligen Ports. Ist wirklich der beste Weg um deinem Problem auf die Schliche zu kommen
    Denn wenn Ping geht, aber sonst nix, beide allerdings ein Gateway des Firmennetzwerkes haben. Dann kann es dir auch gut passieren, dass das vermeintliche "Gateway" eine Firewall ist die für dich halt eben nur Ping zulässt

    MfG Fabsi

  9. #9
    Registriert seit
    29.03.2004
    Beiträge
    5.600
    Danke
    141
    Erhielt 1.653 Danke für 1.203 Beiträge

    Standard

    Zitat Zitat von Fabpicard Beitrag anzeigen
    Denn wenn Ping geht, aber sonst nix, beide allerdings ein Gateway des Firmennetzwerkes haben. Dann kann es dir auch gut passieren, dass das vermeintliche "Gateway" eine Firewall ist die für dich halt eben nur Ping zulässt
    Dass ein Ping geht hatte ich überlesen. Das würde dann wirklich eher für eine Firewall / Paketfilter sprechen, denn die Ping-Pakete werden ja ebenfalls ggf. geroutet. Vielleicht mal die Steuerung abziehen und prüfen ob dann ein Ping wirklich nicht mehr funktioniert, nicht dass da ein anderes Gerät antwortet.
    Die Genialität einer Konstruktion liegt in ihrer Einfachheit – Kompliziert bauen kann jeder.

    (Sergei Pawlowitsch Koroljow, sowjetischer Konstrukteur von Raketen und Weltraumpionier)

  10. #10
    Deep Blue ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    31.08.2006
    Ort
    OH
    Beiträge
    273
    Danke
    69
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Um die Topologie noch einmal zu verdeutlichen habe ich mal laienhaft ein Bild erstellt.

    Nun ist der Admin aber erst mal krank

    Wahrscheinlich hat ihn das Gespräch gestern so mitgenommen das er außer Gefecht ist. Ich würde ihm den Vorschlag mit der Firewall weiter geben. Habe leider keine Möglichkeit dem managed Switch zu editieren.
    Angehängte Grafiken Angehängte Grafiken
    Wahnsinn wohnt nur 1 Stockwerk unter dem Genie. Aber Genie ist nichts anderes, als kontrollierter Wahnsinn.

Ähnliche Themen

  1. TP900 via Profibus stört PC Runtime
    Von Memnon im Forum HMI
    Antworten: 8
    Letzter Beitrag: 05.05.2015, 10:36
  2. "Index Pulse", "Home Switch" und "Position Limit Switch"
    Von senmeis im Forum Antriebstechnik
    Antworten: 3
    Letzter Beitrag: 07.03.2011, 11:21
  3. Schütz stört sichere Kleinsteuerung
    Von cliffmc im Forum Schaltschrankbau
    Antworten: 26
    Letzter Beitrag: 24.02.2009, 00:01
  4. ET 200 stört Profibus
    Von emtewe im Forum Simatic
    Antworten: 12
    Letzter Beitrag: 08.08.2006, 10:03
  5. PPI && TD200 stört die Verbindung zum PC
    Von Anonymous im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 10.11.2004, 14:39

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •