Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 13

Thema: 2 bis 4 Phoenix "IBS S7 400 DSC/I-T" an eine CPU

  1. #1
    Registriert seit
    03.02.2004
    Beiträge
    117
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo!

    Ich bin gearde dabei zu versuchen mehrere dieser Karten hinter einer CPU zu betreiben.

    Die Parametrierung erfolgt über einen DB und ich habe mittlerweile 2 KArten im Modus Run.

    Nur leider geht meine CPU dann in Stop. Hat einer sowas schonmal gemacht und Erfahrung damit?
    Zitieren Zitieren 2 bis 4 Phoenix "IBS S7 400 DSC/I-T" an eine CPU  

  2. #2
    Registriert seit
    30.08.2003
    Beiträge
    2.197
    Danke
    30
    Erhielt 258 Danke für 229 Beiträge

    Standard

    Hallo,

    du brauchst erstmal für jede Anschaltbaugruppe einen eigenen DB. Also DB20 kopieren. Die Aufrufe FC20/21/22 musst du auch für jede Anschaltbaugruppe separat machen. Die Adressen im S5-Adapter dürfen sich genauso wenig überlappen wie die Kommunikationsregister. Im CMD musst du auf den richtigen Steckplatz achten. Dann müsste es gehen. Kannst ja mal dein Projekt mailen.

    MfG
    André Räppel
    Zitieren Zitieren S7/400 DSC-I/T  

  3. #3
    Rengel ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    03.02.2004
    Beiträge
    117
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo!

    Als erstes mal Danke für die Tips, werde ich gleich mal umsetzen!

    Also das ganze soll soll Asynchron mit synchronisationsimpuls laufen. Daher arbeite ich nicht mit dem Step5 Adapter sondern mit der Pos.-baugruppe FM451.

    Den IBDB für die Baugruppen habe ich natürlich seperat gemacht Das die FC's 20/21/22 auch für jede Baugruppe seperat müssen verwirrt mich ein wenig da ein FC je gerade dafür da ist nur einmal abgespeichert und mehrfach genutzt werden zu können. Die Karten werden auch problemlos parametriert und gestartet. Bei CPU in Stop auf RDY und bei CPU in RUN (Da bleibt sie jetzt auch) geht Karte eins auf Run und Karte 2 auf Störung.

    Also mein Status ist im Moment wie folgt:

    Die erste Baugruppe (Prozessalarm OB 40) ist im Run Modus!

    Die zweite Baugruppe (Prozessalarm OB 41) ist in Störung mit folgender Meldung:
    BUS
    BDE
    0000

    Dazu sagte man mir bei Phoenix das die Baugruppe keinen PA auslösen kann.

  4. #4
    Rengel ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    03.02.2004
    Beiträge
    117
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ach sorry, habe dich da eben wohl etwas falsch verstanden!

    Du sprachst ja von den Aufrufen und nicht von den FC's. Habe ich aber auch schon seperat gemacht.

  5. #5
    Rengel ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    03.02.2004
    Beiträge
    117
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Schön schön, Problem gelöst!

    Es reicht nicht wie vermutet, nur in in CMD den OB für den PA einzustellen. Man muss diesen auch noch in der Hardwarekonfiguration der SPS bei der Karte einstellen.

    Und das kann man nur wenn man im letzten Register den PA anwählt und dann wird diese Option in der zweiten Registerkarte freigeschaltet. Habe ich dann leider übersehen. Etwas unglücklich gelöst das ganze aber jetzt geht es!

  6. #6
    Registriert seit
    30.08.2003
    Beiträge
    2.197
    Danke
    30
    Erhielt 258 Danke für 229 Beiträge

    Standard

    Na hallo,

    sowas dachte ich mir schon. Kann nur irgendwas mit dem OB sein.. Ob nun im CMD oder auf der S7-Seite. Die Anschaltbaugruppe hat dann auf den FC28-Aufruf gewartet und nix kam... Mit wievielen Datensätzen arbeiteste denn?

    MfG
    André Räppel
    Zitieren Zitieren Interbus  

  7. #7
    Rengel ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    03.02.2004
    Beiträge
    117
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo!

    Also die größte der CPU's hat vier IBS Karten und alle haben durchschnittlich eine Datensatzlänge im Eingangs- und Ausgangsbereich von ca. 50-70 Byte. Eingelesen wird alles in DB's so das ich die Daten dann auch schon schön in Wincc einbinden kann.

    Ansonsten sind das insg. 10 CPU's mit 20 IBS Karten.

  8. #8
    Rengel ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    03.02.2004
    Beiträge
    117
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ich habe da jett noch ein kleines Problem, vielleicht weiss ja jemand Rat

    Es sieht z.B. wie folgt aus:

    NMach dem einschalten des Hauptschalters werden nur ein Teil der Busmodule mit Spannung versorgt. Der Rest ist also "tot" und ich erhalte somit einen Busfehler in den Karten. Nun sollen aber die andren Karten per "Steuerspanung Ein" zugeschaltet werden. Nur leider liegt dieser Taster auf einem der Module die schon mit Spg. versorgt werden und der Eingang wird daher nicht eingelesen. Gibt es also eine Möglichkeit, aktuelle DAten von einem Bus zu bekommen der eigentlich in Störung ist?

    Ich habe überlegt das ganze so zu realisieren erst nur einige Module per Konfiguration freizuschalten und mit St.spg. ein die restlichen aber das ist ja unheimlich aufwendig!

    Die "unsinnige " verdrahtung ist leider so gegeben, da es sich um eine Altanlage handelt!

  9. #9
    Registriert seit
    30.08.2003
    Beiträge
    2.197
    Danke
    30
    Erhielt 258 Danke für 229 Beiträge

    Standard

    Hallo,

    den Interbus kann man nur im Zustand RUN einlesen. Es gibt die Möglichkeit Teilnehmer zu brücken usw. Aber dann muss dein Busaufbau bis zu dem gewünschten Teilnehmer trotzdem io sein. Ich würde ein extra Kabel einziehen, so erspart man sich undurchsichtiges Gebastel.

    MfG
    André Räppel
    Zitieren Zitieren Interbus  

  10. #10
    Rengel ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    03.02.2004
    Beiträge
    117
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Und genau an dieser Überbrückung arbeite ich gerade!

    Das Problem ist, das es sich um eine Altanlage handelt, die von S5 auf S7 modernisiert wird. Also fällt eine umverdrahtung der Anlage wohl aus, da es ja auch so geht

Ähnliche Themen

  1. Phoenix contact "BLUEMARK X1" Tintenverbrauch ?
    Von Waelder im Forum PHOENIX CONTACT
    Antworten: 5
    Letzter Beitrag: 12.05.2011, 11:31
  2. "Index Pulse", "Home Switch" und "Position Limit Switch"
    Von senmeis im Forum Antriebstechnik
    Antworten: 3
    Letzter Beitrag: 07.03.2011, 11:21
  3. Mit Skript eine Schaltfläche "betätigen"
    Von Shettyman im Forum HMI
    Antworten: 3
    Letzter Beitrag: 21.07.2010, 10:10
  4. Wie "gefährlich" darf eine Maschine bleiben?
    Von element. im Forum Maschinensicherheit - Normen und Richtlinien
    Antworten: 12
    Letzter Beitrag: 24.11.2009, 16:55
  5. Ist eine "universelle" Profibus Slave möglich?
    Von JesperMP im Forum Feldbusse
    Antworten: 8
    Letzter Beitrag: 17.03.2008, 10:38

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •