Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 14

Thema: Phoenix ILC 350PN - Schnelle digitale Eingänge

  1. #1
    Registriert seit
    26.02.2008
    Ort
    Kulmbach
    Beiträge
    151
    Danke
    13
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Leute,

    habe kurz eine Frage zum Phoenix Contact Controller ILC350PN und den dabei zur Verfügung stehenden schnellen digitalen Eingängen.
    Weiß zufällig jemand, wieviele Impulse/Zeit dieser Eingang verarbeiten kann?
    Möchte einen Durchflussmesser an einen der Eingänge anbinden, dieser liefert ca. 1000 Impulse pro Liter bei einem Durchfluss von ca. 1,5 L/min, d. h. ich hätte ca. 25 Impulse pro Sekunde.
    Kann der Eingang das auswerten oder was könnte man sonst noch machen?

    Danke für die Antwort

    Vaninger
    Zitieren Zitieren Phoenix ILC 350PN - Schnelle digitale Eingänge  

  2. #2
    Registriert seit
    25.06.2008
    Ort
    Blomberg/Lippe
    Beiträge
    1.293
    Danke
    51
    Erhielt 130 Danke für 124 Beiträge

    Standard

    Hallo Vaninger,

    also die normalen Eingänge erfassen Signalwechsel von 0 nach 1 bis 500µs, von 1 nach 0 bis 700µs. Die schnellen Eingänge erfassen Signalwechsel von 0 nach 1 bis 5µs, von 1 nach 0 bis 2µs. Ich denke das wird deine Frage beantworten.
    Gruß
    Mobi


    „Das Einfache kompliziert zu machen ist alltäglich. Das Komplizierte einfach zu machen –
    das ist Kreativität“ (Charles Mingus).

  3. #3
    Vaninger ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    26.02.2008
    Ort
    Kulmbach
    Beiträge
    151
    Danke
    13
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Mobi,
    danke für die Antwort!

    Vielleicht kannst du mir bei meinem Problem mit meinem Analogausgang auch helfen. Ich benutze, wie schon erwähnt, eine Phoenix ILC350PN, an die ich mittlerweile auch noch einige Inlineklemmen angeschlossen habe.
    Jetzt zu meinem Problem
    Ich möchte gerne die Analogausgangsklemme IB IL AO 2/U/BP verwenden, und habe hier zur Parametrierung folgende Einstellungen vorgenommen:



    Wenn ich den Baustein aktiviere, kommt folgender Fehlercode:



    "Analogmodul quittiert Parametrierung innerhalb von 5 Sekunden nicht -> Timeout
    Mögliche Fehler: u.a.

    • Falscher Modultyp parametriert
    • Prozessdatenzuordnung fehlerhaft"

    Wie kann ich diesen Fehler beheben. Habe schon den Modultyp geändert, sollte aber hier 2 sein. Oder liegt es am dwInputAddress, da ich hier keinen Wert eingetragen habe und auch nicht weiß, was ich hier eintragen muss...

    Jemand eine Idee?

    Danke

    Gruß

    Vaninger
    Geändert von Vaninger (08.01.2011 um 18:38 Uhr)

  4. #4
    Registriert seit
    25.06.2008
    Ort
    Blomberg/Lippe
    Beiträge
    1.293
    Danke
    51
    Erhielt 130 Danke für 124 Beiträge

    Standard

    Welchen Baustein nutzt du denn? Und wie sehen die Einstellungen aus? Hab zufällig dieselbe Klemme hier liegen.
    Gruß
    Mobi


    „Das Einfache kompliziert zu machen ist alltäglich. Das Komplizierte einfach zu machen –
    das ist Kreativität“ (Charles Mingus).

  5. #5
    Vaninger ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    26.02.2008
    Ort
    Kulmbach
    Beiträge
    151
    Danke
    13
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Mobi,
    vielen dank für die Antwort. Als Klemme verwende ich diese:

    IB IL AO 2/U/BP

    Laut LED Anzeige ist er im Auslieferungszustand parametriert. Wie du auf den Bildern sehen kannst, verwende ich die Bausteine IL_AO_V1_01 sowie IL_AO_Channel_V1 aus der AnalogTechnolgy_V1.2 Bibliothek von Phoenix.

    Was brauchst du noch für Angaben?

    Schöne Grüße

    Vaninger

  6. #6
    Registriert seit
    29.07.2008
    Beiträge
    143
    Danke
    4
    Erhielt 27 Danke für 21 Beiträge

    Standard

    Wie kann ich diesen Fehler beheben. Habe schon den Modultyp geändert, sollte aber hier 2 sein. Oder liegt es am dwInputAddress, da ich hier keinen Wert eingetragen habe und auch nicht weiß, was ich hier eintragen muss...




    dwInputAddress ist die phsikalische Verbindung zu der Inlineklemme. Im Bereich Prozessdatenzuordnung kannst du die Verbindung einer DWORD Variable herstellen. einmal an den Baustein im Code und in den Prozessdaten zu der Inlineklemme, gilt ebenfalls für dwOutput

  7. Folgender Benutzer sagt Danke zu Oerw für den nützlichen Beitrag:

    Vaninger (10.01.2011)

  8. #7
    Registriert seit
    25.06.2008
    Ort
    Blomberg/Lippe
    Beiträge
    1.293
    Danke
    51
    Erhielt 130 Danke für 124 Beiträge

    Standard

    Eben die Bilder, die kann ich nich nicht sehen.
    Gruß
    Mobi


    „Das Einfache kompliziert zu machen ist alltäglich. Das Komplizierte einfach zu machen –
    das ist Kreativität“ (Charles Mingus).

  9. #8
    Vaninger ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    26.02.2008
    Ort
    Kulmbach
    Beiträge
    151
    Danke
    13
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,

    im Anhang nochmal der Programmauszug sowie die Prozessdatenzuordnung.
    Womit muss ich jetzt das Eingangswort verbinden?

    Schöne Grüße

    Vaninger
    Angehängte Grafiken Angehängte Grafiken

  10. #9
    Registriert seit
    25.06.2008
    Ort
    Blomberg/Lippe
    Beiträge
    1.293
    Danke
    51
    Erhielt 130 Danke für 124 Beiträge

    Standard

    Verbinde mal in der Prozessdatenzuordnung AI32 mit dwInputAddress.
    Gruß
    Mobi


    „Das Einfache kompliziert zu machen ist alltäglich. Das Komplizierte einfach zu machen –
    das ist Kreativität“ (Charles Mingus).

  11. Folgender Benutzer sagt Danke zu Mobi für den nützlichen Beitrag:

    Vaninger (10.01.2011)

  12. #10
    Vaninger ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    26.02.2008
    Ort
    Kulmbach
    Beiträge
    151
    Danke
    13
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,
    vielen Dank, funktioniert...

    Schöne Grüße
    Vaninger

Ähnliche Themen

  1. B&R X20BC0087 digitale eingänge forcen
    Von kag1@softsolution.at im Forum HMI
    Antworten: 3
    Letzter Beitrag: 14.03.2011, 08:51
  2. Wago Modbus 8 Digitale Eingänge auf 1 Modbusregister
    Von Speedtriple im Forum CODESYS und IEC61131
    Antworten: 2
    Letzter Beitrag: 08.10.2010, 12:30
  3. 358 Digitale Eingänge Erfassen und Auswerten
    Von Hector im Forum Simatic
    Antworten: 25
    Letzter Beitrag: 13.07.2010, 10:13
  4. Kabel für Digitale Eingänge
    Von klaus1 im Forum Elektronik
    Antworten: 5
    Letzter Beitrag: 12.05.2010, 21:01
  5. Adressierung digitale Eingänge S7 CPU224
    Von lan12 im Forum Simatic
    Antworten: 11
    Letzter Beitrag: 13.09.2008, 13:09

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •