Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Results 1 to 2 of 2

Thread: Kommunikationsfehler PNOZ mc3p

  1. #1
    Join Date
    07.01.2020
    Posts
    2
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Guten Morgen,

    ich habe an einer Trainingsanlage ein PNOZ mc3p Profibus-Kommunikationsmodul an einer m1p hängen, welches mir seit kurzem Probleme bereitet.

    Ursprünglich bestand das Profibussystem aus einer Siemens 318 2DP als Master und einiger Slaves u.a. dem mc3p. Seit der Implementierung gab es niemals Probleme mit dem Ding.
    Vor kurzem ist dann die MPI-Schnittstelle der 318 defekt gewesen und diese wurde gegen eine 315 2DP 6ES7 315-2AF03-0AB0 E-Stand 2 getauscht. Ein älteres Modell, da ich nix neues/teures nehmen darf. Profibus-Netzwerk neu gemacht und alle Slaves neu eingebunden, es befindet sich noch kein lauffähiges Programm auf der CPU. Alle Slaves sind i.O., nur das mc3p stellt keine brauchbare Kommunikation mehr her.
    Zum Test mit der selben Hardware (Kabel, Stecker, andere Slaves) an eine 314C 2DP angeschlossen, dort läuft es auf Anhieb ohne Probleme.
    Zum weiteren Test wurde eine weitere typgleiche 315 2DP angeschlossen, dort ergibt sich das selbe Problem.
    Step7 Hardware-Diagnose sagt mir, dass der Teilnehmer projektiert aber nicht vorhanden ist und Slave-Diagnose des mc3p zeigt die im Bild gezeigten Fehler an.mc3p_1.jpg

    Der Slave ist zumindest erreichbar, ist aber falsch konfiguriert oder antwortet nur Müll. Auffällig ist noch, das mein Master die Adresse 4 hat. Im Bild aber die Master-Adresse als 0 angegeben wird. Wenn ich das mc3p neustarte ändert sich die Zahl auch mal in eine 32 oder 49. Und in ganz seltenen Fällen ist nach einem Neustart alles funktionsfähig und die Kommunikation steht.

    Es hat was mit dem CPU-Typ zu tun. Vielleicht irgendeine Grundeinstellung die anders ist als bei der 318 oder 314C. Hat einer eine Idee was?

    Ein ähnliches Problem hab ich übrigens auch noch seit dem CPU-Wechsel mit einem ESD CANopen-DP Gateway, welches an der 314C einwandfrei funktioniert.
    Kann die CPU einfach zu alt sein?

    Vielen Dank im voraus.
    Last edited by Emanon; 02.03.2020 at 23:22.
    Reply With Quote Reply With Quote Kommunikationsfehler PNOZ mc3p  

  2. #2
    Emanon is offline Neuer Benutzer
    Themenstarter
    Join Date
    07.01.2020
    Posts
    2
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Wie vermutet sind die CPU zu alt. Hab eine neuere 315-2DP 315-2AG10 und es funktioniert einwandfrei.

Similar Threads

  1. Verkaufe Pilz PNOZ X1 und PNOZ XV2
    By acid in forum Suche - Biete
    Replies: 0
    Last Post: 07.01.2012, 17:01
  2. Pilz mc3p
    By jabba in forum PILZ
    Replies: 8
    Last Post: 02.07.2011, 13:42
  3. TwinSAFE Kommunikationsfehler (COM ERR)
    By HK09 in forum CODESYS und IEC61131
    Replies: 1
    Last Post: 04.02.2011, 17:58
  4. TwinSAFE Kommunikationsfehler
    By HK09 in forum CODESYS und IEC61131
    Replies: 1
    Last Post: 20.09.2010, 09:43
  5. Kommunikationsfehler DP_/DP
    By mitchih in forum Feldbusse
    Replies: 6
    Last Post: 10.03.2009, 21:58

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •