Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: unterbrochenes Signal kurzzeitig wieder zuschalten???

  1. #1
    Registriert seit
    25.03.2008
    Beiträge
    4
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hi,
    Ich hab ein Problem mit einer Anlage: Ich frage das vorhanden sein von Werkstücken mit einem Licht-Wellen-Leiter ab. Habe also wenn Werkstücke vorhanden sind immer ein "0" Signal an der SPS anliegen. Wenn sich die Werkstücke allerdings stauen, bekomme ich durchgehend ein dieses "0" Signal. Gibt es eine möglichkeit, trotz des unterbrochenen LWL´s kurzzeitig ein "1" Signal an diesen Eingang zu legen?
    Zitieren Zitieren unterbrochenes Signal kurzzeitig wieder zuschalten???  

  2. #2
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.227
    Danke
    534
    Erhielt 2.698 Danke für 1.950 Beiträge

    Standard

    Man kann einen Eingang im Programm auf 1 setzen, für den Rest des Progammablaufes in dem betreffenden SPS-Zyklus (bis zum erneuten Einlesen des PA) ist dieser Eingang dann True. Aber wozu soll das in deinem Falle genau gut sein?

    Bsp.:
    Dies könnte am Anfang deines OB1 stehen. Wenn du irgendwo im Programm den M100.0 setzt, ist der E0.0 ab dem nächsten Zyklus so lange True, bis du den M100.0 wieder auf False setzt und natürlich auch der eingelesene E0.0 kein True erhält.

    U E0.0
    O M100.0
    = E0.0

    Wenn du so etwas tust, solltest du es möglichst im OB1 am Anfang machen und als Kommentar eine Erläuterung für andere Programmierer einfügen, wozu das dienen soll!
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  3. #3
    Kiesel ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    25.03.2008
    Beiträge
    4
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    ich hab das Problem, das nach dieser Werkstückabfrage ein Vereinzeler gesetzt ist. Dieser macht bisher bei mehreren Werstücken die direkt hintereinander liegen, die erste Schranke jeweils nur beim ersten Werkstück auf, wenn das signal vom LWL nicht zwischendurch wieder da war.

  4. #4
    Registriert seit
    11.10.2005
    Ort
    Pirmasens
    Beiträge
    401
    Danke
    158
    Erhielt 74 Danke für 54 Beiträge

    Standard

    Hi,
    Also Idee kommt mir jetzt nur das du eine Zeitmessung machst also bei einem Positivenimpuls startest du die Zeit die dann die Länge des Werkstückes ist Zeit abgelaufen und keinen Negativenimpuls dann machst Du Dir einen Impuls. Aber das setzt ein langsam laufendes Band und gleichbleibende längen und genau Zeitmessung voraus!

    HDD

  5. #5
    Registriert seit
    04.02.2007
    Beiträge
    2.544
    Danke
    167
    Erhielt 731 Danke für 528 Beiträge

    Standard

    Kann den der Sensor überhaupt eine Lücke zwischen den Werkstücken erkennen ?
    Falls ich das richtig verstanden habe und Du eine Lücke hast, ist bei Stau die Unterbrechungszeit kürzer als die Zykluszeit der SPS.
    Dann könnte man mit einem Impulsverlängerer arbeiten
    Ansonsten würde es mit der Zeitauswertung wie HDD gehen, allerdings wäre dann keine Überwachung der Lichtschranke auf Funktion möglich.

  6. #6
    Registriert seit
    01.08.2006
    Ort
    Nordsaarland
    Beiträge
    1.205
    Danke
    94
    Erhielt 122 Danke für 107 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Wenn da Pausen dazwichen sind, bei Gleichbleibdender länge quasi billig auf negative Flanke abfragen, fehlt diese mit einer Zeit Rückmeldung Materialstau.würde aber bedeuten mindestens soviel Abstand das im Programm die "Lücke" erkannt werden kann.
    Was nicht passt wird Passend gemacht.
    Mehr Powerrrrrr!! *Houwhouwhouw*
    Und Humor ist, wenn man trotzdem lacht.

Ähnliche Themen

  1. Inneren Sicherheitskreis weg- und zuschalten
    Von carsten im Forum Schaltschrankbau
    Antworten: 13
    Letzter Beitrag: 13.10.2010, 10:02
  2. LOGO soll Gastherme zuschalten 24V schaltet 240V
    Von OskarInDerTonne im Forum Elektronik
    Antworten: 9
    Letzter Beitrag: 12.03.2009, 07:57
  3. Zuschalten der SPS-Versorgungsspannung
    Von Markus_Sch im Forum Schaltschrankbau
    Antworten: 12
    Letzter Beitrag: 15.03.2006, 15:48
  4. HTL Signal?
    Von Markus_Sch im Forum Elektronik
    Antworten: 0
    Letzter Beitrag: 27.01.2006, 11:43
  5. Leuchtmelder mit LED gehen kurzzeitig alle an. Warum?
    Von Anonymous im Forum Schaltschrankbau
    Antworten: 4
    Letzter Beitrag: 30.01.2005, 23:53

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •