Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 13

Thema: Regelventile ohne Stellungsrückmeldung

  1. #1
    Registriert seit
    29.03.2004
    Beiträge
    5.735
    Danke
    143
    Erhielt 1.685 Danke für 1.225 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,
    an Heizungsanlagen hat man ja öfters Stellventile nur mit Befehlen "Auf" und "Zu", aber ohne Stellungsrückmeldung.

    Die Ansteuerung bei einem einzelnen Ventil ist dabei recht einfach, da ich dazu je nach Soll-/Ist-Abweichung die Verfahrzeit
    berechne. Also die Funktion wie der z.B. CONT_S-Regler aus der Siemens PID-Bibliothek.

    Nun habe ich eine Anwendung bei der ich intern die Ist-Stellung des Ventils berechnen muss, damit ich das Ventil auf eine von extern
    vorgegebe Stellung fahren kann (0-100%).

    Dazu messe ich einmal die Laufzeit des Ventils von auf bis zu, und weiß somit dass wenn ich vom Programm das Ventil z.B. 1 Sekunde
    ansteuere, es um z.B. 1% verfährt.
    Da sich die Laufzeit in gewissem Maße verändert, mache ich normalerweise z.B. einmal pro Tag eine Initialisierungsfahrt um die Laufzeit zu messen.

    In diesem Fall geht das aber nicht, da durch diese Messfahrt eine Übertemperatur ansprechen würde.
    Hinzukommt, dass meine einzige Rückmeldung vom Ventil nur die "Endlage auf" ist.

    Meine Initialisierungsfahrt besteht darum zur Zeit nur daraus, dass ich das Ventil einmal am Tag komplett schließe damit die berechnete Ist-Stellung nicht ganz aus dem Ruder läuft.
    Denn durch das ständige Verfahren im Regelbetrieb summiert sich der Stellungsfehler im Laufe der Zeit.

    Jetzt das eigentliche Problem:
    Annahme:
    - Sollstellung 100%
    - intern berechnete Stellung ist 100%
    => Ventil würde demnach nicht weiter angesteuert werden
    - wirkliche Stellung ist aber 80%

    Ich könnte es im Programm so machen, dass ich bei 100% Sollwert das Ventil dauerhaft mit Befehl "auf" ansteuere.
    Dann würde das Ventil aber mehr oder weniger unkontrolliert "aufgerissen".

    Gleiches gilt auch für die andere Richtung
    - Sollstellung 0%
    - intern berechnete Stellung ist 0%
    - wirkliche Stellung ist 10%

    Testweise mache ich es jetzt in diesem Fall mit einer Taktung des Ventils (feste Zeit: 1s ein, 60s aus) in die entsprechende, bin damit aber auch nicht glücklich.

    Vielleicht kennt ja jemand noch eine elegante Möglichkeit (außer Stellungsrückmeldung nachrüsten )

    Gruß
    Thomas
    Zitieren Zitieren Regelventile ohne Stellungsrückmeldung  

  2. #2
    Registriert seit
    16.11.2007
    Beiträge
    742
    Danke
    32
    Erhielt 146 Danke für 114 Beiträge

    Standard

    Zitat Zitat von Thomas_v2.1 Beitrag anzeigen
    Jetzt das eigentliche Problem:
    Annahme:
    - Sollstellung 100%
    - intern berechnete Stellung ist 100%
    => Ventil würde demnach nicht weiter angesteuert werden
    - wirkliche Stellung ist aber 80%

    Gleiches gilt auch für die andere Richtung
    - Sollstellung 0%
    - intern berechnete Stellung ist 0%
    - wirkliche Stellung ist 10%

    Testweise mache ich es jetzt in diesem Fall mit einer Taktung des Ventils (feste Zeit: 1s ein, 60s aus) in die entsprechende, bin damit aber auch nicht glücklich.
    So manchen es eigentliche alle mir bekannten Hersteller von 3P-Regelungen.

    Die Positionen 0% u. 100% dienen zum Synchen - dabei wird das Zu oder Auf-Signal solange getaktet ausgegeben, bis der Stellantrieb sicher die Endstellung angefahren hat (außer Defekt natürlich).

    Ich würde allerdings ein anderes/kürzeres Puls-Pausen-Verhältnis wählen z.B. 1s/5s.

  3. #3
    Registriert seit
    04.02.2007
    Beiträge
    2.544
    Danke
    167
    Erhielt 731 Danke für 528 Beiträge

    Standard

    Ich habe das mal so gemacht, das ich den Schaltnocken auf einen Bereich verstellt habe, der immer in der Regelzone liegt. Jedesmal beim überfahren habe ich einen Wert abhägig von der Richtung als Referenz gesetzt.
    „Wenn du ein Problem hast, versuche es zu lösen. Kannst du es nicht lösen, dann mache kein Problem daraus.“
    Siddhartha Gautama

  4. Folgender Benutzer sagt Danke zu jabba für den nützlichen Beitrag:

    Thomas_v2.1 (04.09.2009)

  5. #4
    Avatar von Thomas_v2.1
    Thomas_v2.1 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    29.03.2004
    Beiträge
    5.735
    Danke
    143
    Erhielt 1.685 Danke für 1.225 Beiträge

    Standard

    Zitat Zitat von GLT Beitrag anzeigen
    Die Positionen 0% u. 100% dienen zum Synchen - dabei wird das Zu oder Auf-Signal solange getaktet ausgegeben, bis der Stellantrieb sicher die Endstellung angefahren hat (außer Defekt natürlich).

    Ich würde allerdings ein anderes/kürzeres Puls-Pausen-Verhältnis wählen z.B. 1s/5s.
    Das finde ich aber recht schnell. Diese Taktung muss ja auf jeden Fall langsamer sein als der Regler der davor hängt, damit dieser ggf. noch gegensteuern kann falls die Temperatur durch die Taktung ansteigt/abfällt.

    Gibt es irgendwo Informationen wie diese "bekannten Hersteller" das lösen?

    Zitat Zitat von jabba Beitrag anzeigen
    Ich habe das mal so gemacht, das ich den Schaltnocken auf einen Bereich verstellt habe, der immer in der Regelzone liegt. Jedesmal beim überfahren habe ich einen Wert abhägig von der Richtung als Referenz gesetzt.
    Das ist mal eine gute Idee!
    Ich werde mal nachschauen ob ich das bei den vorhandenen Ventilen auch verstellen kann.
    Wenn ich den Schaltkontakt bei 50% positionieren könnte, bräuchte ich zum synchronisieren auch nur noch die halbe Fahrzeit des Antriebes.

  6. #5
    Registriert seit
    16.11.2007
    Beiträge
    742
    Danke
    32
    Erhielt 146 Danke für 114 Beiträge

    Standard

    Zitat Zitat von Thomas_v2.1 Beitrag anzeigen
    Das finde ich aber recht schnell..
    Die typische Laufzeit der 3P-Antriebe von Sauter, L&S, Siemens, KP usw. liegen meist um 150Sek; da alle 5s ein 1s Fahrsignal findest Du schnell?

  7. #6
    Avatar von Thomas_v2.1
    Thomas_v2.1 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    29.03.2004
    Beiträge
    5.735
    Danke
    143
    Erhielt 1.685 Danke für 1.225 Beiträge

    Standard

    Nagut, so schnell ist es dann doch nicht

    Ich habe bei mir ziemlich unterschiedliche Ventile drin. Eins mit 70s Laufzeit, und ein anderes mit 8 Minuten (Ex).
    Kann man die Taktungszeiten bei diesen Fertig-Steuerungen von Sauter oder Siemens eigentlich einstellen?
    Machen diese auch eine Initialisierungsfahrt?

  8. #7
    Registriert seit
    16.11.2007
    Beiträge
    742
    Danke
    32
    Erhielt 146 Danke für 114 Beiträge

    Standard

    Die Taktung hängt m.E. von Xp u. Tn ab; Synchronisierung wird besser wurde oft gemacht, wenn innerhalb 24h keine Endstellung erreicht wurde.

    Inzwischen nimmt man in GLTs eigentlich keine 3P-Antriebe mehr, sondern stetige u. da ist das Problem ohnehin nicht mehr existent; auch die Krücke mit Endschaltern (bis auf Hähne) löst man intelligenter mit 10V-Rückmeldungen.

  9. #8
    Registriert seit
    01.01.2009
    Ort
    Niedersachsen
    Beiträge
    813
    Danke
    180
    Erhielt 79 Danke für 75 Beiträge

    Standard

    Ich hatte ein Ventil das ich auf eine genaue Position (0-100%) fahren sollte. Natürlich wollte wider jemand (der Auftraggeber) am falschen Ende sparen. Und hat den Antrieb ohne Rückmeldung (keine Analoge Stellungsrückmeldung und keine Endlagen) bestellt.
    Ich habe auch die Laufzeit gemessen. Die Laufzeit 0-60s entsprechen 0-100%.
    Damit sich der Stellungsfehler (den es in so einem Fall immer gibt) nicht summiert, mache ich bei jeder neuen Positionsvorgabe erst eine Referenzfahrt ( 80s Zufahren) und fahre dann für die berechnete Zeit auf die gewünschte Position. Hat dem Kunden und dem Auftraggeber nicht gepasst, aber ich kann nur das möglichst Beste aus der Situation machen.
    Würde ich Anlagen planen, würde ich IMMER analoge Stellungsrückmeldungen vorsehen. Das Nachrüsten wird immer teurer.

    Gruß Jan

  10. #9
    Avatar von Thomas_v2.1
    Thomas_v2.1 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    29.03.2004
    Beiträge
    5.735
    Danke
    143
    Erhielt 1.685 Danke für 1.225 Beiträge

    Standard

    Bei den Neuanlagen die ich gemacht habe wurden auch immer stetige Ventile mit 0-10 V Ansteuerung verbaut, komplett ohne Rückmeldung. Und die laufen alle einwandfrei.
    Diese Anlage ist aber eine Altanlage / Umrüstung, darum ist meine Bibliothek in der Richtung noch nicht vollständig.

    Aber wenn GLT schreibt dass die üblichen Anbieter das auch mit einer Taktung lösen, bin ich mit meiner Variante zumindest nicht auf dem ganz falschen Dampfer.

  11. #10
    Registriert seit
    16.11.2007
    Beiträge
    742
    Danke
    32
    Erhielt 146 Danke für 114 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Du könntest es Dir aber auch vereinfachen indem Du dir die OSCAT.lib speziell ACTUATOR_3P genauer ansiehst.

    Dürfte alles wichtige für dich drin sein.

Ähnliche Themen

  1. SIL2 Not-Aus ohne SPS und ohne Relais?
    Von mebe90 im Forum Maschinensicherheit - Normen und Richtlinien
    Antworten: 6
    Letzter Beitrag: 10.03.2011, 17:07
  2. Stellungsrückmeldung Überwachung?
    Von Poldi007 im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 06.10.2010, 21:18
  3. Regler aufteilen auf 2 Regelventile
    Von Poldi007 im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 03.05.2010, 14:29
  4. S5 OP7 ohne Bit
    Von marchtin im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 30.07.2008, 09:03
  5. CX1000-Zugriff mit Delphi ohne TwinCat und ohne Modbus
    Von jank-automation im Forum CODESYS und IEC61131
    Antworten: 9
    Letzter Beitrag: 09.06.2008, 09:50

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •