Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 5 ErsteErste 1234 ... LetzteLetzte
Ergebnis 11 bis 20 von 43

Thema: Fototransistor

  1. #11
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.717
    Danke
    443
    Erhielt 919 Danke für 740 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    So in der Art, wie hier im Siemenssupport der 2-Draht-Messumwandler, müsste auch der Fototransistor angeschlossen werden.

  2. Folgender Benutzer sagt Danke zu hucki für den nützlichen Beitrag:

    Hetzer (05.01.2014)

  3. #12
    Registriert seit
    23.07.2009
    Ort
    Österreich
    Beiträge
    2.351
    Danke
    452
    Erhielt 692 Danke für 517 Beiträge

    Standard

    1. Jup, 10VDC Spannungsquelle benötigt. Theoretisch könntest du einen einfachen Spannungsteiler aus 2 Widerständen nehmen um auf die 10VDC zu kommen. Da der Ananlogeingang eh hochohmig ist müsste das hinhauen.

    2. Anschluss 1: +10VDC, Anschluss 2: 16, Anschluss 17 auf Masse (Bezugspotential der verwendeten 10VDC. Wenn du eine separate Quelle zum erzeugen der 10VDC nimmst ist empfehlenswert die beiden Massen miteinander zu verbinden. Machts einfacher.

    3. Willst du mit dem Widerstand dort irgendwas messen, oder war er nur als Beschaltung für freie Klemmen gedacht?
    If at first you don't succeed, you're not Van Damme!
    ... or maybe using TIA!

  4. Folgender Benutzer sagt Danke zu RONIN für den nützlichen Beitrag:

    Hetzer (05.01.2014)

  5. #13
    Hetzer ist offline Benutzer
    Themenstarter
    Registriert seit
    27.09.2013
    Beiträge
    67
    Danke
    11
    Erhielt 0 Danke für 0 Beiträge

    Standard

    So in der Art, wie hier im Siemenssupport der 2-Draht-Messumwandler, müsste auch der Fototransistor angeschlossen werden.
    ahhhhhh ok aber da ist L ja 24V und der analoge eingang geht ja nur bei 10 V?!?!
    aber den messumformer brauche ich nicht oder?

  6. #14
    Hetzer ist offline Benutzer
    Themenstarter
    Registriert seit
    27.09.2013
    Beiträge
    67
    Danke
    11
    Erhielt 0 Danke für 0 Beiträge

    Standard

    3. Willst du mit dem Widerstand dort irgendwas messen, oder war er nur als Beschaltung für freie Klemmen gedacht?
    habe auf einer Siemen Seite gelesen das freie anschlüsse mit einem 1,5-3,3kOhm widerstand beschalten werden müssen... was zwar für Strommessung, klang aber logisch

  7. #15
    Registriert seit
    23.07.2009
    Ort
    Österreich
    Beiträge
    2.351
    Danke
    452
    Erhielt 692 Danke für 517 Beiträge

    Standard

    Deine Photodiode(transitor) ist der 2-Drahtmessumformer.

    Der dort dargestellt 2-Drahtmessumformer ein in Sensor der an seinem 2ten Anschluss 0..10V rausgibt. Das tut deine Diode nicht, die gibt bis zur
    vollen Versorgungsspaunng raus. Dem Analogeingang machen die 24VDC zwar nix. Aber die verlierst natürlich mehr als den Halben Messbereich.
    If at first you don't succeed, you're not Van Damme!
    ... or maybe using TIA!

  8. #16
    Hetzer ist offline Benutzer
    Themenstarter
    Registriert seit
    27.09.2013
    Beiträge
    67
    Danke
    11
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Aber die verlierst natürlich mehr als den Halben Messbereich.
    naja hauptsache da kommt irgendwie ein signal an egal wie groß oder klein....

  9. #17
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.717
    Danke
    443
    Erhielt 919 Danke für 740 Beiträge

    Standard

    Wie hattest Du denn das Ganze an den Digitaleingang angeschlossen? Eigentlich sollte doch der Fototransistor prädestiniert für einen Anschluss zwischen 24V und dem DI sein. Noch ein Pulldown-Widerstand zur Masse als Sicherheit. Da gibt's m.M.n. sogar Vorlagen für.

  10. #18
    Hetzer ist offline Benutzer
    Themenstarter
    Registriert seit
    27.09.2013
    Beiträge
    67
    Danke
    11
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Wie hattest Du denn das an den Digitaleingang angeschlossen?
    Na eine seite 24V dran und andere seite an den eingang... habe ja auch vom fototransistor die spannung gemessen... und hell ca. 23,8V und dunkel ca.7-8V ausprobiert... das ging auch alles einwandfrei... nur wo ich es am eingang hätte kam nix... und wo ich die anschlüsse getauscht habe war immer ein eins signal egal ob hell oder dunkel

  11. #19
    Registriert seit
    23.07.2009
    Ort
    Österreich
    Beiträge
    2.351
    Danke
    452
    Erhielt 692 Danke für 517 Beiträge

    Standard

    Zitat Zitat von hucki Beitrag anzeigen
    Wie hattest Du denn das Ganze an den Digitaleingang angeschlossen? Eigentlich sollte doch der Fototransistor prädestiniert für einen Anschluss zwischen 24V und dem DI sein.
    Hatte ich mich auch schon gewundert. Denn eigentlich müsste der Phototransitor bei ausreichend Licht locker niederohmig genug werden um die ca. 15V zu übersteigen....

    Es wird dir wohl nichts anderes übrig bleiben als mal ein Messgeät in die Hand zu nehmen!

    Hier noch das Handbuch zu deinem Analogmodul (Hab mal google für dich verwendet). Dort steht zum Beispiel auch genau was man mit seinen freien Eingänge machen sollte. Die Betonung liegt aber auf sollt, in freier Wildbahn hab ich noch keinen seine freien Klemmen beschalten sehen.
    https://support.automation.siemens.c...n-US_en-US.pdf
    If at first you don't succeed, you're not Van Damme!
    ... or maybe using TIA!

  12. #20
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.717
    Danke
    443
    Erhielt 919 Danke für 740 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Hetzer Beitrag anzeigen
    und wo ich die anschlüsse getauscht habe war immer ein eins signal egal ob hell oder dunkel
    Bin kein Elektroniker (nur ohne on), klingt aber sehr nach fehlendem Pulldown-Widerstand. Üblicherweise was um die 10k.

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •