Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 16

Thema: Pinbelegung Keyence LR-TB2000 gesucht

  1. #1
    Registriert seit
    12.07.2013
    Beiträge
    22
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    kennt jmd. die Pinbelegung o.g. Sensors?
    Im Datenblatt und auf der Webseite finde ich nichts dazu welcher Pin was ist.

    Danke im Voraus.
    Zitieren Zitieren Pinbelegung Keyence LR-TB2000 gesucht  

  2. #2
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.205
    Danke
    926
    Erhielt 3.293 Danke für 2.662 Beiträge

    Standard

    PDF Seite 13

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  3. Folgender Benutzer sagt Danke zu PN/DP für den nützlichen Beitrag:

    spine2 (05.06.2015)

  4. #3
    spine2 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    12.07.2013
    Beiträge
    22
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard

    braun und blau ist für die Spannung (24V) ist somit klar.
    Wenn ich die Werte die von dem Sensor kommen in die SPS einlesen möchte an welchen Pins muss ich diese abgreifen?
    Ich geb zu das ist mein erstes Mal .

    Ich nehme stark an das schwarz und weiß die ermittelten Daten beinhaltet!
    Wie schließe ich sie an die SPS an? Ich nehme an an ein AI!
    Nur welches Kabel/Farbe bekomme ich die Werte?
    Geändert von spine2 (05.06.2015 um 13:37 Uhr)

  5. #4
    Registriert seit
    26.11.2012
    Ort
    Gummersbach
    Beiträge
    502
    Danke
    18
    Erhielt 71 Danke für 69 Beiträge

    Standard

    Hmm,

    also laut dem Datenblatt gibt es den sowohl mit einem digitalen als auch einem analogen Ausgang - für den digitalen Ausgang benutzt du bitte ein DI auf der SPS
    Ich gehe jetzt mal davon aus, das Du keinen externen Eingang brauchst (mittleres Schaltbild), dann ist in allen Schaltbildern schwarz der Out1, somit solltest Du diesen zunächst mal anschließen, was der Out2 macht lässt sich normalerweise einstellen.
    Ganz kurz ganz hell
    ganz lange ganz dunkel....

  6. Folgender Benutzer sagt Danke zu Morymmus für den nützlichen Beitrag:

    spine2 (05.06.2015)

  7. #5
    spine2 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    12.07.2013
    Beiträge
    22
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke für deine Hilfe.
    Woran erkennst du das es ein für analog und einen für digitalen gibt?
    Alle 2000 haben die selbe Beschreibung womit ich wenig anfangen kann .
    Es ist richtig kein Externer Eingang notwendig, ich benötige lediglich die ermittelten Werte (Abstände).

    Als Anmerkung, ich habe den LR-TB2000CL.
    Da ist der Steuerausgang wie folgt beschrieben:
    "Umschaltbar zwischen NPN offener Kollektor und PNP offener Kollektor
    30 VDC oder weniger, 50 mA oder weniger, Restspannung 2 V oder weniger*3"
    "*3 Sie können den E/A aus den folgenden Kombinationen auswählen.
    Steuerausgang x 2, Steuerausgang + externer Eingang, IO-Link"

    Allerdings kann ich damit nicht viel damit anfangen ^^.

  8. #6
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.205
    Danke
    926
    Erhielt 3.293 Danke für 2.662 Beiträge

    Standard

    Ich kenne den Sensor nicht. Ich lese nur die PDF.

    Der Sensor muß doch irgendwie eingestellt sein und eine Ausgangs-Funktion festgelegt sein.
    Wenn da "Analog"(?) eingestellt ist, dann sollte das Analogsignal am weißen Draht rauskommen.
    Siehe das ganz rechte Schaltbild "When I/O wire (➁ white) is set to Analogue (analogue output)"

    Weiter sollte da einstellbar sein, ob 0/4-20mA (current) oder 0-10V (voltage) oder ??? 'rauskommen "Analogue current/voltage output circuit"
    Der weiße Draht muß passend dazu an einen x-20mA/0-10V-Analogeingang (+) der SPS angeschlossen werden. Bei 20mA vermutlich als aktiver Sensor (Siemens: 4DMU = 4 Draht Meßumformer). Der Minus-Anschluß des Analogeingangs wird mit dem blauen Draht verbunden = 0V

    Details siehe die Dokumentation Deiner SPS/Analogeingänge

    Oder willst/bekommst Du Schaltsignale vom Sensor? Die werden an Digitaleingänge der SPS angeschlossen, in Europa üblicherweise als "PNP"-Signal. siehe die linken Schaltungen

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  9. #7
    Registriert seit
    26.11.2012
    Ort
    Gummersbach
    Beiträge
    502
    Danke
    18
    Erhielt 71 Danke für 69 Beiträge

    Standard

    Die Zeilen bei den Ausgängen in der Tabelle auf Seite 14 sind durchgezogen, daher war ich davon ausgegangen, das diese Informationen für alle Sensoren gilt, ich sehe aber gerade im Kleingedruckten - wenn ich das richtig lese - das es den Analogausgang nur bei den 5000er gibt.
    Den Unterschied zwischen NPN und PNP siehst Du in den Abgebildeten Schaltungen auf Seite 13. Für dich gelten demnach die beiden Schaltungen ganz links, üblich sind bei uns aber Schaltungen als PNP.
    Geändert von Morymmus (05.06.2015 um 14:49 Uhr) Grund: Zu dicke Finger ;-)
    Ganz kurz ganz hell
    ganz lange ganz dunkel....

  10. Folgender Benutzer sagt Danke zu Morymmus für den nützlichen Beitrag:

    PN/DP (05.06.2015)

  11. #8
    spine2 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    12.07.2013
    Beiträge
    22
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Das es nur Digitale sind war mir klar.
    Leider nicht wie ich an die Werte komme!

    Ich habe probiert, was sicherlich sinnlos ist, dort Spannungsänderungen durch veränderten Abstand zu messen.
    Je nach eingestellte Abstände kann ich an weiß entweder 9V bzw. 24V messen.
    Somit kann ich scheinbar nur abfragen ob in einem Bestimmten Bereich etwas dedektiert wird!

  12. #9
    Registriert seit
    15.07.2008
    Ort
    Ørting Danmark
    Beiträge
    122
    Danke
    13
    Erhielt 23 Danke für 17 Beiträge

    Standard

    Nach welchen der Anschlussbilder ist den dein Sensor angeschlossen?
    Und wie ist er eingestellt NPN oder PNP?

  13. #10
    spine2 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    12.07.2013
    Beiträge
    22
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich habe schwarz an Masse gelegt und ist somit PNP.

Ähnliche Themen

  1. Keyence LK-G an S7 SPS
    Von sschnurr im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 25.07.2011, 08:04
  2. Biete: Keyence Laser WegmessSensor
    Von krainer im Forum Suche - Biete
    Antworten: 0
    Letzter Beitrag: 14.12.2010, 19:24
  3. Siemens AI Karten / Keyence Farbsensoren
    Von Jetfix im Forum Suche - Biete
    Antworten: 0
    Letzter Beitrag: 22.11.2010, 12:18
  4. Antworten: 12
    Letzter Beitrag: 25.09.2008, 22:00
  5. Keyence LK-G an Mitsubishi E1070 HMI
    Von blubb0r im Forum HMI
    Antworten: 0
    Letzter Beitrag: 17.10.2007, 14:47

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •