Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: ifm O3D310 Sensor im TIA Portal

  1. #1
    Registriert seit
    17.03.2016
    Beiträge
    15
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Guten Morgen Zusammen,
    hat einer von euch schonmal mit diesem 3D-Sensor gearbeitet? Den Sensor habe ich im TIA V13 Sp1 bereits projektiert. Der Sensor verfügt über einen ProfiNet Anschluss. Wie kann ich Daten von einem "ProfiNet"-Sensor auslesen? Gibt es dafür auch FBs wie für OpenUser Communication?

    Danke vorab!
    Zitieren Zitieren ifm O3D310 Sensor im TIA Portal  

  2. #2
    Registriert seit
    04.10.2010
    Beiträge
    166
    Danke
    45
    Erhielt 34 Danke für 27 Beiträge

    Standard

    Hallo,

    hatte das damals mit der ifm Steuerung mal gehabt.
    Soweit ich mich erinnere bietet ifm Bausteine dafür an.

    Schau mal hier: https://www.ifm.com/de/de/search?que...alanddownloads

    Da müsste was dabei sein.

    MfG,
    Micha

  3. #3
    Erik10 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    17.03.2016
    Beiträge
    15
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Dort habe ich schon nachgeschaut. Dort haben die zwar Bausteine, aber die sind für die "normale" TCP/IP-Verbindung. Für ProfiNet habe ich nichts gefunden. Oder macht das kein Unterschied?

  4. #4
    Registriert seit
    04.10.2010
    Beiträge
    166
    Danke
    45
    Erhielt 34 Danke für 27 Beiträge

    Standard

    Hallo,

    also wie gesagt ist schon etwas her als ich damit zu tun hatte.
    Die Bausteine sollten einwandfrei funktionieren. Zumindest gabs damals keine Probleme damit.

    War eher die Problematik die Kamera richtig einzustellen.....


    MfG,
    Micha

  5. #5
    Erik10 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    17.03.2016
    Beiträge
    15
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Die Bausteine verwenden ja OpenUser-Bausteine (TCON, TRCV) etc. Dies will ich vermeiden und daher direkt mit ProfiNet verbinden. In der Gerätekonfig ist auch soweit alles parametriert. Ich wollte mit dem Baustein RDREC den String empfangen und auswerten. Aber dies klappt nicht. Ich muss mich wahrscheilich erstmal noch vergewissern, ob der String auch tatsächlich über die ProfiNet-Prozessschnittstelle verschickt wird.

    Welchen Baustein könnt ihr mir sonst empfehlen, um Telegramme von ProfiNet-Teilnehmern zu empfangen und hin zu schicken?

  6. #6
    Registriert seit
    30.11.2008
    Ort
    Baesweiler
    Beiträge
    697
    Danke
    211
    Erhielt 106 Danke für 75 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Schau dir mal das Handbuch an, im Anhang 13.5.2 steht, was du machen musst um aus dem Sensor die Daten zu bekommen.
    Markus Nüsser
    Equipment: XMG P705, 32GB Ram, 512GB SSD + 1TB SSD
    Liebstes Werkzeug: Mein Softing ProfiBus-Tester, Dremel Lötkolben, Weber Grill

    ---------------------------
    Chatten rund um SPS und Banalitäten...
    irc://irc.rbx.fr.euirc.net/#sps-forum

Ähnliche Themen

  1. TIA CPU314 IFM im Tia Portal V13 nachträglich einfügen
    Von Deforce1988 im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 06.10.2014, 16:36
  2. Verbindung zwischen ifm sensor und cp
    Von Ötzwurst im Forum Simatic
    Antworten: 12
    Letzter Beitrag: 07.09.2012, 08:05
  3. Antworten: 0
    Letzter Beitrag: 06.04.2012, 08:37
  4. Antworten: 0
    Letzter Beitrag: 22.01.2012, 18:59
  5. IFM 03d200 Sensor
    Von bluebird277 im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 14.11.2011, 15:47

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •