Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 12

Thema: SEW DOP11A-10 an Siemens S7 300 anbinden

  1. #1
    Registriert seit
    05.04.2005
    Ort
    Raesfeld
    Beiträge
    195
    Danke
    32
    Erhielt 11 Danke für 11 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Guten Tag,

    ich möchte ein SEW DOP11A-10 Bedienpanel an eine Siemens S7 300 anschließen. Das Bedienpanel verfügt über eine RS 485 Schnittstelle und die notwendigen Treiber für MPI. Mein Problem ist die physikalische Anbindung an die MPI Schnittstelle.

    Anbei habe ich einen Link zu einer PDF. Auf Seite 288 steht die Steckerbelegung der RS 485 Schnittstelle des Bedienpanels.

    Jetzt fehlt mir eigentlich nur ein Schaltbild der MPI-Schnittstelle damit ich ein Kabel konfektionieren kann.

    Vielleicht hat ja schon mal jemand so etwas gemacht und kann mir erklären wie ich das machen kann.

    http://www.sew-eurodrive.de/download/pdf/11424206.pdf

    Zitieren Zitieren SEW DOP11A-10 an Siemens S7 300 anbinden  

  2. #2
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.732
    Danke
    314
    Erhielt 1.520 Danke für 1.282 Beiträge

    Standard

    Das Bild ist aus der Hilfe vom E-Designer,
    da SEW hier auch offensichtlich gelabelte Beijer Geräte verkauft, sollte das passen!

    Wichtig: Die Baudrate auf dem MPI-Netz musst du auf 19,2 kbit/s drosseln.

    Mfg
    Manuel
    Angehängte Grafiken Angehängte Grafiken
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  3. Folgender Benutzer sagt Danke zu MSB für den nützlichen Beitrag:

    nico (24.11.2008)

  4. #3
    nico ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    05.04.2005
    Ort
    Raesfeld
    Beiträge
    195
    Danke
    32
    Erhielt 11 Danke für 11 Beiträge

    Standard

    Super! Danke Dir!

    Eine Frage noch: Benötige ich die Abschlusswiderstände auch bei einer Punkt zu Punkt-Verbindung. Wenn ja könnte ich die ja einfach mit in den Stecker einlöten, oder?

  5. #4
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.732
    Danke
    314
    Erhielt 1.520 Danke für 1.282 Beiträge

    Standard

    Inoffiziell kannst du das bei den typischen 3m Kabel weglassen.

    Du kannst die Widerstände aber natürlich auch einlöten.

    Mfg
    Manuel
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  6. Folgender Benutzer sagt Danke zu MSB für den nützlichen Beitrag:

    nico (24.11.2008)

  7. #5
    nico ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    05.04.2005
    Ort
    Raesfeld
    Beiträge
    195
    Danke
    32
    Erhielt 11 Danke für 11 Beiträge

    Standard

    Moin

    Wie gehe ich am besten vor das Bedienpanel in mein S7-Programm einzubinden. Ich kenne das bisher nur von den Siemens-Paneln. Da habe ich sie immer über WinCC Flexible mit in das Projekt integriert.

    In dem HMI Builder kann ich ja eine MPI-Adresse einstellen, aber wie projektiere ich diese in Step 7?

    Außerdem muss ich über das Panel einige Zeiten einstellen können. Kann ich dieses direkt im HMI Builder als s5t parametrieren?

  8. #6
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.732
    Danke
    314
    Erhielt 1.520 Danke für 1.282 Beiträge

    Standard

    1. Eine Integration ähnlich Flexible gibt es hier nicht, es sei denn SEW hätte da speziell was für,
    das kann ich mir aber nicht vorstellen.

    2. Der Steuerung ist das Panel vollkommen egal.
    Auf der Steuerungsseite musst du eine MPI-Adresse vergeben (Werksmäßig immer 2),
    und die Baudrate der MPI-Schnittstelle auf 19,2 reduzieren (Standart 187,5)
    Dann musst du Panelseitig halt die Adresse der Steuerung und die Adresse des Panels eingeben (typischerweise 1).

    3. Die Zeiten als S5Time wird nicht gehen, da dies ein Format ist, welches es ausschließlich bei Siemens gibt,
    aber ich würde dir das Format Time empfehlen, das ist ein DINT in ms, das kannst du dann beliebig skalieren (Panelseitig) auf Sek, Min ...
    Steuerungsseitig könntest du das dann mit FC40/FC33 aus den IEC-Function Blocks
    auf S5Time konvertieren.

    Mfg
    Manuel
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  9. Folgender Benutzer sagt Danke zu MSB für den nützlichen Beitrag:

    nico (28.11.2008)

  10. #7
    nico ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    05.04.2005
    Ort
    Raesfeld
    Beiträge
    195
    Danke
    32
    Erhielt 11 Danke für 11 Beiträge

    Standard

    Danke nochmals,

    werde in den nächsten Tagen wohl nicht dazu kommen das auszuprobieren. Melde mich dann aber demnächst nochmal und berichte wie es geklappt hat.

    Schönes Wochenende!

  11. #8
    nico ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    05.04.2005
    Ort
    Raesfeld
    Beiträge
    195
    Danke
    32
    Erhielt 11 Danke für 11 Beiträge

    Standard

    So bin jetzt endlich mal dazu gekommen die Verbindung von Panel und Steuerung zu testen. Leider mit wenig Erfolg.

    Ich habe mir ein Kabel gemäß obiger Beschreibung angefertigt.

    Anbei mal meine Konfiguration. Wäre toll wenn mir jemand sagen könnte was ich da falsch eingestellt habe .
    Angehängte Dateien Angehängte Dateien

  12. #9
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.732
    Danke
    314
    Erhielt 1.520 Danke für 1.282 Beiträge

    Standard

    Ich sehe hier gerade ein Problem!

    SEW hat scheinbar in seiner Software den sog. MPI-Direct Treiber weggelassen.

    Alles was oben zum Thema Kabel etc. steht gilt nur für diesen Treiber !!!
    Den Treiber den du ausgewählt hast würde zusätzliche Hardware erfordern, z.B. das ding http://www.helmholz.de/prod.d,17_24,...4.html?prod=88

    Auf jeden Fall solltest du mal den Support mit der Anfrage nach den sog. "MPI Direct" Treiber bemühen, sollte imho eigentlich kein Problem sein ...

    Edit: Du könntest auch mal probieren, beim E-Designer gibts einen Punkt "Datei" - "Update ... Drivers from" - Internet ... falls SEW das auch hat (wovon ich ausgehe) kannst du dir hierüber den benötigten Treiber downloaden ...

    Mfg
    Manuel
    Geändert von MSB (25.02.2009 um 11:03 Uhr)
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  13. Folgender Benutzer sagt Danke zu MSB für den nützlichen Beitrag:

    nico (25.02.2009)

  14. #10
    nico ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    05.04.2005
    Ort
    Raesfeld
    Beiträge
    195
    Danke
    32
    Erhielt 11 Danke für 11 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hi Manuel,

    Habe den Treiber von der SEW Homepage heruntergeladen. Habe im Anhang jetzt nochmal die Einstellung mit diesem Treiber.
    Angehängte Dateien Angehängte Dateien

Ähnliche Themen

  1. S7 an S5 anbinden
    Von Katrin1982 im Forum Simatic
    Antworten: 15
    Letzter Beitrag: 03.12.2010, 15:53
  2. IEC 60870-5-101 an S7-300 Anbinden?
    Von eYe im Forum Feldbusse
    Antworten: 3
    Letzter Beitrag: 02.03.2010, 10:35
  3. Mircomaster an S7-300 anbinden
    Von DJFelix im Forum Simatic
    Antworten: 15
    Letzter Beitrag: 30.07.2007, 17:56
  4. PDA an SPS anbinden
    Von maccap im Forum Feldbusse
    Antworten: 18
    Letzter Beitrag: 01.10.2005, 11:02
  5. S5-100U an ein PLS anbinden ?
    Von Thinker im Forum HMI
    Antworten: 2
    Letzter Beitrag: 23.07.2004, 22:19

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •