Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 5 ErsteErste 1234 ... LetzteLetzte
Ergebnis 11 bis 20 von 43

Thema: Referenzfahrt mit SEW-FU funktioniert nur halb

  1. #11
    sk1rie ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    05.09.2008
    Beiträge
    108
    Danke
    13
    Erhielt 4 Danke für 3 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    1. Ja, Movidrive (sorry, hatte ich vorhin vergessen)
    2. Im Handbetrieb aus dem Motion Studio funktioniert die super
    3. Hat der FU ganz von allein gemacht. Nach ein paar Fehlermeldungen habe ich die richtige Einstellung gefunden, dann auch mal mit dem Offset herumgespielt (ist jetzt jedoch wieder 0). Den Punkt habe ich nicht vorgegeben, sondern der FU fährt bis zum Endschalter und dann einfach ein Stück nach oben. Das jedoch nur, wenn ich die Referenzfahrt aus dem Motion Studio heraus starte. Im Automatikbetrieb fährt er den Punkt auf direktem Weg an, und nicht erst an den Endschalter.
    10000 Inkremente entsprechend übrigens ~3cm, wäre also an sich schon ne super Sache. Würde der das nicht von alleine machen, hätte ich suchen müssen, wir das geht, da wir genau diese Position haben wollen.

  2. #12
    Registriert seit
    06.10.2009
    Ort
    NRW
    Beiträge
    1.572
    Danke
    63
    Erhielt 259 Danke für 219 Beiträge

    Standard

    Wenn das Referenzieren über Motion Studio funktioniert kann man ja schon einiges ausschließen. Als nächstes könntest Du noch prüfen, ob der Referenzierbefehl korrekt am Umrichter ankommt, wenn die SPS diesen ausgibt. Dazu kannst Du die Steuerwörter im Motion Studio online betrachten.
    Mehr fällt mir sonst erstmal auch nicht ein.

    Zur Info:
    Der Offset gibt ja nur an, welche Istposition die Achse übernehmen soll, wenn die Referenzfahrt beendet wurde. Das ist der Fall, wenn der Endschalter erreicht, und mit der Kriechgeschwindigkeit wieder freigefahren wurde.

    10.000 Ink für 3cm finde ich nicht so ideal. Du solltest Dir überlegen das Geberverhältnis so einzustellen, dass man es einfacher umrechnen kann. Z.B. 10.000 Ink = 1cm.
    Meine Motivation läuft nackig mit einem Cocktail über eine Wiese.

  3. #13
    Registriert seit
    13.10.2007
    Beiträge
    12.037
    Danke
    2.789
    Erhielt 3.270 Danke für 2.158 Beiträge

    Standard

    Kann es den sein das du mit deinen Referenzpunkt, im Bereich der Software-
    Endschalter liegst. Das heisst Referenz "0" und SWE auf "10". Was gibt der
    Umrichter den an Meldungen raus wenn er auf dem Referenzpunkt steht und
    nicht mehr fährt.
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  4. #14
    sk1rie ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    05.09.2008
    Beiträge
    108
    Danke
    13
    Erhielt 4 Danke für 3 Beiträge

    Standard

    Folgende Dinge habe ich jetzt herausgefunden, nachdem ich mit etwas intensiver mit der sache Beschäftigt habe:

    Nicht alle FU haben die Technologie-Option. Der, an dem ich gerade sitze, hat sie zum Beispiel nicht.
    Parameter 610 (Binäreingang DI10) ist auf "Referenzfahrt Start gestellt".

    Jetzt ist die Frage, erstmal grundsätzlich, Wenn die Referenzfahrt gestartet ist und fertig ist, dann sollte das Bit "Referenzfahrt ok" auf 1 gehen und die Fahrt das Bit "Referenzfahrt Start" in der SPS wieder zurückgesetzt werden, richtig?

    Weitere Frage: muss man ein IPOS-Programm in den FU spielen, damit die Referenzfahrt funktioniert?
    Denn das ist nicht vorhanden.

    Im übrigen zeigt die 7-Segment-Anzeige beim Starten der Referenzfahrt "A" an. Das bedeutet Technologie-Option. Aber wie kann das sein? Ich bin der Meinung, dass dieser FU keine Technologie-Option besitzt ...

  5. #15
    Registriert seit
    13.10.2007
    Beiträge
    12.037
    Danke
    2.789
    Erhielt 3.270 Danke für 2.158 Beiträge

    Standard

    um erkennen zu können ob die Technologieoption auf dem Gerät vom Werk
    aus Freigeschaltet ist müsstes du auf auf das Typenschild schauen, die
    letzten Buchstaben müssten 'OT' sein für Technologieausführung.

    Wenn nicht, hat dein Gerät Sie nicht und du kannst keine Busposi ausführen,
    du kannst Sie aber nachrüsten, dazu rufst du bei dein SEW Vertriebler deines
    Vertrauens an, mit ihn kannst du diese Option freischalten, aber bitte nicht
    vergessen das Geld für diese Option an SEW zu überweisen.
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  6. #16
    sk1rie ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    05.09.2008
    Beiträge
    108
    Danke
    13
    Erhielt 4 Danke für 3 Beiträge

    Standard

    Nach einem sehr ausführlichen Gespräch heute mit dem Support scheint mein Problem noch viel größer.
    Ich hab das S7-Programm von einer anderen Firma bekommen. Der Auftrag lautet, die exakt baugleiche Anlage in Betrieb zu nehmen mit dem vorhandenen Programm.
    Nun hat mir der Support mitgeteilt, dass ich dazu auch ein IPOS-Programm im FU brauch, welches mir dann die Daten liefert und bestimmte Aktionen ausführt. Selbstverständlich liegt mir das nicht vor. Daher geht auch die Referenzfahrt nicht. Super, was?

    Hat jemand nen Vorschlag dazu, wie ich mir den Compiler oder Assembler am schnellsten selbst bei bringe? Gibt es da noch mehr außer die von SEW gelieferte Dokumentation?

  7. #17
    Registriert seit
    13.10.2007
    Beiträge
    12.037
    Danke
    2.789
    Erhielt 3.270 Danke für 2.158 Beiträge

    Standard

    Las dir die 'OT' Funktion freischalten, das machen die von SEW, das geht alles
    per Telefon, haben wir auch schon gemacht. Du musst natürlich diese Option
    bezahlen, kostet etwa 100,--€, dafür kannst du das nicht selber schreiben.
    Wenn du das selber schreiben möchtest, bin ich sicher das du einen Monat min. zu tun hast.
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  8. #18
    sk1rie ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    05.09.2008
    Beiträge
    108
    Danke
    13
    Erhielt 4 Danke für 3 Beiträge

    Standard

    Ja, der Supportmitarbeiter sagte mir auch, dass das die einfachste Lösung wäre. Dann könnte ich eine Applikation einspielen und hätte alles, was ich brauch. Aber ich bin da ein wenig Skeptisch, denn meine Vorgänger haben das auch ohne Technologie-Option gemacht. Es soll ja eigentlich eine baugleiche Anlage werden.
    Wer weiß, welche Löcher man aufreißt, wenn man jetzt was ändert. Das fängt ja schon mit der Belegung der Ein-/Ausgänge an. Ich weiß nicht, ob das so die beste Wahl ist.
    Gibt es sonst noch Vorschläge?
    Meinst Du eigentlich wirklich, dass man da einen Monat dazu brauch? Wenn ich das dem Kunden erzähle, dann macht der dicke Backen.

  9. #19
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard

    Zitat Zitat von sk1rie Beitrag anzeigen
    Meinst Du eigentlich wirklich, dass man da einen Monat dazu brauch? Wenn ich das dem Kunden erzähle, dann macht der dicke Backen.
    Würde ich auch

    Seit ihr der Hersteller der 1. Anlage?
    Da ihr das PLC Programm habt, müsstet ihr dann auch das SEW Programm haben.



    bike

  10. #20
    Registriert seit
    06.01.2005
    Ort
    im schönen Lipperland
    Beiträge
    4.472
    Danke
    498
    Erhielt 1.143 Danke für 736 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von sk1rie Beitrag anzeigen
    . Daher geht auch die Referenzfahrt nicht. Super, was?

    Hat jemand nen Vorschlag dazu, wie ich mir den Compiler oder Assembler am schnellsten selbst bei bringe? Gibt es da noch mehr außer die von SEW gelieferte Dokumentation?
    Interessant das die Referenzfahrt über MotionStudio trotzdem geht
    Früher gab es Peitschen .... heute Terminkalender

Ähnliche Themen

  1. Referenzfahrt Incrementalgeber
    Von Wila im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 01.09.2011, 22:06
  2. Referenzfahrt mit der KL2541
    Von maximb im Forum CODESYS und IEC61131
    Antworten: 7
    Letzter Beitrag: 14.12.2009, 21:56
  3. FM357-2 Referenzfahrt ändern
    Von disdata im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 04.09.2009, 13:49
  4. halb byte ausgeben
    Von veritas im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 15.12.2008, 19:57
  5. Referenzfahrt bei EM253 stoppen (S7-200)
    Von Daimonion im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 15.02.2008, 09:11

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •