Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: Funktionsweise SEW Servo -> Positionsüberwachung

  1. #1
    Registriert seit
    23.09.2008
    Beiträge
    49
    Danke
    9
    Erhielt 1 Danke für 1 Beitrag

    Frage


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    Wegen einem kleinen Problem mit einem Spindelantrieb (Hubwerk) habe ich mich gerade gefragt, was der Drehgeber an meinem Servo genau macht. Vielleicht kann mir da ja kurz jemand helfen.

    Der Servomotor (SEW-Motor mit SEW-Umrichter MDX61) errechnet sich ja beim Verfahren seine Position und vergleicht diese mit der Position, die er vom Drehgeber gemeldet bekommt. Bei zu großer Abweichung kommt ein Schleppfehler. Welche Position ist jetzt aber die Ausschlaggebende, die errechnete Position, oder die Drehgeberposition? Eine von beiden ist ja im Prinzip nur zum vergleichen da.

    Ich frage, weil ich für meine Anwendung die Schleppfehlergrenze vergrößern musste und jetzt eine schleichende verschiebung der Nullposition feststellen kann. Nach X Umdrehungen des Hubwerks, ist die Nullposition ein paar Millimeter weggewandert. Bei einem ähnlichen Hubwerk (Leistungsstärkerer Antrieb) habe ich diese Probleme nicht.

    Kann sich jemand vorstellen, woran das liegt?


    Danke schonmal
    Zitieren Zitieren Funktionsweise SEW Servo -> Positionsüberwachung  

  2. #2
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    Hallo

    Nach X Umdrehungen des Hubwerks, ist die Nullposition ein paar Millimeter weggewandert.
    Das hat mW. nichts mit dem Schleppfehler zu tun. Schleppfehler = erlaubte abweichende Position +/- von der aktuellen Sollposition (Drehgeber Master).
    Bei Dir scheint aber die Position an sich abzuweichen.
    Getriebe/Übersetungsdaten richtig? Kein Komma in der Übersetzung vorhanden?

    Bei einem ähnlichen Hubwerk (Leistungsstärkerer Antrieb) habe ich diese Probleme nicht.
    Da würde ich mal das aktuelle Hubwerk auf 50% fahren und kontrollieren, ob es sich genauso verhält.

    PS: kannst Du einen mechanischen Schlupf oder ähnliches ausschließen?

  3. #3
    Registriert seit
    22.02.2012
    Ort
    Rüsselsheim
    Beiträge
    34
    Danke
    2
    Erhielt 4 Danke für 4 Beiträge

    Standard

    Hallo,
    gibt es bei den SEW Servos die Möglichkeit, die Ziel-Sollposition einzulesen und zu prüfen?
    Um den Schleppfehler zu verkleinern sollte man sich das Tuning und die Rampen noch einmal ansehen.
    Gerne werden bei Rundtischanwendungen ein Positionsbereich von 0 ... 3600 für 3600 position user units angegeben. Richtig wäre aber 0 ... 3599.
    Der Fehler ist aber dann nicht abhängig vom Schleppfehler und von der Geschwindigkeit.

  4. #4
    Registriert seit
    17.07.2009
    Ort
    Am Rande der Ostalb
    Beiträge
    5.532
    Danke
    1.152
    Erhielt 1.253 Danke für 982 Beiträge

    Standard

    Zitat Zitat von Baschankun Beitrag anzeigen
    Hallo,
    gibt es bei den SEW Servos die Möglichkeit, die Ziel-Sollposition einzulesen und zu prüfen?
    Um den Schleppfehler zu verkleinern sollte man sich das Tuning und die Rampen noch einmal ansehen.
    Gerne werden bei Rundtischanwendungen ein Positionsbereich von 0 ... 3600 für 3600 position user units angegeben. Richtig wäre aber 0 ... 3599.
    Der Fehler ist aber dann nicht abhängig vom Schleppfehler und von der Geschwindigkeit.
    Was meinst du mit Ziel-Sollposition?
    Üblicherweise legst du ja die Zielposition fest und der Antrieb fährt sie an.

    Du kannst auch die Istposition und den Schleppabstand einlesen.
    Istposition + Schleppstand = Position an der der Antrieb im Augenblick gerne wäre

    Tracen kannst du das Ganze auch mit der Scope-Funktion. Du musst dir halt die entsprechenden IPOS-Variablen aus der Doku heraussuchen.

    Gruß
    Dieter

  5. #5
    Registriert seit
    13.09.2010
    Beiträge
    2.292
    Danke
    178
    Erhielt 375 Danke für 355 Beiträge

    Standard

    Kann es sein, dass du dein Hubwerk relativ positionierst ?

    Und das beim Einschalten des Reglers das Haltemoment des Hubwerk-Antriebs (bevor die Bremse löst) nicht mit Drehrichtung nach oben, sondern nach unten aufgebaut wird und der Antrieb etwas absackt ?

    Und dass damit mit jedem Einschalten durch das Gewicht sich die Ist-Position innerhalb des (erlaubten) Schleppabstands mechanisch verschiebt (Antrieb läuft erstmal weiter)?

    Und irgendwann nach X Umdrehungen des Hubwerks die Abweichung sich aufaddiert hat und der erlaubte Schleppabstand überschritten wird ?

    Und dass bei deiner Vergleichmaschine mit leistungstärkeren Antrieb das Haltemoment beim Einschalten ausreicht ?

    Und nochmal Beitrag#2 und Beitrag#4 beachten !

    ... Nur mal laut gedacht ...
    kind regards
    SoftMachine

  6. #6
    Registriert seit
    14.12.2005
    Ort
    Karlsruhe
    Beiträge
    162
    Danke
    10
    Erhielt 25 Danke für 23 Beiträge

    Standard

    Hallo,

    beim Hubwerk kann es auch sein, dass bei beim Öffnen der Bremse das Hubwerk mechanisch etwas absackt. Das können nur 1/10mm sein, aber wenn man dann z.B. 30 mal relativ positioniert steht man ganz wo anders wie geplant.

    Bei der absoluten Postionierung, wird der Postionssollwert immer mit dem Geberpositionsistwert verglichen. Am Ende der Postionierung sollte alles passen, wenn der Riemen nie überspringt. Das kann aber in der Praxis auch mal passieren, wenn die Gurtspannung nicht passt. Der Geber ist ja immer am Motor angebaut, und wenn der Riemen hinter dem Getriebe um einen Zahn überspringt, hast du auch verloren.
    Immer Ärger mit Siemens -> macht nix -> wir schimpfen und kaufen!!

  7. #7
    Registriert seit
    03.04.2008
    Beiträge
    6.205
    Danke
    237
    Erhielt 817 Danke für 691 Beiträge

    Standard

    Zitat Zitat von Superkater Beitrag anzeigen
    Der Geber ist ja immer am Motor angebaut, ..
    Es gibt aber auch direkte Messung mit Gebern, die nicht am Motor sondern am Hubwerk selbst angebaut sind.

    Dass der Nullpunkt wartet ist ungewöhnlich.
    Denn unabhängig von der Mechanik ist auch ein Riemen irgendwann einmal ausgelängt.
    Da der Fehler jetzt erst kommt, stellt sich die Frage was hat sich geändert.
    Ich würde einmal die Kupplung zwischen Hubwerk und Motor überprüfen.
    Ein anderer Ansatz ist, das ganz mechanisch zu überprüfen.
    Wenn dein Schleppabstand größer wird, kann es auch sein, dass etwas schwergängig ist und daher es länger dauert bis die Position erreicht wird.


    bike

  8. #8
    Registriert seit
    06.10.2009
    Ort
    NRW
    Beiträge
    1.580
    Danke
    63
    Erhielt 261 Danke für 221 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Dabei ist auch die Geberkupplung (sofern vorhanden) ein verdächtiger Kandidat.
    Meine Motivation läuft nackig mit einem Cocktail über eine Wiese.

Ähnliche Themen

  1. S_VIMP Funktionsweise
    Von Univibrator im Forum Simatic
    Antworten: 14
    Letzter Beitrag: 07.09.2009, 10:02
  2. Funktionsweise von MFC's ??
    Von Insane im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 30.01.2009, 11:35
  3. Prozessdaten von SEW Servo gehen verloren ??
    Von Pizza im Forum SEW-EURODRIVE
    Antworten: 9
    Letzter Beitrag: 05.11.2007, 23:05
  4. Funktionsweise eines Resolvers
    Von brossi_lgs im Forum Elektronik
    Antworten: 0
    Letzter Beitrag: 10.01.2006, 11:43
  5. Funktionsweise Barcodeleser
    Von Corrado im Forum Elektronik
    Antworten: 2
    Letzter Beitrag: 29.04.2005, 16:16

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •