Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Page 3 of 3 FirstFirst 123
Results 21 to 27 of 27

Thread: Motor dreht unkontrolliert im Handbetrieb (MDX61B + CMP50S)

  1. #21
    Join Date
    08.04.2016
    Location
    4040 Linz, Österreich
    Posts
    381
    Danke
    33
    Erhielt 125 Danke für 100 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Quote Originally Posted by DeltaMikeAir View Post
    Ja, die Minimaldrehzahl 15 bei einem geregelten Servomotor hat mich auch schon sehr gewundert.
    Solange nur die Drehzahlregelung (Betriebsart Servo) genutzt wird, ist das schon ok. Sobald aber Lageregelung oder Halteregelung ins Spiel kommt, pendelt der Antrieb ständig zwischen +/-- 15 U/min hin und her - und das mit einer Frequenz zwischen 50 und 500 Hz - das hört man dann schon schön

  2. Folgender Benutzer sagt Danke zu maxder2te für den nützlichen Beitrag:

    DeltaMikeAir (30.11.2018)

  3. #22
    Join Date
    03.02.2015
    Posts
    44
    Danke
    2
    Erhielt 1 Danke für 1 Beitrag

    Default

    Danke für die Hinweise.
    Die Minimaldrehzahl ist auf 0 eingestellt
    Mit dem Servotunig warte ich noch. Mache ich erst wenn die Achsen dran hängen.
    Aber erst mal die 3. Achse in Linuxcnc Konfigurieren und In-betrieb nehmen.

  4. #23
    Join Date
    03.02.2015
    Posts
    44
    Danke
    2
    Erhielt 1 Danke für 1 Beitrag

    Default

    OK,

    nun habe ich doch noch Fragen. Ich hoffe Ihr habt soviel Geduld mit mir.

    Ich habe die 3. Achse nun auch in Betrieb genommen.
    Es ist ein MDX6B0055 mit einem CMP71M.
    Vorweg, ich habe ihn im Handbetrieb getestet. Er läuft etwas ruppig an und bei Drehzahlwechsel reagiert er auch etwas Ruppig,
    ansonsten läuft er super. Ich denke mal das liegt an den zu kleinen Rampen.

    Im Positionierbetrieb sieht es allerdings anders aus.
    Hier läuft der Servo extrem Rau und ratternd, gut das ich ihn ordentlich befestigt habe.
    Die Ursache ist die Steuerung, sie übermittelt kontinuierlich neue Positionswerte (Bahnsteuerung).
    Der Servo reagiert entsprechend heftig darauf indem er ständig abbremst und wieder beschleunigt.
    Im Gegensatz zu dem Anderen Servo der erst gar nicht wollte. Dieser läuft schön ruhig.
    Ich würd ihn gerne weicher Einstellen und habe bisher folgendes versucht.

    Par910: Verstärkung 3.69 > 1
    Par911: Pos Rampe1 1
    Par912: Pos Rampe2 1
    Par916: Ruckbegrenzt
    Par933: Ruckzeit 0.005

    Leider ohne Erfolg.
    Könnte es an der Steifigkeit liegen?, diese liegt bei 1.15


    Gruß

    Andre

  5. #24
    Join Date
    17.07.2009
    Location
    Am Rande der Ostalb
    Posts
    6,223
    Danke
    1,277
    Erhielt 1,448 Danke für 1,124 Beiträge

    Default

    Ja, kann an der Steifigkeit liegen

  6. #25
    Join Date
    21.12.2016
    Posts
    20
    Danke
    0
    Erhielt 2 Danke für 2 Beiträge

    Default

    Wenn die Erweiterte Buspositionierung verwendet wird, werden die Parameter 911 und 912 durch die Vorgabe vom Bus überschrieben.
    Die Ruckzeit sollte in dem Fall mal auf 0.1 oder 0.2 eingestellt werden. Hierdurch wird der Anstieg der Beschleunigung reduziert.
    Die Verstärkung P910 ist nur für den Lageregler, um den Drehzahlregler weicher einzustellen, würde ich die Steifigkeit auf 1 oder sogar auf 0,9 einstellen.
    In welchem Intervall erhält der MDX neue Lagesollwerte?
    SEW-EURODRIVE Support Team
    scc-elektronik@sew-eurodrive.de
    Service Hotline: 0800 7394357 oder 0800 SEWHELP
    www.sew-eurodrive.de

  7. #26
    Join Date
    03.02.2015
    Posts
    44
    Danke
    2
    Erhielt 1 Danke für 1 Beitrag

    Default

    guten Morgen,

    Steuerungsseitig:
    der Servo-thread läuft mit 0,8ms, Ethercat-bus Abtastrate 0,1ms.

    Profibus:
    Der Task-zyklus der Profibusklemme ist 1ms
    Der Profibus läuft mit 12M im DP/MC Modus, Telegramm 6PD.

    Weitere Einstellungen:
    Beschl/ Abbremsrampe: 0
    Die Steuerung übernimmt die Rampenfunktion mittels Drehzahlvorgabe.
    Die Steifigkeit hab ich am Wochenende bis 0,7 getestet (Grenzwertig) und hab aktuell 0,9 eingestellt.
    Lastträgheit 0
    Kürzeste Rampe 0,3
    Zeitraster 0,1s

    Der P910 (Danke für die Information) steht bei 2.00
    P933 steht bei 0.08, hier werde ich die Größeren Werte mal eintragen.
    P938 5
    P939 4

    Schleppfehler:

    Vf1000 mm/min (40 1/min) = ca.1,6 mm
    Vf2000 mm/min (80 1/min) = ca. 3,6 mm
    Vf3000 mm/min (120 1/min) = ca. 7 mm

    Ich werd mal ein Video Einstellen, wo man sieht/ hört wie die 3 Servos laufen.

    Ansonsten denke ich, wäre es Sinnvoll das Telegramm auf 3PD zurückzustellen.
    Das Ganze ohne ipos. Die Ansteuerung per Drehzahlvorgabe und Auswertung der Istposition über den Profibus.

    Oder Hybrid, Analog von Außen über die Klemmen und Auswertung Istposition per Profibus.

    Gruß

    Andre

  8. #27
    Join Date
    03.02.2015
    Posts
    44
    Danke
    2
    Erhielt 1 Danke für 1 Beitrag

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Jungs Ihr seid Spitze

    Nachdem ich gestern ein Video vom rauhen Lauf aufgenommen hatte,
    https://www.youtube.com/watch?v=cxoBpZY5_ao

    habe ich nochmals die Vorgeschlagenen Parameter angepasst.
    Steifigkeit auf 0.9
    Antrieb Spielfrei
    Kürzeste geforderte Rampe 0
    Ruckzeit 0,1

    Das Ergebnis kann sich sehen lassen.
    https://www.youtube.com/watch?v=DpQrzx9-EhE&t=18s

    Danke euch

    Andre

Similar Threads

  1. Siemens Sinamics V20 FU. Motor dreht nicht!!!
    By Martin L. in forum Antriebstechnik
    Replies: 2
    Last Post: 14.07.2015, 16:25
  2. ABB ACS355 Frequenzumrichter Motor dreht nicht
    By Bomber in forum Antriebstechnik
    Replies: 1
    Last Post: 06.11.2012, 06:07
  3. Rollomotoren fahren unkontrolliert
    By blasterbock in forum Elektronik
    Replies: 16
    Last Post: 12.10.2010, 05:46
  4. Replies: 9
    Last Post: 15.03.2010, 18:45
  5. Mein Motor dreht sich nicht!
    By HLUNKE23 in forum Feldbusse
    Replies: 26
    Last Post: 01.12.2006, 12:56

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •