Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23

Thread: SICK DL50HI als Streckengeber an MoviDriveMDX61b

  1. #11
    Join Date
    08.04.2016
    Location
    4040 Linz, Österreich
    Posts
    400
    Danke
    35
    Erhielt 133 Danke für 104 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Wichtige Information:

    Bitte bringt die Begriffe Absolutwertgeber und Streckengeber in der SEW-Nomenklatur nicht durcheinander.
    Wenn in den SEW-Handbüchern oder in MotionStudio von Absolutwertgeber die Rede ist, dann ist i.d.R. damit ein SSI-Geber an der alten DIP11B-Geberkarte im Erweiterungsschacht die Rede, oder von der seltenen DEH21B. Es steht meist nicht nur Absolutwertgeber dort, sondern Absolutwertgeber DIP. Hier liegt die Istposition in H509.

    Die genannte Applikation läuft aber mit der Universal-Geberkarte DEU21B. Diese Karte unterstützt neben Hiperface auch SSI, Endat und andere Geber. Bei dieser Karte ist die Einstellung Streckengeber (X14) relevant. Die Istposition des Streckengebers wird in H510 gemappt.
    Die Karte hat SEW etwas ungeschickt ins System gepfriemelt, und die Dokumentation ist nicht überall so ganz nachgezogen worden.

    Prinzipiell sollte die Geberinbetriebnahme aber so ablaufen:
    1. Inbetriebnahme mit Motorgeber
    2. Streckengeber in Betrieb (einmessen) nehmen und Lagequelle auf Streckengeber umstellen

    Beim 2. Schritt passiert nun etwas, mit dem man in der Regel nicht rechnet: Bei der Geberauswahl bzw. bei der beim Einmessen werden Skalierungsfaktoren so eingestellt, dass der Streckengeber auf Motorinkremente skaliert wird. Bei der Inbetriebnahme fällt das noch nicht weiter auf, aber bei der Einstellung der Schleppfehlergrenze im Parameterbaum ist das relevant, da diese in Inkrementen angegeben wird.
    Der Wert bezieht sich immer auf den aktiven Geber. Da bei der DEU21 eine Skalierung auf den Motorgeber erfolgt, ist hier mit Motorinkrementen zu rechnen.

    Ich kenn die Applikation Busposi nicht, da wir immer mit eigenen IPOS-Programmen gearbeitet haben. Aber ich kann mir durchaus vorstellen, dass das Applikationsmodul hier irgendwo Unsinn macht und eine zu knappe Schleppfehlergrenze einstellt.
    Last edited by maxder2te; 09.09.2019 at 14:31.

  2. #12
    Join Date
    25.06.2017
    Location
    Oerlinghausen
    Posts
    1,751
    Danke
    152
    Erhielt 324 Danke für 267 Beiträge

    Default

    Quote Originally Posted by maxder2te View Post
    Wenn in den SEW-Handbüchern von Absolutwertgeber die Rede ist, dann ist damit ein SSI-Geber ... die Rede, oder von der seltenen DEH21B.
    Nein, in der Beschreibung der DEU21B-Karte ist nicht nur von SSI, sondern auch von Hiperface und EnDat die Rede.
    Aber der Sick-AbsolutGeber des TE ist nicht mit aufgeführt, deshalb hatte ich in #6 den Hinweis "Für alle parametrierbaren SSI-Geber gilt:" herausgepickt.

    PS:
    Ich bekomme jetzt aber GewissensBisse, ob ich "alle parametrierbaren" richtig gedeutet habe.
    Meint SEW damit, dass "alle" sich auf alle beschränkt, die in der DEU21B-Beschreibung aufgelistet sind?
    Last edited by Heinileini; 09.09.2019 at 13:30.

  3. #13
    Join Date
    17.07.2009
    Location
    Am Rande der Ostalb
    Posts
    6,431
    Danke
    1,312
    Erhielt 1,494 Danke für 1,163 Beiträge

    Default

    Quote Originally Posted by maxder2te View Post
    Wichtige Information:

    Bitte bringt die Begriffe Absolutwertgeber und Streckengeber in der SEW-Nomenklatur nicht durcheinander.
    Wenn in den SEW-Handbüchern von Absolutwertgeber die Rede ist, dann ist damit ein SSI-Geber an der alten DIP11B-Geberkarte im Erweiterungsschacht die Rede, oder von der seltenen DEH21B. Hier liegt die Istposition in H509

    Die genannte Applikation läuft aber mit der Universal-Geberkarte DEU21B. Bei dieser Karte ist die Einstellung Streckengeber (X14) relevant. Die Istposition des Streckengebers wird in H510 gemappt.
    Die Karte hat SEW etwas ungeschickt ins System gepfriemelt, und die Dokumentation ist nicht überall so ganz nachgezogen worden.

    Prinzipiell sollte die Geberinbetriebnahme aber so ablaufen:
    1. Inbetriebnahme mit Motorgeber
    2. Streckengeber in Betrieb (einmessen) nehmen und Lagequelle auf Streckengeber umstellen

    Beim 2. Schritt passiert nun etwas, mit dem man in der Regel nicht rechnet: Bei der Geberauswahl bzw. bei der beim Einmessen werden Skalierungsfaktoren so eingestellt, dass der Streckengeber auf Motorinkremente skaliert wird. Bei der Inbetriebnahme fällt das noch nicht weiter auf, aber bei der Einstellung der Schleppfehlergrenze im Parameterbaum ist das relevant, da diese in Inkrementen angegeben wird.
    Der Wert bezieht sich immer auf den aktiven Geber. Da bei der DEU21 eine Skalierung auf den Motorgeber erfolgt, ist hier mit Motorinkrementen zu rechnen.

    Ich kenn die Applikation Busposi nicht, da wir immer mit eigenen IPOS-Programmen gearbeitet haben. Aber ich kann mir durchaus vorstellen, dass das Applikationsmodul hier irgendwo Unsinn macht und eine zu knappe Schleppfehlergrenze einstellt.
    Irgendwo hab ich noch einen Faktor bei der Skalierung im Hinterkopf.
    Umrechnung von Streckengeber-Inkrementen auf IPos-Inkremente.

  4. #14
    Join Date
    08.04.2016
    Location
    4040 Linz, Österreich
    Posts
    400
    Danke
    35
    Erhielt 133 Danke für 104 Beiträge

    Default

    Quote Originally Posted by Heinileini View Post
    Nein, in der Beschreibung der DEU21B-Karte ist nicht nur von SSI, sondern auch von Hiperface und EnDat die Rede.
    Aber der Sick-AbsolutGeber des TE ist nicht mit aufgeführt, deshalb hatte ich in #6 den Hinweis "Für alle parametrierbaren SSI-Geber gilt:" herausgepickt.
    Mein Beitrag war zu wenig präzise. Ich hab das nachgeschärft.

    Mir war beim Lesen der Antworten aufgefallen, dass im Zuge der Diskussion die DIP- und die DEU-Varianten vermischt wurden.

  5. #15
    dust2 is offline Neuer Benutzer
    Themenstarter
    Join Date
    03.06.2012
    Posts
    9
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Default

    Hallo, ich hatte mich letzte Woche auch gewundert, warum die Schleppfehlergrenze noch in Inkrementen angegeben wird und diese testweise auf 4000Incr hochgesetzt da die Inbetriebnahme das Gebers 400Ink/mm ergab. Schleppfehler blieb!
    Mich wunderte halt auch warum ich nirgendwo auf SEW-Seite die SSI-Parameter wie Fehlerbit und Graycodierung Ändern/Einstellen kann obwohl das laut Doku getan werden soll. Das sind die SSI-Parameter die ich ändern kann:
    SSI.jpg

    Auf Sensorseite weiß ich wie das geht.


    Ich bin am Mittwoch nochmal vor Ort und probiere Eure Ratchläge aus. Ich werde berichten. Danke erstmal für Euer ausführliches Bemühen!!

  6. #16
    Join Date
    02.04.2019
    Posts
    8
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Default

    Ich bin selbst gerade an einem Projekt mit MDX61B + DEU21B inkl. Motorgeber mit Schlupf und schlupffreiem SSI-Streckengeber dran.
    Laut SEW-Anwendungstechnik muss hier zwingend ein freigegebener Fremdgeber verwendet werden. Ansonsten funktionieren nicht alle Funktionen.
    Der DL50Hi ist in der Auswahlliste der freigegebenen (=zertifizierten) Geber vorhanden. Du musst das Ganze in der Erstinbetriebnahme nur richtig auswählen. Auf die detaillierten Geber-Eingaben komme Ich dann gar nicht mehr.
    Vielleicht liegt hier ja der Hund begraben.
    (Motion Studio 6.30 SP1,2,3 / 6.3.0.8 )
    SEW Freigegebener Geber.JPG

    Gruß Michael
    Last edited by Holzmichl; 09.09.2019 at 23:02. Reason: Edit: Motion Studio Version eingefügt

  7. #17
    Join Date
    25.06.2017
    Location
    Oerlinghausen
    Posts
    1,751
    Danke
    152
    Erhielt 324 Danke für 267 Beiträge

    Default

    Quote Originally Posted by dust2 View Post
    Mich wunderte halt auch warum ich nirgendwo auf SEW-Seite die SSI-Parameter wie Fehlerbit und Graycodierung Ändern/Einstellen kann obwohl das laut Doku getan werden soll.
    Ich habe aus der DEU21B-Doku nicht herausgelesen, dass man auf SEW-Seite die SSI-Parameter wie FehlerBit und GrayCodierung ändern/einstellen kann. Warum sonst würde die Beschreibung darauf hinweisen, dass die Geber-Seite auf 24-Bit GrayCodierung plus FehlerBit eingestellt werden muss (ich füge hinzu: passend zur fest vorgegebenen SEW-Seite)?

    Quote Originally Posted by dust2 View Post
    Der SICK DL50HI läuft noch auf Werkseinstellungen, man kann da auch nicht viel Einstellen.
    Laut BeipackZettel des DL50HI SSI kann man wählen zwischen:
    - 24 Bit Gray + Fehlerbit binär (Gry24E)
    - 24 Bit Gray (Gry24)
    - 25 Bit Gray (Gry25)
    - 24 Bit + Fehlerbit binär (Bin24E)
    - 24 Bit binär (Bin24)
    - 25 Bit binär (Bin25)
    OriginalText:
    Sick-SSI.jpg
    Last edited by Heinileini; 10.09.2019 at 00:37.

  8. #18
    dust2 is offline Neuer Benutzer
    Themenstarter
    Join Date
    03.06.2012
    Posts
    9
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Default

    ich füge hinzu: ppassend zur fest vorgegebenen SEW-Seite
    Danke stimmt. Wenn man genau liest, merkt man, dass die Geberseite gemeint ist!
    Die hatte ich bereits geprüft: Werksteinstellung heißt GR24E, ResDist=0.1 und Averag=fast müstste also passen, ich sehe die Werte des Gebers unter Inbetriebnahme und die stimmen auch.
    Hab mir gestern noch das Handbuch "Positionierung und Ablaufsteuerung IPOSplus" durchgelesen, da sind die Zusammenhänge Motorgeber/ext. Geber bei IPOS auch nochmal gut erklärt.

    @Michael: genau so habe ich den DL50HI in Betrieb genommen.
    Nutzt Du einen Laserdistanzsensor?
    Wieviel Inkremente/mm wurden bei Dir in der Inbetriebnahme für Deinen ext. Geber unter Anbau ermittelt (Messfahrt)?
    Arbeitest Du mit der "Erweiterte Buspositionierung" ?

  9. #19
    Join Date
    02.04.2019
    Posts
    8
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Default

    @dust2 :
    Nein ich habe hier 2 Stück SEW DRL mit jeweils ES7S im Fahrwerk und SSI-Drehgeber über Zahnriehmen zur Wegmessung.
    Bei mir sollen die beiden Antriebe als Master und Slave per "DriveSync über Feldbus" betrieben werden. Bin gerade kurz vor dem Start, in 1 bis 2 Tagen kann ich hier mehr berichten.

    Vom Gefühl her könnte dein Schleppabstands-Fehler auch noch mechanisch begründet sein.
    Du schreibst, dass beim langsamen Fahren alles in Ordnung ist und bei höherer Sollgeschwindigkeit kommt der Fehler.
    a) Hast Du eventuell die Rampen zu scharf eingestellt und bekommst zu viel Schlupf für die vom MDX berechnete Bewegung? (Bei kleinerem V_Soll kann der Antrieb innerhalb der Toleranz wieder aufholen + 1,0 mm max Schleppabstand ist mMn nicht viel)
    b) Ist die Drehzahlvorsteuerung P202 zu klein eingestellt und der Drehzahlregler kommt nicht nach?

    Ich kann mich natürlich auch täuschen, aber hier würde ich als Erstes nachsehen.
    Vielleicht kann mich auch einer der hier mitlesenden alten Hasen korrigieren.

  10. #20
    Join Date
    08.04.2016
    Location
    4040 Linz, Österreich
    Posts
    400
    Danke
    35
    Erhielt 133 Danke für 104 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Quote Originally Posted by Holzmichl View Post
    Laut SEW-Anwendungstechnik muss hier zwingend ein freigegebener Fremdgeber verwendet werden. Ansonsten funktionieren nicht alle Funktionen.
    Das unterschreibe ich so nicht, man kann auch mit anderen Geber alle Funktionen nutzen.

    ABER:
    wenn man einen nicht freigegebenen Geber einsetzt, artet das schnell mal in einer ziemlichen Bastelei aus. Ich denke noch mit Schrecken an die SSI-Geber zurück, welche direkt in VAHLE Stromschienen verbaut sind. Da mussten wir irgendwo eine Art Retry-Funktion in der Geber-Konfig aktivieren, dass der Geber nach Power-Off - Power On wieder korrekt den Absolutwert geliefert hat.
    An die Einstellung kommt man in MotionStudio natürlich nur mit entsprechendem Benutzerlevel ran......

    Fazit:
    Wenn der SSI-Geber nicht in der Liste war, war faktisch immer (wenn auch teils nur minimaler) Support von SEW nötig. An der DEU21B immer auf Anhieb funktioniert haben übrigens die EnDat 2.1 und die Hiperface-Geber.

Similar Threads

  1. SICK C2000 Inbetriebnahme
    By DerHeisseDraht in forum Sensorik
    Replies: 0
    Last Post: 08.07.2018, 12:14
  2. Sick T4000
    By Larry Laffer in forum Sensorik
    Replies: 0
    Last Post: 20.08.2014, 10:16
  3. SICK Barcodeleser
    By RWY in forum Simatic
    Replies: 13
    Last Post: 26.02.2011, 18:52
  4. Sick WL 27 an SM 321
    By HAL9000 in forum Simatic
    Replies: 7
    Last Post: 04.06.2009, 16:23
  5. Sick Neu/ Ovp
    By McMallan in forum Suche - Biete
    Replies: 0
    Last Post: 28.04.2007, 11:57

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •