Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: Step5 - EPROM schiessen bricht ab ??

  1. #1
    wentom Gast

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hi,

    ich habe da ein Problem mit EPROM schiessen auf einen PG720. Es sind 16K EPROMS für eine S5-95U. Sie sind sauber gelöscht und waren zuvor einwandfrei lesbar. Beim Schiessen mit Step5 7.00 bricht der Vorgang nach etwa 5-15 Bausteinen ab mit "Vergleichsfehler" oder so. Jetzt habe ich die Vermutung, das die EPROMs halt einfach alt sind.

    Kann ich noch Hoffung haben? Sollte ich lieber gleich EEProms besorgen ?

    Vielleicht weiß jemand Rat.

    Danke...Tom
    Zitieren Zitieren Step5 - EPROM schiessen bricht ab ??  

  2. #2
    Registriert seit
    05.04.2004
    Beiträge
    93
    Danke
    11
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Kenne diese Probleme nur von C51 - wird aber hier genauso sein.
    EPROM´s kann man zwar löschen - vertragen aber nur eine gewisse Anzahl von Schreibzyklen - ich habe die Erfahrung gemacht, dass nach 10, 15 vielleicht 20 Schreibvorgängen die ersten Bit´s ausfallen.
    In Wirklichkeit ist es dann so, dass die Isolation zwischen den einzelnen Bit nicht mehr funktioniert und somit, wenn man ein Bit schreibt auch die Nachbarbit mitschreibt - wenn man dann vergleicht kommt dann ein Vergleichsfehler raus. Ev könnte es helfen das Programm ein wenig umzudrehen - so dass das Bitmuster anders aussieht und zufällig auf die falschen Bit im EPROM passt. In Wirklichkeit ist der EPROM aber defekt.
    Zitieren Zitieren ✔ hilfreichste Antwort! EPROM´s sterben - irgendwann  

  3. #3
    Registriert seit
    19.06.2003
    Beiträge
    2.200
    Danke
    85
    Erhielt 259 Danke für 175 Beiträge

    Standard

    Ich würde auf jeden Fall zunächst versuchen, das fenster gründlich von Spuren des Etikettenklebers zu reinigen und die 3-fache Löschzeit zu benutzen, falls feine Kratzer das Licht streuen.
    Die Angabe "EPROM gelöscht" bezieht sich bei Siemens nur auf das Inhaltsverzeichnis! Es wird nicht, wie bei Chipprommern üblich, jedes Byte geprüft!

  4. #4
    wentom Gast

    Standard

    Dann wird ich mal lieber schauen, ob ich nicht noch irgendwo nen EEPROM besorgen kann.

    Besten Dank erst mal

    So long Tom

  5. #5
    Anonymous Gast

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,
    ich denke auch, dass ein mehrmaliges Löschen durchaus dieses Problem lösen könnte, evtl. würde ich versuchen, das EPROM auf einem anderen PG zu brennen.
    /Ironie an
    Die UV-Lampe war doch an beim löschen ??
    /Ironie aus
    Manche UV-Lampen haben auch Altersschwäche. Der findige Inschenör nimmt das Ding mit auf die Sonnenbank und setzt die Kosten von der Steuer ab !!!

    Gruss
    Question_mark

Ähnliche Themen

  1. Programm auf EPROM schiessen
    Von mick_de im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 28.09.2011, 18:54
  2. Programm auf EPROM schiessen
    Von COD im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 26.06.2009, 14:26
  3. MPI Verbindung bricht ab.
    Von CheGuevara83 im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 19.11.2007, 06:58
  4. Eprom schiessen S5 115U
    Von sauer1 im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 21.09.2006, 22:58
  5. Eprom brennen mit STEP5 V7.23
    Von E-Marco im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 28.10.2004, 18:36

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •