Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Results 1 to 7 of 7

Thread: TD 200 Passwort Problem

  1. #1
    spassmann Gast

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hi Bitfreunde,

    bin ein verzweifelter Anfänger und stehe vor nem Problem. Ich habe ein TD 200 auf dem Fehlermeldungen ausgegeben werden. Einer meiner Vorgänger hat in der S7200 ein Passwort in diesem TD200 Assistenten hinterlegt. Ich habe keine Ahnung welche Fehlermeldungen er irgendwann mal programmiert hat. Und das Passwort ist natürlich auch wech gekommen über die Jahre.

    Gibt es da irgend eine Möglichkeit da ran zu kommen oder das zurückzusetzen?

    Danke im Voraus

    Ronny
    Reply With Quote Reply With Quote Answered: TD 200 Passwort Problem  

  2. "
    Quote Originally Posted by Anonymous
    Hallo Zottel,

    danke erstma für die Hilfe.
    Wenn ich meinen Datenbaustein öffne dann beginnt das ganze etwa so:
    VB0 16#54
    VB1 16#44
    VB2 16#20
    VB3 16#20
    VB4 16#18
    VB5 16#01
    VB6 16#00
    VB7 16#20
    VB8 16#00
    VB9 16#0C
    VB10 16#00
    .
    .
    .
    VB511 16#20


    Ich habe jetzt nach den Bytewerten 84 gesucht aber keinen gefunden.
    Also ich meine hinter der # stehen doch die Bytewerte die du angesprochen hast. Oder? Bin ein dummer Anfänger. Sorry.

    Muss ich da irgendwie anders suchen? Was hab ich falsch verstanden?

    Danke für deine Geduld

    Ronny
    Sorry, ich habe dezimale 84 gemeint. Das ist 16#54 hexadezimal und der ASCII-Code fuer 'T'. Ebenso: 16#44 = 4*16+4=68 = ASCII D"


  3. #2
    Join Date
    19.06.2003
    Posts
    2,299
    Danke
    85
    Erhielt 274 Danke für 179 Beiträge

    Default

    Der TD-Assistent legt einen Block von 14 Byte und daran anschliessend die Fehlermeldungen in einen (den einzigen) Datenbaustein der S7-200. Der Block beginnt entweder ab VB0 oder in VW0 steht die Adresse wo er beginnt oder das TD ist auf eine andere Startadresse konfuguriert. Du erkennst den Block daran, das die ersten beuden Bytes die Kennung 'TD' (bytewerte 84 und 68 ) enthalten.
    Byte 10 und 11 diese Blocks enthalten das Passwort.
    Du solltest auch den Datenbaustein aus der CPU laden und diesen erneut mit dem TD-Assistenten bearbeiten klnnen.

    Ich muss doch die Forensoftware daran hintern acht,Klammer auf in ein Grinsgesicht zu verwandeln!

  4. #3
    Anonymous Gast

    Default

    Hallo Zottel,

    danke erstma für die Hilfe.
    Wenn ich meinen Datenbaustein öffne dann beginnt das ganze etwa so:
    VB0 16#54
    VB1 16#44
    VB2 16#20
    VB3 16#20
    VB4 16#18
    VB5 16#01
    VB6 16#00
    VB7 16#20
    VB8 16#00
    VB9 16#0C
    VB10 16#00
    .
    .
    .
    VB511 16#20


    Ich habe jetzt nach den Bytewerten 84 gesucht aber keinen gefunden.
    Also ich meine hinter der # stehen doch die Bytewerte die du angesprochen hast. Oder? Bin ein dummer Anfänger. Sorry.

    Muss ich da irgendwie anders suchen? Was hab ich falsch verstanden?

    Danke für deine Geduld

    Ronny

  5. #4
    Join Date
    19.06.2003
    Posts
    2,299
    Danke
    85
    Erhielt 274 Danke für 179 Beiträge

    Default

    Quote Originally Posted by Anonymous
    Hallo Zottel,

    danke erstma für die Hilfe.
    Wenn ich meinen Datenbaustein öffne dann beginnt das ganze etwa so:
    VB0 16#54
    VB1 16#44
    VB2 16#20
    VB3 16#20
    VB4 16#18
    VB5 16#01
    VB6 16#00
    VB7 16#20
    VB8 16#00
    VB9 16#0C
    VB10 16#00
    .
    .
    .
    VB511 16#20


    Ich habe jetzt nach den Bytewerten 84 gesucht aber keinen gefunden.
    Also ich meine hinter der # stehen doch die Bytewerte die du angesprochen hast. Oder? Bin ein dummer Anfänger. Sorry.

    Muss ich da irgendwie anders suchen? Was hab ich falsch verstanden?

    Danke für deine Geduld

    Ronny
    Sorry, ich habe dezimale 84 gemeint. Das ist 16#54 hexadezimal und der ASCII-Code fuer 'T'. Ebenso: 16#44 = 4*16+4=68 = ASCII D

  6. #5
    spassmann Gast

    Default

    Danke dir,

    Also müsste ich in meinem Fall

    VB9 16# und VB10 16# beide auf 00 setzen? Richtig?
    Also das 10. und 11. Byte.

    Ich weis ich stell mich bissl an.

    Gruß
    Spassmann

  7. #6
    Join Date
    19.06.2003
    Posts
    2,299
    Danke
    85
    Erhielt 274 Danke für 179 Beiträge

    Default

    Quote Originally Posted by spassmann
    Danke dir,

    VB9 16# und VB10 16# beide auf 00 setzen? Richtig?
    Also das 10. und 11. Byte.
    Das Passwort steht in Byte 10 und 11, also im 11. und 12. Byte.
    Wenn du dir VW10 (2 byte als wort) anzeigen lässt, hast du es gleich als Wort. Sonst must du 256*vb10 +vb11 rechnen.
    Dies sollte das Passwort sein, das du am TD eintippen must.
    0 beduetet wohl, dass du 0000 eintippen oder bestätigen musst. Es bedeutet wohl nicht, dass kein Passwort aktiv ist. Um das Passwort global inaktiv zu schalten, musst du bit 6 im byte 3 (VB3, 4.Byte) auf 0 setzen.
    In deiner Konfiguration ist das Passwort jedoch bereits dektiviert:
    VB3 16#20
    =binär 0010 000
    Vergleiche Handbuch zum TD200, Anhang D, Seite D-6, Bild D-4

  8. #7
    spassmann Gast

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ja hab ich jetzt probiert, habs umgeschrieben und auch das Passwort deativiert im TD Assistent. Aber da war nix zu machen. Ich hab dann noch probiert das Programm aus der S7 zu laden, aber da sieht es genauso aus. Ich schreib alle Fehlermeldungen noch mal.

    Trotzdem Danke für deine Geduld mit mir.

    Gruß
    Spassmann

Similar Threads

  1. Replies: 19
    Last Post: 15.01.2009, 13:51
  2. Problem mit Passwort OP7
    By margral2 in forum HMI
    Replies: 6
    Last Post: 29.08.2006, 08:31
  3. S7-200 Passwort für Datenbausteine
    By S7-Fighter in forum Simatic
    Replies: 3
    Last Post: 26.07.2006, 14:34
  4. S7 200 Passwort
    By Much2k in forum Simatic
    Replies: 2
    Last Post: 19.06.2006, 12:59
  5. Passwort S7-200
    By Anonymous in forum Simatic
    Replies: 3
    Last Post: 02.11.2003, 16:29

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •