Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 3 ErsteErste 123 LetzteLetzte
Ergebnis 11 bis 20 von 25

Thema: Visualisierung mit SPS S7-200 über Excel

  1. #11
    oddball ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    19.12.2006
    Beiträge
    12
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    hi helmut,
    es ist noch aktuell. Zurzeit warte ich auf das Master-Kabel um SPS und PC anzuschließen(über USB). Nächste Woche soll es so weit sein.
    MFG
    oddball

  2. #12
    oddball ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    19.12.2006
    Beiträge
    12
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hi Helmut,
    sowit sogut. Habe zurzeit komplett die Hard- und Software. Kriege eine einwandfreie Verbindung der SPS und PC über Multi-Master-Cable (USB/PPI). Probeweise habe ich ein PT100 mit Wandler 0-10V an das Erweiterungsmodul EM231 angeschlossen. PC Access ist ebenfalls installiert.
    Frage: wie kann ich diesen Sensor über Excel Auswerten. Ich brauche eine KOP oder FUP. Hilfe, hilfe.
    MFG
    oddball

  3. #13
    Registriert seit
    01.08.2005
    Beiträge
    247
    Danke
    3
    Erhielt 41 Danke für 32 Beiträge

    Standard

    Hallo oddbal,

    Starte mal PC-Access. Die Kommunikation brauchst nicht einstellen, da die Einstellungen von MicroWIN automatisch übernommen werden.

    Jetzt hast du in PC-Access ganz links oben ein Project und einen Zugangspunkt (z.B. MicroWIN (USB)). Markiere den Zugangspunkt und füge mit rechter Maustate eine Steuerung hinzu. Achte darauf, daß die CPU-Stationsadresse deiner CPU entspricht. Defualt Name ist "Neues Zielsystem" kannst aber auch anders benennen.

    Markiere dein Zielsystem. Jetzt kannst wieder mit rechter Maustaste schon den ersten Item (Wert in der CPU) eintragen. Hast du schon ein MicroWIN Projekt mit symbolischen Namen so kannst diese direkt in PC-Access importieren.

    Erster Test:
    Wähle <Einfügen; Item>. In dem erscheinenden Fenster gib mal in das Feld "Adresse" SMB0 ein. SMB0 enthält die Status SM's der CPU und ändert ständig seinen Wert wenn die CPU in RUN ist.

    Jetzt kannst du dein erstes Item in den Testclient ziehen (von rechts oben in das untere Fenster) und den Status aktivieren.

    Wenn die Verbindung klapt, dann sollte nach ein paar Sekunden im Testclient die "Qualität" von "Schlecht" nach "Gut" wechseln und du solltest in der Spalte "Wert" einen sich ändernden Wert sehen.

    Wenn dem so ist, dann läuft alles. PC-Access kann mit der CPU kommunizieren und alle Komm-Einstellungen passen.

    Wichtig:
    Bevor du jetzt irgend einen anderen OPC-Client verwendest MUSST du das Projekt in PC-Access speichern.

    Wenn das soweit funktioniert, dann melde dich und wir machen mit MS-Excel weiter.

    Gruss

    Helmut

  4. #14
    oddball ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    19.12.2006
    Beiträge
    12
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hi Helmut,
    sowit bin ich leider nicht, dass wir weiter mit Excel machen können. Eins ist mit unklar. Wieso fangen wir gleich mit Access, wenn ich noch kein Programm auf der SPS geladen habe? Mussen wir das zerste machen oder mache ich hier einen Denkfehler?
    Also wenn ich PC Access öffne ist oben links Projekt zu sehen dadrunter MicroWin(USB).
    Mir ist aber noch unklar was ich danach machen muss (bitter erklär das so wie für 6-jährigen lol).
    Was bei mir möglich ist, ist Rechtsklick auf MicroWin(USB) dann "neues Zielsystem..". Es erscheint Eigenschaften Zielsystem-Fenster in dem ich Name und Netzadresse einstellen kann. Wenn ich einen Name z.B: NewPLC eingebe und auch die Netzadresse einstelle (2) erscheint in PCAccess fenster (oben rechts) unter MicroWin(USB) ein weiter "Zweig" mit der Angabe NewPLC. Ist das OK? Was soll ich weitermachen?
    MFG
    oddball
    Geändert von oddball (17.01.2007 um 10:14 Uhr)

  5. #15
    Registriert seit
    01.08.2005
    Beiträge
    247
    Danke
    3
    Erhielt 41 Danke für 32 Beiträge

    Standard

    Hallo oddball,

    Das SMB0 ist immer in der CPU. Auch wenn kein Programm in der CPU vorhanden ist. Ist mein Favorit wenn darum geht mal schnell was zu testen ohne was zu programmieren.

    Hier nochmal das weiter Vorgehen Schritt für Schritt ohne große Erklärungen:

    + Markiere "MicroWIN (USB)
    + mit rechter Maus "Einfügen; Item" auswählen
    + in dem Fenster bei Adresse SMB0 eintragen + OK
    + Den Eintrag von oben rechts nach unten in Test Client ziehen
    + Unter <Status> "Testclient starten" auswählen
    + Im unteren Fenster jetzt den Status des Wertes SMB0 beobachten
    + Wenn in Spalte <Qualität> "Gut" steht dann passt alles
    + In PC-Acess jetzt speichern und einen sinnvollen Namen vergeben

    Wenn das alles funktioniert, dann haben wir mal eine Grundlage und können als nächstes diesen einen Wert in Excel lesen.#

    Gruss Helmut

  6. #16
    oddball ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    19.12.2006
    Beiträge
    12
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ich habe einwenig weiter überlegt und ausprobiert und es klappt. Ich kann Items einfügen. Alles klappt. Qualität ist gut. Kann weiter gehen!!!
    Geändert von oddball (17.01.2007 um 11:00 Uhr)

  7. #17
    Registriert seit
    01.08.2005
    Beiträge
    247
    Danke
    3
    Erhielt 41 Danke für 32 Beiträge

    Standard

    Hallo oddbal,

    ein Programmierkurs ist hier zu aufwendig.

    Installier die mal die zweite CD von MicroWIN auf deinem Rechner.

    Wenn die S7-200 Doku dann startest die Sprache auswählen.
    Unter <Programmiertraining; Grundlegende SPS-Konzepte> findest du die 1-Stunden Fibel.
    Unter <Programmiertaining; Programmierung> die 2-Stunden Fibel.

    Hier denke ich das ist eine recht gut gemachte Einsteigerlektüre zur Programmierung. Ist allerdings schon "etwas" älter aber die Prgrammierung hat sich nicht wesentlich geändert (für Anfänger ).

    Gruss
    Helmut

  8. #18
    oddball ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    19.12.2006
    Beiträge
    12
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hi,
    die beiden Fiebelstunden habe ich bereits hinter mir. Doch sehr viel zu meinen Problem habe ich dort nicht gefunden. Die Kurse beziehen sich nur auf die reine digitale Verarbeitung eines Problems jedoch wird dort die analoge Problematik nicht behandelt. Ein Kurs in der Programieren verlange ich auch net, dass währe umständlich.
    Zurück zu meinen Problem! Ich bekomme das Sigmal auf Exceloberfläche. Kein Problem. Jedoch schwanken die Werte ziemlich stark zwischen 1 und 130. Eine ordentliche Wertauswertung ist das net da ich mit den Temperatursensor hier im Raum eine zienlich konstante Temperatur haben musste. Auch wenn ich den Sensor komplet abklemme, werden diese stark schwankende Werte angezeigt. Wieso??? Kannst du mir da weiterhelfen?
    MFG
    oddball
    Geändert von oddball (17.01.2007 um 12:27 Uhr)

  9. #19
    Registriert seit
    01.08.2005
    Beiträge
    247
    Danke
    3
    Erhielt 41 Danke für 32 Beiträge

    Standard

    Hallo oddball,

    die einfachste Lösung ist eine Mittelwertbildung.
    Öffne in MicroWIN mal den Systemdatenbaustein. Hier findest du einen Ordnen mit "Eingabefilter". Öffne den mal und wechsle in das Register Analog. Aktiviere mal das Filtern für die von dir verwendeten Analogeingänge und prüfe, ob sich das Verhalten verbessert.

    Wenn ja, aber du noch nicht zufrieden bist, dann kannst den Wert "Analogabfragen" höher stellen.

    Wenn da nicht weiterhilft, dann hast wahrscheinlich Störungen auf deinen Signalen und musst die verrringern (Schirrmung, geschirmte Leistungen, Leitungsführung, Leitungslänge, Schutzbeschaltungen, ungenutzte Analogeingänge kurzschließen, etc.).

    Wenn die Mittelwertbildung nicht den gewünschten Erfolg bringt, dann die Analogkanäle kurzschließen und prüfen, ob der Analogeingang jetzt stabiler wird. Wenn nicht, dann hast du Störungen und mußt diese minimieren. Meist hilft aber das Filtern.

    Ich teste das immer mit einer Statustabelle in MicroWIN. Einfach den erstan Kanal Adresse AEW0 in die Tabele eingeben und "ENTER" drücken, dann wird immer der nächste Kanal automatisch eingefügt. Hast deine verwendeten alle in der Liste, Status starten und dann mit der Untersuchung beginnen.

    Hoffe das hilft weiter.

    Gruss

    Helmut

  10. #20
    oddball ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    19.12.2006
    Beiträge
    12
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hi Helmut,
    Das Problem habe ich bereits behoben. Trotzdem vielen Dank für deine Hilfe. Habe jetzt eine ordentliche Verbindung zum Temp.sensor. Bekomme jetzt int Werte. Diese habe ich bereits skaliert mit 0V und 10V. Mit diesen Werten und dem Messbereich habe ich eine Geradengleichung errechnet und diese in Excel eingegeben. Es funktioniert einwandfrei.
    Meine nächste Sorge sind die Alarmwerte. Ich schreibe dir was ich bis jetzt ausprobiert habe:
    1. habe ein Makro geschrieben (Public Funktion Temp () ...), der mir ein Digitalenausgang auf der SPS aktiviert(1). Diese Makro habe ich versucht in Excel in eine WENN-Funktion einzufügen (wenn(a1>=25;Temp();"")). Doch wenn der Temperaturwert die 25 erreicht schmiert mir Excel ab. Habe keine ahnung wieso.
    2. als zweite Möglichkeit sehe ich die OPC-Funktion OPCwrite(a;b;c) mit der Möglichkeit vordefinierte Werte in der Steuerung zu beschreiben. Nun weiss ich abet net was ich für die Kordinaten a, b und c in der Funktion eintargen soll.
    Kannst du mir bitte da weiterhelfen oder weist du eine andere Möglichkeit Alarmwerte zu definieren (z.B sensortem. über 25°C; Folge: Ausgang 0.0 der SPS wird 1; Folge: Alarm geht los!)
    MFG
    oddball

Ähnliche Themen

  1. Visualisierung über ProTool
    Von Black Scorpion im Forum HMI
    Antworten: 8
    Letzter Beitrag: 30.03.2009, 10:20
  2. Visualisierung über Modbus
    Von jeanfischer im Forum HMI
    Antworten: 0
    Letzter Beitrag: 09.07.2008, 10:25
  3. Antworten: 0
    Letzter Beitrag: 27.07.2007, 17:55
  4. Visualisierung über PC
    Von teslaeisenbahner im Forum HMI
    Antworten: 9
    Letzter Beitrag: 08.10.2006, 10:46
  5. Visualisierung Eigensoftware - über AS 512
    Von Unregistriert im Forum HMI
    Antworten: 1
    Letzter Beitrag: 17.02.2006, 07:15

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •