Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 16

Thema: S5 an OP5

  1. #1
    Registriert seit
    07.12.2005
    Beiträge
    17
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Leuts,

    Ich habe folgendes Problem, ich habe eine S5 CPU 103 und möchte ein OP5 /A1 daran anschließen.
    Ich habe die passenden Kabel und Software da, es scheitert jegendlich an der Programmierung.

    Ich bin noch Anfänger auf dem Gebiet.
    Ein paar kleine Programmiertips wie z.B. ich drücke Taste F2 und am AG schaltet Ausgang 0.0

    Wäre nicht schlecht wenn mir dieses einer schritt für schritt erklärt.

    Ich danke schon mal im Voraus.

    Tschau Ronny
    Zitieren Zitieren S5 an OP5  

  2. #2
    Registriert seit
    20.12.2003
    Ort
    Obrigheim
    Beiträge
    420
    Danke
    31
    Erhielt 31 Danke für 27 Beiträge

    Standard

    Hi,

    schreib mal genau was du machen willst?
    Arbeitest mit ProTool,oder?


    Robert
    Stress hat nur der Leistungsschwache

  3. #3
    Registriert seit
    10.10.2006
    Ort
    Krefeld
    Beiträge
    101
    Danke
    0
    Erhielt 10 Danke für 10 Beiträge

    Standard

    Hallo,

    Zitat Zitat von Ronny Beitrag anzeigen
    Hallo Leuts,

    Ich habe folgendes Problem, ich habe eine S5 CPU 103 und möchte ein OP5 /A1 daran anschließen.
    Ich habe die passenden Kabel und Software da, es scheitert jegendlich an der Programmierung.

    Ich bin noch Anfänger auf dem Gebiet.
    Ein paar kleine Programmiertips wie z.B. ich drücke Taste F2 und am AG schaltet Ausgang 0.0

    Wäre nicht schlecht wenn mir dieses einer schritt für schritt erklärt.

    Ich danke schon mal im Voraus.

    Tschau Ronny
    Hier mal die Links zu den Handbüchern:

    Protool/Lite - Benutzerhandbuch
    Operator Panel OP5, OP15 - Gerätehandbuch
    Kommunikation - Benutzerhandbuch

    Wenn nach dem Lesen und ersten Versuchen konkrete Fragen bzw. Probleme auftauchen, wird sich hier bestimmt jemand finden, der Dir diese beantwortet bzw. Hilfestellungen gibt.


    Gruss & juten Rutsch
    Jörg
    Nobody is perfect ... so don't call me Nobody
    Wer glaubt, dass Abteilungsleiter Abteilungen leiten, der glaubt auch, dass Zitronenfalter Zitronen falten.

  4. #4
    Registriert seit
    09.11.2006
    Beiträge
    690
    Danke
    36
    Erhielt 31 Danke für 29 Beiträge

    Standard

    Desweiteren ist zu beachten das du bei der S5 Kopllung über AS511 udn auc bei anderen Kopplungsarten einen Funktionsbaustein aus der Siemens Bibliothek, die du wie alles bei Siemens kaufen musst, benötigst. Es handelt sich glaub ich um den FB TDOP weiß nicht ob der Baustein auch noch CPU abhängig ist.

  5. #5
    Ronny ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    07.12.2005
    Beiträge
    17
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hi Jörg,

    Danke für deine Antwort, Ich arbeite mit Protool und die Handbücher habe ich auch alle. Den sogenanten FB habe ich nach langem suchen auch. Ich habe auch schon eine Verbindung zur SPS. Das OP Schreibt Fehler 613 im Handbuch steht was von Datenbaustein. Da ich aber das erste mal mit Datenbausteinen zu tuhen habe ( vorher nur kleine Regelaufgaben gesteuert). Ich war schon überfordert alls im Handbuch für Komunikation drin stand das ich ein DB mit 185 DW erzeugen soll wo nix drin steht. Wie mach ich das?

    Im Prinzip soll das Ganze mal ne Steuerrung für das AQ sein, aber davon bin ich sicher noch sehr weit entfernt.

    Jetz will ich eigentlich nur erst mal das, wenn ich z.b Taste F1 drücke soll ausgang 0.0 geschaltet werden.

    Es wäre nicht schlecht wenn mir dieses schritt für schritt (für Doofe) erklären könnte.

    Ich danke schon mal im Voraus

    tschau Ronny

  6. #6
    Registriert seit
    20.12.2003
    Ort
    Obrigheim
    Beiträge
    420
    Danke
    31
    Erhielt 31 Danke für 27 Beiträge

    Standard

    Hallo,

    der Fehler mit dem Datenbaustein könnte folgendes sein:
    - er wurde nicht erstellt
    - er ist vielleicht nicht lange genug.

    Mit OP's und S5 hab ich noch nichts zu tun gehabt. Aber normalerweise eine Variable erstellen und diese dann weiterverarbeiten. Wie das genau bei S5 geht, keine Ahnung.

    Guten Rutsch.

    Robert
    Stress hat nur der Leistungsschwache

  7. #7
    Registriert seit
    28.06.2006
    Ort
    Königreich Neuseeland
    Beiträge
    2.027
    Danke
    133
    Erhielt 96 Danke für 76 Beiträge

    Standard

    Zitat Zitat von Ronny Beitrag anzeigen
    Ich war schon überfordert alls im Handbuch für Komunikation drin stand das ich ein DB mit 185 DW erzeugen soll wo nix drin steht. Wie mach ich das?
    In dem du "F2" drückst.

  8. #8
    Ronny ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    07.12.2005
    Beiträge
    17
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hi leuts,

    Es wäre erst mal die Frage zu klären wie ich den Schnittstellenbereich erstelle.
    Wie schon gesaget mit nem DB mit 185 Worten wo nix drin steht? wie geht das unter WinSPS?

    wen das geschaft ist müsst dan auch die Fehlermeldung verschwinden.

    Ich danke schon mal im Vorraus für eure Antworten.

    tschau Ronny

  9. #9
    Registriert seit
    20.06.2003
    Ort
    Sauerland.NRW.Deutschland
    Beiträge
    4.850
    Danke
    78
    Erhielt 800 Danke für 543 Beiträge

    Standard

    für die 103er benötigst du den db der gruppe 2 (der ist länger als der der gruppe 1)
    zur kommunikation benötigst du den fb51:as511

    der wird folgendermassen im ob1 aufgerufen.
    L KY 51,0
    SPA FB 51

    du musst darauf achten, dass du den richtigen fb51 benutzt.
    der ist für die verschiedenen cpu's nicht immer der gleiche.
    schau diesbezüglich einfach mal auf meine hp.

    hier mal der db51

    im protoolprojekt lege einen bereichszeiger schnittstellenbereich an. db51 mit der länge 254 worte.

    damit steht schon mal die kommunikation.
    Angehängte Dateien Angehängte Dateien
    .
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download

    Meine Definition von TIA: Total Inakzeptable Applikation

  10. #10
    Ronny ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    07.12.2005
    Beiträge
    17
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Volker,

    danke für deine Antwort. Ich habe es auch gleich mal ausprobiert aber leider schreibt das OP immernoch $613 DB Fehler NR 10 (3;7). Im Benutzerhandbuch steht nichts über die Fehlernummer. Nur das es ein Projektierfehler ist. Zu der Nr 10 (3;7) steht nüscht.

    vieleicht hat jemand eine Ahnung was das sein könnte, Ich bin für jede dankbar.

    tschau Ronny

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •