Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 4 von 4 ErsteErste ... 234
Ergebnis 31 bis 33 von 33

Thema: PID Regler Problem

  1. #31
    S7_Mich ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    18.05.2004
    Beiträge
    203
    Danke
    2
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo nochmal,

    kann mich erinnern, das irgendwo mal gelesen habe, das es eine PID-Tuner gibt, der selbständig die PID-Anteile berechnet. Allerdings glaube ich, das war nur für S7-200. Gibts sowas nicht auch für die S7-300?

    Nennt sich PID-Tuner oder so ähnlich. Kennt das jemand?

    Gruß
    Michael

  2. #32
    Registriert seit
    22.09.2006
    Ort
    Bodenseeraum
    Beiträge
    1.022
    Danke
    61
    Erhielt 136 Danke für 122 Beiträge

    Beitrag

    Hi,
    es gibt ein Siemens FB (TCONT_CP, FB58 ) , der selftunning beinhaltet, ist aber speziell für Temp. Regelung geeignet.

    Gruss: V.
    ______________________________________
    relax, take it easy
    Zitieren Zitieren Pid  

  3. #33
    S7_Mich ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    18.05.2004
    Beiträge
    203
    Danke
    2
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    hallo,

    lenkung funktioniert jetzt einwandfrei.

    habe mich jetzt an den regler für den fahrantrieb gemacht. dieser war auch im hardwareregler implementiert. es war hier ein pt regler im einsatz.

    http://www.automation.siemens.com/do...ngstechnik.pdf

    Hier auf seite 48 ist eine pt2 regelung beschrieben, bzw. wie ich den p und den i-anteil berechne. man kann also sagen ein PT-Regler ist ein pi regler, oder sehe ich das falsch. wenn ich alle so mache, wies dort beschrieben ist, erhalte ich genau diese kurve. was aber nicht klar ist, ist im hardwareregler ein pt1 oder pt2 regler drin. das ist nirgends beschrieben. pt2 regler hat ja eine verzugszeit tu und eine ausgleichszeit tg. wenn man jetzt vermuten würde, da im hardwareregler ein pt1 regler drin ist, hätte ich dann nur eine ausgleichszeit und keine verzugszeit?

    kpr=0,9*tg/ks*tu
    tn=3,33*tu

    kpr=proportionalwert
    tn=integrationszeit

    wenn ich diese werte berechne kommt man auf folgendes ergebnis.

    kpr=0,9*1,7s/1*0,25s=6,12
    tn=0,83

    wie hier schon mal beschrieben, wird der p-bereich, der im hardwareregler bei 80 ist, errechnet mit dem kehrwert. 1/80 *100 = 1,25. da bin ich aber dann weit weg.

    übrigens ist mir auch noch nicht ganz klar, wie ich die obere begrenzung des stellwert im pid parametrieren programm einstellen soll. der servo wird mit 0-5V angesteuert. der analogausgang ist 0-10v. ich habe die obere grenze auf 100% gestellt und die normierungsfaktor auf 0.5. somit habe ich wieder eigentlich nur 50%. aber rein theoretisch könnte man es ja auch anders herum einstellen. obere grenze 50% und normierungsfaktor auf 1. was ist hier richtig?

    man kann aber sagen, das der proportionalbeiwert von 6,12 zu hoch ist. ganz klar ist mir aber auch noch nicht, wo der wert ks herkommt.

    fragen über fragen, aber vielleicht könnt ihr mir ein wenig licht ins dunkle bringen!

    gruß
    michael

    übrigens: gibts so eine beschreibung (also tagente ziehen und daraus werte berechnen) auch für einen PDT regler. wobei ich aber noch nicht ganz verstehe, was eigentlich ein pdt regler sein soll. p und d ist klar, aber wieder der t. dieser regler ist in der lenkung im einsatz. gut der funktioniert zwar jetzt schon, aber wissen würd ich es trotzdem gerne.

Ähnliche Themen

  1. CPU-tausch Problem mit PID-Regler
    Von dicker im Forum Simatic
    Antworten: 12
    Letzter Beitrag: 29.03.2011, 10:57
  2. Problem mit S7 / Pt100 & PID Regler / TP177A
    Von suelzle.frank@web.de im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 18.12.2009, 10:55
  3. Lenze Pos.Regler 9300 Problem
    Von Erdferkel im Forum Antriebstechnik
    Antworten: 4
    Letzter Beitrag: 29.10.2007, 22:28
  4. S5-95u Integrierter PID Regler Problem
    Von demo im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 14.01.2007, 17:57
  5. Problem mit dem PID Regler S7-200
    Von BTDA im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 03.06.2004, 12:32

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •