Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: S7 Onlineverbindung über Funk (Dataeagle)

  1. #1
    Registriert seit
    09.11.2006
    Beiträge
    690
    Danke
    36
    Erhielt 31 Danke für 29 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Leute,
    ich hoffe einige von euch haben ein Lösung für mein Problem:


    Ich habe 2 Dataegle DE1000 der Firma Schildknecht. Dabei handelt es sich im Prinzip um ein virtuelles Kabel. Diese waren bis jetzt als "Funkschnittstelle" an einer S5 im Einsatz. Hat alles super geklappt!!!

    Nun hat der Kran aber eine S7 bekommen!!!!!

    Jetzt habe ich folgendes probiert:

    MPI/TS Adapter der Fa. Deltalogic an SPS angekoppelt. Ausgang des Adapters an Dataegle.
    Anderes Dataeagle über RS232 an PC!!!

    Nur kann ich einstellen was ich will ich bekomme keine Verbindung.

    Jetzt habe ich 2 vermutungen :

    1. Die Baudrate vom MPI/TS Adpter ist nicht fix.

    Die einstellungen Parity Datenbits etc passen nicht

    Hat jemand sowas schon mal benutzt und wie habt ihr dieses Problem gelöst.

    P.S. Wenn ich den Adapter direkt an mein PG hänge funktioniert er einwandfrei!!!!
    Vermutlich liegt daher das Problem am Adapter da er über Simatic Manager parametriert wird. aber der hat ja keinen direkten Zugriff mehr.

    Danke für euer Hilfe
    Zitieren Zitieren S7 Onlineverbindung über Funk (Dataeagle)  

  2. #2
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.224
    Danke
    630
    Erhielt 955 Danke für 769 Beiträge

    Standard

    S5 und S7 haben komplett andere Parameter auf der RS232-Seite. Wie ist denn der DE eingestellt? Was sagt der Support von Schildknecht dazu?
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

  3. #3
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.218
    Danke
    533
    Erhielt 2.696 Danke für 1.948 Beiträge

    Standard

    Hier ist die Bedienungsanleitung der Geräte (falls du keine hast). Lt. dieser sollte deine Variante funktionieren. Es wird wohl tatsächlich an den Einstellungen liegen.

    Link: http://www.wito-ag.ch/download/Dataeagle/DE_HB.pdf
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  4. #4
    mitchih ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    09.11.2006
    Beiträge
    690
    Danke
    36
    Erhielt 31 Danke für 29 Beiträge

    Standard

    Hallo,
    das ging aber fix. Handbuch habe ich trotzdem danke. Also der DE ist auf User eingestellet Baudrate kann ich auf 56,2k und 115k 8/E/1 Daten/Parity/Stopbits Außerdem könnte ich noch none oder odd bim Parity einstellen dazu gibt es noch den Menüpunkt S7-MPI dort sollten laut schildknecht die Parameter eignetlich passen passen!!!!!!!
    Sie meinen es liegt am S7 Adapter das er die Baudrate nicht fix eingestellt hat. Denn der Deltalogic Adapter besitzt ja nicht wie der S7 Adapter eine Schalter für die Baudrate.

    Das die S5 über eine TTY Schnittstelle angekoppelt war ist mir bekannt. Dort gab es ja einen extra Menüpunkt Schnittstellen treiber S% AS511

    Hat vielleicht jemand noch eine Idee???

  5. #5
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.224
    Danke
    630
    Erhielt 955 Danke für 769 Beiträge

    Standard

    Zitat Zitat von mitchih Beitrag anzeigen
    Sie meinen es liegt am S7 Adapter das er die Baudrate nicht fix eingestellt hat. Denn der Deltalogic Adapter besitzt ja nicht wie der S7 Adapter eine Schalter für die Baudrate.
    Der Adapter hat eine automatische Baudratenerkennung. Dies bedeutet, wenn er mit z.B. 57,2 kBps angesprochen wird, antwortet er auch mit dieser Baudrate. Diese Erkennung funktioniert zuverlässig.
    Was geht den wirklich über die Schnittstelle bzw. was kommt zurück? Dafür z.B. http://www.serial-port-monitor.com/index.html einsetzen und mir das Log (exportierte Daten des "Request View" und des "Table View") per Mail schicken. Kann dann mehr dazu sagen.
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

  6. #6
    mitchih ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    09.11.2006
    Beiträge
    690
    Danke
    36
    Erhielt 31 Danke für 29 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Rainer Hönle Beitrag anzeigen
    Der Adapter hat eine automatische Baudratenerkennung. Dies bedeutet, wenn er mit z.B. 57,2 kBps angesprochen wird, antwortet er auch mit dieser Baudrate. Diese Erkennung funktioniert zuverlässig.
    Was geht den wirklich über die Schnittstelle bzw. was kommt zurück? Dafür z.B. http://www.serial-port-monitor.com/index.html einsetzen und mir das Log (exportierte Daten des "Request View" und des "Table View") per Mail schicken. Kann dann mehr dazu sagen.
    Vielen Dank für die prompten antworten,leider fehlte bis jetzt die Zeit das ganze mit dem Port Monitor zu testen.

    Folgendes haben ich aber zusätzlich anzumerken:

    Die beiden Funksender haben eine Aktivitätsanzeige,
    es reagiert nur ab und zu das Dataeagle welches am PC Adapter hängt.

    Das Dataeagle am PC macht keine Mucken auch nicht wenn ich beide untereinander tausche.

    Habe halt mal die Standardeinstellung der Funkschnittstelle genommen die macht das wie oben beschrieben,

    hätte noch die Möglichkeit USER Parameter einzugeben. Einzustellen sind

    Baudrate/ Daten/Parity/Stoppbits RTS nächste Zeile aktuelle einstellung

    57,2 8 O 1 aus

    lt. nochmaliger Nachfrage bei Fa. Schildknecht müsste es mit den USER Parametern immer klappen, leider konnte mann mir die EInstellung welche zum PC Adpater passt nicht nennen, weiß jemand diese????

    Versuche es nochmal mit der Soft auzuwerten, muss aber dazu erst ein Notebook ohne Netzanbindung haben sonst darf ich die nicht installieren

Ähnliche Themen

  1. Endschalter über Funk
    Von WimC im Forum Elektronik
    Antworten: 8
    Letzter Beitrag: 12.11.2010, 17:21
  2. RS232 über Funk
    Von Johannes F im Forum Feldbusse
    Antworten: 13
    Letzter Beitrag: 22.11.2009, 12:36
  3. Antworten: 7
    Letzter Beitrag: 08.06.2009, 10:01
  4. Profibus DP über Funk
    Von HaSchi im Forum Feldbusse
    Antworten: 10
    Letzter Beitrag: 19.10.2007, 11:40
  5. Antworten: 0
    Letzter Beitrag: 18.10.2007, 11:49

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •