Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 4 ErsteErste 1234 LetzteLetzte
Ergebnis 11 bis 20 von 34

Thema: PT-100 an S7-414 3°C zu hoch?

  1. #11
    Registriert seit
    08.07.2006
    Beiträge
    149
    Danke
    1
    Erhielt 11 Danke für 7 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    bei richtiger Einstellung der Analogkarte wird der In Grad *10 oder in Grad *100 ausgegeben. (sihe Anhang)
    Man muß also nur das Eingangswort durch den entsprechenden Faktot teilen und schon hat man den Temperaturwert.

    Nartürlich muß man auch die Genauigkeit der Analogbraugruppe beachten.

    Martin
    Angehängte Grafiken Angehängte Grafiken
    • Dateityp: jpg PT.jpg (46,9 KB, 38x aufgerufen)

  2. #12
    Registriert seit
    08.07.2006
    Beiträge
    149
    Danke
    1
    Erhielt 11 Danke für 7 Beiträge

    Standard

    Zitat Zitat von gravieren Beitrag anzeigen
    Hi Martin



    Warum nicht ?

    PT100 --> 100 Ohm

    Widerstandsmessung bis 500 Ohm.


    Siehe Handbuch 5-79.
    https://a248.e.akamai.net/cache.auto...B/425rfh_d.pdf


    Oder habe ich da einen Denkfehler

    +
    +
    Hallo gravieren

    dabei erfasse ich nicht die Temperatur sonden einen Widerstandswert.
    Dann muß man im S7-Programm den Widerstandswert in eine Temperatur un rechnen. Dabei ist zu beachten, das die Kurve eines PT100 nicht liniar ist.

    Martin

  3. #13
    Registriert seit
    10.05.2005
    Beiträge
    1.996
    Danke
    220
    Erhielt 233 Danke für 204 Beiträge

    Standard

    Hi Martin

    Sorry etwas aus der Rehe gerissen

    Nochmals zum nachverfolgen


    Martin:
    Hallo Chris

    Laut Siemens Handbuch:
    Analogeingabebaugruppe SM 431; AI 8 x 13 Bit;
    (6ES7431-1KF00-0AB0)
    Eigenschaften
    Die Analogeingabebaugruppe SM 431; AI 8 x 13 Bit hat folgende Eigenschaften:
    • 8 Eingänge bei Spannungs-/Strommessung
    • 4 Eingänge bei Widerstandsmessung
    • verschiedene Messbereiche parallel einstellbar
    • Auflösung 13 Bit
    • Analogteil potenzialfrei gegenüber CPU
    • maximal zulässige Gleichtaktspannung zwischen den Kanälen bzw. zwischen den Bezugspotenzialen der angeschlossenen Geber und MANA AC 30 V


    Also wie hast du den PT100 angeschlossen?
    Laut Handbuch kann man einen PT100 nicht direkt anschliessen.
    PT100 ist elektrisch gesehen ein Widerstand und somit
    gesehen anschliesbar.
    Deshalb mein Tread


    gravieren:
    Warum nicht ?
    PT100 --> 100 Ohm
    Widerstandsmessung bis 500 Ohm.

    Matin:
    Hallo gravieren

    dabei erfasse ich nicht die Temperatur sonden einen Widerstandswert.
    Dann muß man im S7-Programm den Widerstandswert in eine Temperatur un rechnen. Dabei ist zu beachten, das die Kurve eines PT100 nicht liniar ist
    .
    Logisch PT100 ist NICHT linear.

    Korekturtabelle ist in der Baugruppe.



    Kurzum haben wird beide recht
    Das heißt jedoch auch, dass Chris vermutlich eine Widerstandsmessung macht ?

    (Falsche Parametriesierung der Baugruppe ODER Kodierstecker falsch gesteckt ?)
    Karl

  4. #14
    Registriert seit
    10.05.2005
    Beiträge
    1.996
    Danke
    220
    Erhielt 233 Danke für 204 Beiträge

    Standard

    Hi Martin


    DU HAST RECHT ! ! !


    Ich habe die Baugruppe 6ES7 431-1KF00-0AB0 mal unter der HW Konfig eingerichtet.

    Diese Baugruppe kann KEINE Widerstands-->Messung.
    Ergo auch keinen PT100.

    Da muss ein Signalwandler am PT100 sein ! ! !
    Karl

  5. #15
    Registriert seit
    10.05.2005
    Beiträge
    1.996
    Danke
    220
    Erhielt 233 Danke für 204 Beiträge

    Standard

    Diese Baugruppen können PT100 OHNE Wandler :

    6ES7 431-7QH00-0AB0
    6ES7 431-1KF10-0AB0
    6ES7 431-1KF20-0AB0



    Dann Erübricht sich auch das Problem der Linearisierung.
    (Falls ein grosser Temperaturbereich benötigt wird)
    Karl

  6. #16
    Registriert seit
    08.07.2006
    Beiträge
    149
    Danke
    1
    Erhielt 11 Danke für 7 Beiträge

    Standard

    Zitat Zitat von gravieren Beitrag anzeigen
    ich habe die Baugruppe 6ES7 431-1KF00-0AB0 mal unter der HW Konfig eingerichtet.

    Diese Baugruppe kann KEINE Widerstands-->Messung.
    Ergo auch keinen PT100.
    Hallo gravieren

    wenn ich das Handbuch (Seite 5-72) richtig lese, kann man an der Baugrppe 4 Widerstandsgeber im Bereich von 0 bis 500 Ohm anschliessen, Aber keinen Temperaturwiderstand direkt anschliessen.

    Martin

  7. #17
    Registriert seit
    08.07.2006
    Beiträge
    149
    Danke
    1
    Erhielt 11 Danke für 7 Beiträge

    Standard

    Zitat Zitat von gravieren Beitrag anzeigen
    Diese Baugruppen können PT100 OHNE Wandler :

    6ES7 431-7QH00-0AB0
    6ES7 431-1KF10-0AB0
    6ES7 431-1KF20-0AB0



    Dann Erübricht sich auch das Problem der Linearisierung.
    (Falls ein grosser Temperaturbereich benötigt wird)
    Laut Handbuch Seite 5-3 sind folgende Baugruppen zur Temperaturmesseung geeignet:

    6ES7 413-1KF10-0AB0
    6ES7 413-7QH00-0AB0
    6ES7 413-7KF10-0AB0
    6ES7 413-7KF00-0AB0 (nicht für PT100)

  8. #18
    Registriert seit
    10.05.2005
    Beiträge
    1.996
    Danke
    220
    Erhielt 233 Danke für 204 Beiträge

    Standard

    Hi Martin


    Baugrppe 4 Widerstandsgeber im Bereich von 0 bis 500 Ohm anschliessen, Aber keinen Temperaturwiderstand direkt anschliessen.
    Richtig, er müsste sich die Temperaturkurve linearisieren,
    da die Baugruppe das für ihn NICHT macht.

    Welche Bereich benöigt er überhaupt.

    Wenn er nur 25 - 40 °C Messbereich benötigt, kann mann das z.b.
    als linear ansehen.
    (Soweit ich die Kennlinie im Kopf habe)
    Karl

  9. #19
    Guitarrero ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    10.01.2007
    Beiträge
    14
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hey Leute... ich bedanke mich für soviel Input.

    Ich bin ja neu hier und dass das hier solche Formen annimmt ist genial.

    Aber ich habe geschrieben, dass das PT100 über ein Koppelrelais angeschlossen ist <-- Das ist nicht richtig..

    Das PT100 ist an einen Messumformer angeschlossen, damit Analogeingangswerte habe, die die Baugruppe auch verarbeiten kann..
    Es ist ein PhoenixContact MCR-SL-PT100-I-DC-24

    Temperaturmessbereich : -100 bis 600°C

    Ausgangssignal : 0 -20 mA oder 4- 20 mA (die Baugruppe ist in der HW-Config auf 4-20 mA eingestellt)

    Jetzt ist die nächtse Frage, da ich jetzt einen Strom messe an der Baugruppe, sollte ich auch, nach dem Handbuch, mit dem Strommessbereich arbeiten und nicht mit dem Widerstandsbereich eines PT´s.
    Wie gebe ich das nun in den FC105 an..
    Ich bin der Meinung, dass er die -100 als LOW und 600 als HI eingestellt haben muss.
    Ist das richtig?

    Der Chris

  10. #20
    Guitarrero ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    10.01.2007
    Beiträge
    14
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Und so würde das dann aussehen:

    CALL "SCALE"
    IN :=PEW560
    HI_LIM :=6.000000e+002
    LO_LIM :=-1.000000e+002
    BIPOLAR:=TRUE
    RET_VAL:=MW342
    OUT :=DB50.DBD518
    Der Chris

Ähnliche Themen

  1. CPU DB-Nummer zu hoch
    Von simon.s im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 13.04.2011, 22:04
  2. SCL Lokaldatenbedarf zu hoch!
    Von hoT im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 19.03.2010, 09:17
  3. Hoch bzw. runterzählen
    Von PG675 im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 25.11.2009, 11:19
  4. 2 hoch 2/3
    Von marcelmoonwalker im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 16.11.2009, 14:44
  5. Hoch der 1. Mai
    Von riesermauf im Forum Stammtisch
    Antworten: 13
    Letzter Beitrag: 02.05.2008, 07:32

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •