Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 4 123 ... LetzteLetzte
Ergebnis 1 bis 10 von 34

Thema: PT-100 an S7-414 3°C zu hoch?

  1. #1
    Registriert seit
    10.01.2007
    Beiträge
    14
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hey an alle... gutes Neues noch...

    bei mir fängts damit an, dass meine S7-414 2DP mit der Analogbaugruppe (6ES7 431-1KF00-0AB0), an die ein PT-100 angeschlossen ist, mir ein Ergebnis anzeigt, dass um ca. 3 Grad zu hoch ist.

    L PEW 560
    ITD
    DTR
    L 5.060000e-003
    *R
    L -5.000000e+001
    +R
    T DB50.DBD 10

    So sieht die AWL dazu aus.

    Kann es daran liegen, dass ich nicht 3 nach links schiebe, das hatte ich gelesen, dass man das bei der S5-115 so machen sollte, weil Bit 0-2 die Fehlerbits sind??
    Außerdem ist das PT-100 über ein Koppelrelais mit der Analogeingabe verdrahtet.

    Kann mir da jemand helfen?
    Das wäre mal super!

    Der Chris
    Geändert von Guitarrero (10.01.2007 um 13:19 Uhr) Grund: Vergessen zu sagen, was ich schon erfahren habe-
    Zitieren Zitieren PT-100 an S7-414 3°C zu hoch?  

  2. #2
    Registriert seit
    22.09.2006
    Ort
    Bodenseeraum
    Beiträge
    1.022
    Danke
    61
    Erhielt 136 Danke für 122 Beiträge

    Ausrufezeichen

    Hi,
    für Analogwertnormierung gibt es fertige Bausteine, in der Lib
    zu finden sind (SCALE/UNSCALE). Deine AWL sieht eher aus nach
    etwas total gebasteltes(sorry)...

    Gruss: Vladi
    ______________________________________
    relax, take it easy
    Zitieren Zitieren Analogwert  

  3. #3
    Guitarrero ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    10.01.2007
    Beiträge
    14
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hey Vladi,

    ich war auch schon auf er suche, aber habe es nicht gefunden... ist schon in Ordnung, der Ursprung stammt nicht von mir

    Dann werde ich mal schaun.
    Danke schon mal.

  4. #4
    Registriert seit
    10.05.2005
    Beiträge
    1.996
    Danke
    219
    Erhielt 232 Danke für 204 Beiträge

    Standard

    Hi

    Bitte nicht schlagen, beid er 300er ist die Temperatur in 1/10 Grad bei "PT100" und bei "PT100 Klima" in 1/100 Grad.

    VORAUSGESETZT daß die Baugruppe richtig "Projektiert" ist.
    Menue Hardware ...




    Deine AWL sieht eher aus nach
    etwas total gebasteltes(sorry)...

    Warum ?


    L PEW 560 // Einlesen Wort der PT100
    ITD //
    DTR // Wandeln in REAL
    L 5.060000e-003 // Skalieren bei PT100 sollte hier 0.1 stehen ?
    // z.b. 357 * 0.1 --> 37,5 °C
    *R //
    L -5.000000e+001 // Temp-Offset z.b. 2.8 37,5 + 2.4 --> 39.9°C
    +R // Entsteht dadurch,
    // , dass du das "falsche" Kabel verwendest.
    // bei Verwendung eines Kabels mit einem
    // Widerstand von exakt 0.0 Ohm linear
    // auf auf eine Entfernung von z.b. 100 meter
    // hast du dieses Problem NICHT
    T DB50.DBD 10 // Ergebnis

    Der Inhalt von Scale ist identisch mit den AWL-Code.
    Geändert von gravieren (10.01.2007 um 16:34 Uhr)
    Karl

  5. #5
    Registriert seit
    22.09.2006
    Ort
    Bodenseeraum
    Beiträge
    1.022
    Danke
    61
    Erhielt 136 Danke für 122 Beiträge

    Standard

    Hi,
    vielleicht verstehe ich etwas nicht, aber:
    -die Analogkarte liefert z.B. 0..27648 Integer
    Der Wert muss normiert werden, sodass ich Temperatur habe:
    0: entspricht 0°C
    27648 entspricht z.B.150 °C

    Das machen die Normierbausteine. Wenn der Fühler mit
    "Sense" Leitung angeschlossen ist, ist der Fehler wegen Widerstand
    der Leitung schon weg.

    Gruss: Vladi

    P.S.: "...ist die Temperatur in 1/10 Grad bei "PT100" und bei "PT100 Klima" in 1/100 Grad.
    " : das verstehe ich nicht.
    ______________________________________
    relax, take it easy
    Zitieren Zitieren Pt100  

  6. #6
    Registriert seit
    02.02.2006
    Ort
    Hessen
    Beiträge
    429
    Danke
    16
    Erhielt 28 Danke für 22 Beiträge

    Standard

    Zitat Zitat von Guitarrero Beitrag anzeigen

    L PEW 560
    ITD
    DTR
    L 5.060000e-003
    *R
    L -5.000000e+001
    +R
    T DB50.DBD 10
    Hallo,
    nichts für ungut, aber dieser Code geht bei mir nicht als "Scalierung mit Normierung" durch. Wenn es schon nicht der FC105 SCALE CONVERT sein soll, dann aber etwas vergleichbares.
    mfG Werner
    Hoch lebe die Suchfunktion!
    Zitieren Zitieren Scalierung mit Normierung  

  7. #7
    Registriert seit
    10.05.2005
    Beiträge
    1.996
    Danke
    219
    Erhielt 232 Danke für 204 Beiträge

    Standard

    Hi Vladi


    Wir reden von 12 bis 15 bit !

    27648 entspricht z.B.150 °C
    Nein, 8500 --> 850°C BEI PT100

    Nein, 85000 --> 850°C BEI PT100 Klima.




    Anbei eine DOC-Datei mit einer Hardcopy.

    Hast du das Handbuch nicht dazu ?

    Automatisierungsystem
    S7-300
    Baugruppendaten
    Referenzhandbuch
    Kapitel 4-16


    Das Handbuch für eine S7-400 Habe ich momentan NICHT parat, solte jedoch Technisch ähnlich sein (Ohne Gewähr)


    Bei Fragen sende mir per PM deine E-Mail-Adresse




    Hier ein Handbuch jedoch 4-9 ff

    http://www.berufsschulen.de/htm/elek.../handbaugr.pdf

    *
    *
    *
    Geändert von gravieren (10.01.2007 um 18:26 Uhr)
    Karl

  8. #8
    Registriert seit
    10.05.2005
    Beiträge
    1.996
    Danke
    219
    Erhielt 232 Danke für 204 Beiträge

    Standard

    Hi

    Handbuch für die S7-400

    https://support.automation.siemens.c...1082&caller=nl



    @Vladi
    P.S.: "...ist die Temperatur in 1/10 Grad bei "PT100" und bei "PT100 Klima" in 1/100 Grad.
    " : das verstehe ich nicht.


    5-14 Auch Erklärung wegen PT100 PT100 klima
    Karl

  9. #9
    Registriert seit
    08.07.2006
    Beiträge
    149
    Danke
    1
    Erhielt 11 Danke für 7 Beiträge

    Standard

    Zitat Zitat von Guitarrero Beitrag anzeigen
    bei mir fängts damit an, dass meine S7-414 2DP mit der Analogbaugruppe (6ES7 431-1KF00-0AB0), an die ein PT-100 angeschlossen ist, mir ein Ergebnis anzeigt, dass um ca. 3 Grad zu hoch ist.
    Hallo Chris

    Laut Siemens Handbuch:
    Analogeingabebaugruppe SM 431; AI 8 x 13 Bit;
    (6ES7431-1KF00-0AB0)
    Eigenschaften
    Die Analogeingabebaugruppe SM 431; AI 8 x 13 Bit hat folgende Eigenschaften:
    • 8 Eingänge bei Spannungs-/Strommessung
    • 4 Eingänge bei Widerstandsmessung
    • verschiedene Messbereiche parallel einstellbar
    • Auflösung 13 Bit
    • Analogteil potenzialfrei gegenüber CPU
    • maximal zulässige Gleichtaktspannung zwischen den Kanälen bzw. zwischen den Bezugspotenzialen der angeschlossenen Geber und MANA AC 30 V


    Also wie hast du den PT100 angeschlossen?
    Laut Handbuch kann man einen PT100 nicht direkt anschliessen.

    Martin

  10. #10
    Registriert seit
    10.05.2005
    Beiträge
    1.996
    Danke
    219
    Erhielt 232 Danke für 204 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hi Martin

    Also wie hast du den PT100 angeschlossen?
    Laut Handbuch kann man einen PT100 nicht direkt anschliessen.
    Warum nicht ?

    PT100 --> 100 Ohm

    Widerstandsmessung bis 500 Ohm.


    Siehe Handbuch 5-79.
    https://a248.e.akamai.net/cache.auto...B/425rfh_d.pdf


    Oder habe ich da einen Denkfehler

    +
    +
    Geändert von gravieren (10.01.2007 um 19:59 Uhr)
    Karl

Ähnliche Themen

  1. CPU DB-Nummer zu hoch
    Von simon.s im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 13.04.2011, 22:04
  2. SCL Lokaldatenbedarf zu hoch!
    Von hoT im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 19.03.2010, 09:17
  3. Hoch bzw. runterzählen
    Von PG675 im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 25.11.2009, 11:19
  4. 2 hoch 2/3
    Von marcelmoonwalker im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 16.11.2009, 14:44
  5. Hoch der 1. Mai
    Von riesermauf im Forum Stammtisch
    Antworten: 13
    Letzter Beitrag: 02.05.2008, 07:32

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •