Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 17 von 17

Thema: Usb Op 7

  1. #11
    Registriert seit
    19.07.2006
    Beiträge
    397
    Danke
    127
    Erhielt 40 Danke für 32 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Möglicherweise mal mit einer niedrigeren Baudrate versuchen ?

    Hate da mal Probleme mit einem OP17 das seltsamerweise nur mit 9600baud ging.....

  2. #12
    Registriert seit
    22.09.2006
    Ort
    Bodenseeraum
    Beiträge
    1.022
    Danke
    61
    Erhielt 136 Danke für 122 Beiträge

    Idee

    Hi,
    ich verwende schon lange ein billiges USBtoSeriall Adapter(wie UG). Sobald
    der auf virtuell "COM1" oder "COM2" richtig eingestellt ist und funktioniert
    (mann kann es testen mit zwei PCs und HyperTerminal), gibt es kein
    Problem mit Laden von OPs, habe zig mal gemacht. Klar, wenn das OP
    auf 9600 umgestellt ist, und du versuchts mi7 19200... .
    Drei Drähte reichen, die Belegung gibt es im Handbuch Siemens.
    Sonst alle Baudraten durchtesten halt..

    Gruss: V.
    ______________________________________
    relax, take it easy
    Zitieren Zitieren OPs und USB  

  3. #13
    Registriert seit
    22.11.2006
    Ort
    CH
    Beiträge
    3.618
    Danke
    775
    Erhielt 646 Danke für 492 Beiträge

    Standard

    Zitat Zitat von Unregistrierter gast Beitrag anzeigen
    Solange man diese auf COM1 oder COM2 einstellen kann, hab ich noch keine Probleme damit gehabt.
    Und ich hab so ein billiges 19 Euro - Teil.
    Du glücklicher. Ich hab vier stück solche Adapter von verschiedenen Herstellern.
    Einer funktioniert.
    Mein neues Notebook hat zum glück wieder RS232.
    Komischerweise komm ich damit über die RS232 Schnittstelle nicht auf die alten SC35 rechner. Und auch mit PDP11 hab ich probleme.


    mfG René

  4. #14
    Registriert seit
    22.09.2006
    Ort
    Bodenseeraum
    Beiträge
    1.022
    Danke
    61
    Erhielt 136 Danke für 122 Beiträge

    Beitrag

    Hi,
    ja, denn manche Hersteller von Laptops "mit RS232" SS bauen da kein
    UART rein, sondern ein "internes" USB to Seriell Billigteil. Falls da
    ältere Anwendungen versuchen, das Teil als BIOS UART zu erreichen
    (über BIOS Portbefehle), geht das in die Hose. Da muss man schauen,
    ob im Laptom UART drin ist, und dann die BIOS Settings evtl.
    Ich habe eine sehr teuere 2 fache PCMCIA Karte mit UARTs, und die
    alten Programme können normalerweise nichts damit anfangen. Die suchen
    halt ein richtiges UART auf dem Mainboard.

    Gruss: V.
    ______________________________________
    relax, take it easy
    Zitieren Zitieren Rs232  

  5. #15
    Registriert seit
    02.06.2005
    Beiträge
    300
    Danke
    23
    Erhielt 6 Danke für 6 Beiträge

    Standard

    Hallo
    Wenn dein Kabel seitlich DIP Schalter hat. Ich habe die Nummer nicht im Kopf. Muß Dip 5 umgestellt werden auf "Free" Kommunkation. Mit dem USB Adapter sollte es klappen.
    sonnige Grüße Wilhelm

  6. #16
    Registriert seit
    20.11.2004
    Ort
    Linz, OÖ
    Beiträge
    1.365
    Danke
    96
    Erhielt 177 Danke für 133 Beiträge

    Standard

    .
    Zitat Zitat von Betriebselektriker28 Beitrag anzeigen
    Möglicherweise mal mit einer niedrigeren Baudrate versuchen ?

    Hate da mal Probleme mit einem OP17 das seltsamerweise nur mit 9600baud ging.....
    Hatte vorletzte Woche dasselbe Problem bei einem OP17 Bj. 98 und einem USB/seriell-Umsetzer. Zuverlässiges Transferverhalten hab ich erst erreicht, als ich die Baudrate auf 9600 Kbit/s eingestellt und das OP vom MPI-Bus getrennt hab.

    Mit höheren Baudraten ist der Transfer immer abgebrochen - bei 9600 teilweise auch noch. Interessanterweise funktionierte der Verbindungsaufbau nicht immer - hab das OP übers Systemmenü auf Tranfer-Modus geschaltet - der Verbindungsuafbau klappte zum Teil erst beim 2. oder 3. Versuch.

    Welche Baudrate man am PC für den Tranfer wählt, ist übrigens egal - das OP erkennt die Baudrate automatisch. Die zulässigen Baudraten werden von ProTool vorgeschlagen.


    Ach ja:
    Das OP muss vorher natürlich in den Modus "Transfer" geschaltet werden. Am einfachsten erreicht man das durch ein Urlöschen des OP (Pfeiltaste nach unten, Pfeiltaste nach rechts & ESC-Taste gleichzeitig gedrückt halten bei POWER-ON).


    mfg
    Maxl
    Geändert von Maxl (28.01.2007 um 22:07 Uhr)
    Bin aufgrund §2 der "Rechte des Betreibers" der Forum-Regeln nicht mehr aktiv, da nicht nicht akzeptiere, dass Informationen und Erkenntnisse ohne Quellangabe weitergegeben werden sollen. Jedem steht frei, auf die gleichen Erkenntnisse durch Eigenversuche zu kommen, vor allem Buchautoren.

  7. #17
    Registriert seit
    22.11.2006
    Ort
    CH
    Beiträge
    3.618
    Danke
    775
    Erhielt 646 Danke für 492 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Maxl Beitrag anzeigen
    . Das OP muss vorher natürlich in den Modus "Transfer" geschaltet werden. Am einfachsten erreicht man das durch ein Urlöschen des OP (Pfeiltaste nach unten, Pfeiltaste nach rechts & ESC-Taste gleichzeitig gedrückt halten bei POWER-ON).

    Dann sollte die Verbindung aber auch so stabil sein um auch umfangreichere Programme zu übertragen.
    Das kann ja dann gut und gerne 15 Minuten dauern.

    mfG René

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •