Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 14

Thema: Analogwert in nicht gleich Analogwert aus ?

  1. #1
    Registriert seit
    08.02.2006
    Beiträge
    13
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo ich hab mal eine Frage an euch

    Ich habe eine CPU 313C mit 4 analogen Eingängen und 2 analogen Ausgängen
    on Board.

    Aus 3 analogen Eingängen 4 - 20 mA bilde ich einen Mittelwert
    ( AW1 + AW2 + AW3 : 3 ) und gebe ihn wieder als Analogwert aus.
    Soweit auch kein Problem. Seltsamerweise stimmen die Werte
    nicht exakt überein. D.h. eingelesene Werte z.B. von 3 x 6mA ergeben
    an dem Analogausgang 6,1 mA. An den mA-Gebern und dem Messgerät
    liegt es nicht, die hab ich gegeneinander getestet. Die Werte der Analogeingänge
    und des Analogausgangs in der Online-Darstellung sind auch exakt gleich.
    Dennoch bleibt da eine kleine Anweichung ( 0,1 mA).
    Ich habe so was schon mal mit ner VIPA gemacht da war diese Abweichung
    nicht.

    Hat jemand eine Idee ????

    Gruß
    Peter
    Zitieren Zitieren Analogwert in nicht gleich Analogwert aus ?  

  2. #2
    Registriert seit
    07.03.2004
    Beiträge
    4.369
    Danke
    946
    Erhielt 1.158 Danke für 831 Beiträge

    Standard

    Zitat Zitat von Dilbert Beitrag anzeigen
    Hallo ich hab mal eine Frage an euch

    Ich habe eine CPU 313C mit 4 analogen Eingängen und 2 analogen Ausgängen
    on Board.

    Aus 3 analogen Eingängen 4 - 20 mA bilde ich einen Mittelwert
    ( AW1 + AW2 + AW3 : 3 ) und gebe ihn wieder als Analogwert aus.
    Soweit auch kein Problem. Seltsamerweise stimmen die Werte
    nicht exakt überein. D.h. eingelesene Werte z.B. von 3 x 6mA ergeben
    an dem Analogausgang 6,1 mA. An den mA-Gebern und dem Messgerät
    liegt es nicht, die hab ich gegeneinander getestet. Die Werte der Analogeingänge
    und des Analogausgangs in der Online-Darstellung sind auch exakt gleich.
    Dennoch bleibt da eine kleine Anweichung ( 0,1 mA).
    Ich habe so was schon mal mit ner VIPA gemacht da war diese Abweichung
    nicht.

    Hat jemand eine Idee ????

    Gruß
    Peter
    1. Das "( AW1 + AW2 + AW3 : 3 )" soll wohl eher ( AW1 + AW2 + AW3) / 3 )) lauten.

    2. Also auch eine Ausgangskarte hat eine Genauigkeitsklasse vielleicht ist das noch innerhalb der Spezifikation?

    3. Wie sind den die Werte innerhalb der SPS?

    If you open your Mind too much, your Brain will fall out.

  3. #3
    Registriert seit
    16.06.2003
    Ort
    88356 Ostrach
    Beiträge
    4.811
    Danke
    1.231
    Erhielt 1.101 Danke für 527 Beiträge

    Standard

    zeig mal den code.

    wie werden die werte normiert?
    hast du in der sps im status bei allen normierten werten 6mA stehen?
    rechnest direkt mit den werten der analgkanäle (0-2764 oder normierst du in der sps und rechnest mit diesen werten?
    mit welchen formaten rechnest du?

    nur weil deine messgeräte hinter und vor deiner sps irgendwas anzeigen, muss das noch lange nicht heissen das der analogeingang das selbe misst bzw. der normierungsfaktor genau das ergebniss bringt...
    "Es ist weit besser, große Dinge zu wagen, ruhmreiche Triumphe zu erringen, auch wenn es manchmal bedeutet, Niederlagen einzustecken, als sich zu den Krämerseelen zu gesellen, die weder große Freude noch großen Schmerz empfinden, weil sie im grauen Zwielicht leben, das weder Sieg noch Niederlage kennt." Theodore Roosevelt - President of the United States (1901-1909)

  4. #4
    Registriert seit
    20.10.2004
    Beiträge
    650
    Danke
    5
    Erhielt 26 Danke für 26 Beiträge

    Standard

    mal eine frage
    hat die 313c nicht einen 8 bit wandler bei ihren ein und ausgangskarten
    dann ist der fehler doch mininmal

  5. #5
    Dilbert ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    08.02.2006
    Beiträge
    13
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Danke erst mal für die Antworten.

    Also ich normiere nicht und rechne einfach mit 0 – 27648


    Die Integer-Werte in der Online – Darstellung sind alle OK

    Wenn also der Analogwert aller drei Eingänge jeweils 10 000 Integer ist
    ( mit mA Geber eingestellt ) steht dieser Wert auch für´s PAW in der
    Online – Darstellung zur Verfügung.

    Ich rechne aber mit Doppelinteger, weil ja eine Adition von 3 x 20mA
    locker einen Überlauf erzeugen würde.

    Ich muß mal schauen was diese CPU für ne Analogkarte On-Boad hat.

    Gruß

    Peter

  6. #6
    Registriert seit
    22.11.2006
    Beiträge
    186
    Danke
    2
    Erhielt 12 Danke für 12 Beiträge

    Standard

    rechne nicht mit Integer sondern mit Real, und die rechnung müsste dann genauer sein.
    BSP INT:
    9:4=2

    BSP REAL
    9:4=2,25
    Ciao

    Antonio
    ________________________________
    nicht in Problemen, sondern in Lösungen denken

  7. #7
    Registriert seit
    29.01.2007
    Ort
    Pfalz
    Beiträge
    71
    Danke
    4
    Erhielt 15 Danke für 8 Beiträge

    Standard

    Es ist sicherlich richtig, dass wenn er mit Real rechnet, die Rechnung genauer wird.
    Nur, was passiert wenn er mit Integer rechnet und die Ungenauigkeit durch Kommastellen entstehen. Die werden dann halt "weggeschnitten"

    Es dürfte also nie ein größerer Wert rauskommen, sonderen eher ein kleinerer.

    Bei der geringen Abweichung von 0,1mA, denke ich dass das einfach nur Messfehler sind.
    Jedes Bauteil hat Toleranzen. Sowohl die Analogkarten, als auch die Messgeräte. Ich kann mir nicht vorstellen, dass es gelingt am Eingang 100% 6mA einzustellen.
    Mit was sollte das gemessen werden?
    Wenn da nun 6.04mA anliegen, so genügt die kleinste Abweichung und am Ausgang liegt 6,05mA an. Das wird dann vieleicht aufgerundet und schwupps sind es 6,1mA.
    Selbst ein Messgerät mit 0,5% Toleranz hat immerhin noch einen Fehler von 0,03mA + was weis ich wieviele Digits.

  8. #8
    Registriert seit
    07.05.2004
    Ort
    Campbelltown
    Beiträge
    2.437
    Danke
    131
    Erhielt 276 Danke für 86 Beiträge

    Standard

    Die Eingänge, sind die auf 4-20mA eingestellt in der Hardware?

    Oder ist 4mA = 55xx digits?
    Gegen Schwachsinn, Schwachköpfe und armselige Trittbrettfahrer kann man nicht argumentieren.

    Gott sieht alles, auch Signaturen in Geheimschrift,,... aber er petzt nicht.

  9. #9
    Registriert seit
    16.06.2003
    Ort
    88356 Ostrach
    Beiträge
    4.811
    Danke
    1.231
    Erhielt 1.101 Danke für 527 Beiträge

    Standard

    Zitat Zitat von plc_tippser Beitrag anzeigen
    Die Eingänge, sind die auf 4-20mA eingestellt in der Hardware?

    Oder ist 4mA = 55xx digits?

    dachte ich auch schon, aber 4mA bei 6mA, da sollte die Abweichung doch wesentlich mehr als 0,1mA sein?
    "Es ist weit besser, große Dinge zu wagen, ruhmreiche Triumphe zu erringen, auch wenn es manchmal bedeutet, Niederlagen einzustecken, als sich zu den Krämerseelen zu gesellen, die weder große Freude noch großen Schmerz empfinden, weil sie im grauen Zwielicht leben, das weder Sieg noch Niederlage kennt." Theodore Roosevelt - President of the United States (1901-1909)

  10. #10
    Registriert seit
    07.05.2004
    Ort
    Campbelltown
    Beiträge
    2.437
    Danke
    131
    Erhielt 276 Danke für 86 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Habe nur wegen der Auflösung gefragt.

    Fakt ist, 11Bit Auflösung, Ein sowie Aus.

    Also 2048 Schritte. Entspricht einer Auflösung von ca. 0,01mA bei 0-20mA

    Mich würden die Werte im Online interessieren und die Parametrieung.

    pt
    Gegen Schwachsinn, Schwachköpfe und armselige Trittbrettfahrer kann man nicht argumentieren.

    Gott sieht alles, auch Signaturen in Geheimschrift,,... aber er petzt nicht.

Ähnliche Themen

  1. Ist der Analogwert wieder nicht plausibel?
    Von Paule im Forum Suche - Biete
    Antworten: 10
    Letzter Beitrag: 22.07.2010, 07:56
  2. Analogwert
    Von Andy_speedy im Forum Simatic
    Antworten: 21
    Letzter Beitrag: 06.05.2008, 18:14
  3. Analogwert nicht-linear zuordnen
    Von Nico99 im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 09.08.2007, 14:40
  4. Analogwert
    Von Hobbyler im Forum Sonstige Steuerungen
    Antworten: 2
    Letzter Beitrag: 10.10.2006, 11:30
  5. Analogwert mit S7
    Von tonka im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 05.03.2004, 15:29

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •