Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 3 123 LetzteLetzte
Ergebnis 1 bis 10 von 21

Thema: SPS S5 Adressierung

  1. #1
    Registriert seit
    07.04.2007
    Beiträge
    223
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo!!!

    habe folgendes Problem.
    habe in meiner e-lehre auf einer S7 programmiert aber die ist mir zu teuer und da hab ich mir eine s5 gekauft.
    nun bei den eingangsbauteilen gibts unten dran so ein weises rädchen zum verstellen von 0-7 glaub ich.und meins ist auf 4 eingestellt.wie bringe ich das ins programm bei S5W rein?muss ich da zb. bei einen eingang schreiben E4.1 oder E4.2???

    und wie ist das bei den ausgängen?da gehts ja von a-f oder so.


    dann hab ich noch ein kleines problem mit dem programm S5W. wenn ich das auf mache und ein neues projekt anlege und auf neu geh und zb. ein OB einfügen will dann bringt der mir folgende fehlermeldung "die bausteinnummer von OB ist ungültig oder nicht vorhanden" an was kann das liegen?
    aber wenn ich zb ein beispielprojekt öffne und da den ob1 kopiere und den in ein neues projekt einfüge geht das.
    Zitieren Zitieren SPS S5 Adressierung  

  2. #2
    Registriert seit
    12.12.2006
    Ort
    Wehringen
    Beiträge
    1.471
    Danke
    248
    Erhielt 190 Danke für 155 Beiträge

    Standard

    Hallo,

    das weiße Rädchen ist nur eine reine Hardware-Codierung der Karte, damit man an den Steckplatz nix anderes Stecken kann (wenn man sich nicht auskennt).
    Untersuche das doch mal vorsichtig mit einem Schraubendreher , dann wirst du sehen, daß da nur Plastik ist und nix elektrisches.
    Das Dink kannst du auch genausogut wegpopeln.

    Welche S5 ist es denn?

    MfG

  3. #3
    Krma1985 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    07.04.2007
    Beiträge
    223
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    hallo!!!

    ach so ist das. ist eine CPU100U.in einen anderen forum wurde mir nämlich gesagt das ich mit diesen rädchen also die eingestellte zahl in die programmierung einbeziehen muss.deshalb hab ich mich gewundert.

    also verstellen kann man das rädchen nur vom bauteil und nicht am Busmodul zumindest siehts so aus als ob man es verstellen könnte aber ich wills nicht kaputt machen deshalb lass ich es ganz einfach.

    und wegen dem programm da eine idee???
    Zitieren Zitieren SPS S% Adressierung  

  4. #4
    Registriert seit
    30.04.2005
    Beiträge
    908
    Danke
    58
    Erhielt 161 Danke für 147 Beiträge

    Standard

    Hi,

    die 100U ist rein Steckplatzadressiert.
    Die 1. BG ist Byte0 bei Digitalkarten und Byte 64 bei Analogkarten.
    Die 2. BG ist dann Byte 1 bei Digitalkarten und Byte 72 (4xAnalogwert a 1 Wort) bei den Analogkarten.

    Du kannst an den Adressen auch nichts ändern.
    Damit du die CPU in RUN bekommst muss min. ein Peripheriesockel gesteckt sein.

    Gruß Centi
    Krieg ist Gottes Art den Amerikanern Geographie beizubringen

  5. #5
    Krma1985 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    07.04.2007
    Beiträge
    223
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    das mit dem byte versteh ich jetzt nicht richtig.

    also mal ein beispiel.
    ich habe
    2 digital input
    1 digital output
    1 analog output

    wenn ich zb vom ersten input den eingang 0 und 1 auf ein habe soll digital output ausgang 0 ein sein.

    wie sieht das dann im programm S5W aus?da gibts ja glaube andere eingangsbezeichnungen also nicht 0. sondern 32. oder?
    bei der s7 kenn ich es ja so

    ..............-------
    ............../ ...& .../
    E0.0-----/ ........./
    ............../ ......../ .......--------
    E0.1-----/ ......../----/..A0.0. /
    ............./ ......../ .......--------
    .............-------

    das mit der darstellung hat net richtig gelappt aber man kanns erkennen.soll ein und-baustein sein mit 2 eingängen
    Zitieren Zitieren SPS S5 Adressierung  

  6. #6
    Registriert seit
    22.11.2006
    Ort
    Landkreis Freudenstadt
    Beiträge
    168
    Danke
    25
    Erhielt 10 Danke für 10 Beiträge

    Standard

    Hallo Krma1985
    Verstehe nicht ganz was du meinst. Die Eingangsbezeichnung z.B. E0.0 ist doch durch die Baugruppe vorgegeben und muss so auch Softwaremässig angesprochen werden (egal ob S5W oder Step5, usw.) Wieso sollte der Eingang in der Software eine andere Bezeichnung haben. Wie kommst du da drauf?

    Gruss
    Geändert von Zimbo30 (07.04.2007 um 13:00 Uhr)

  7. #7
    Krma1985 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    07.04.2007
    Beiträge
    223
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    das mit dem E0.0 war ja nur ein beispiel wies bei der s7 gemacht wird.aber bei der s5 ist das doch anders.deshalb versteh ich es ja nicht bei der eingangsbezeichnung.

    also nochmal zum verständnis.

    habe meine cpu daran sind 2 busmodule angeschlossen
    auf dem ersten busmodul steckplatz 1 ist eine zahl 2 geschrieben da stecke ich mein digital input drauf auf dem 2. steckplatz steht eine 3 drauf und da steck ich mein digital output drauf.

    also schreib ich jetzt in mein programm was ich dann in die cpu spiele.

    E2.0 UND E2.1 istgleich A3.0

    also wenn ich dann den .0 und .1 mit 24V versorge müsste dann der ausgang angehen oder lieg ich da falsch?

    kann ich auch das programm öffnen meine s5 ranhängen über das verbindungskabel dann irgend ein eingang auf 24v setzen. kann ich das dann im programm sehen welcher eingang gerade ein oder aus ist oder geht das nicht?
    Zitieren Zitieren SPS S5 Adressierung  

  8. #8
    Registriert seit
    22.11.2006
    Ort
    Landkreis Freudenstadt
    Beiträge
    168
    Danke
    25
    Erhielt 10 Danke für 10 Beiträge

    Standard

    Steckplatz 1 Eingangskarte wäre dann E0.0 - E0.7
    Steckplatz 2 Ausgangskarte wäre dann A1.0-A1.7
    Vorraussetzung ist natürlich auch das die Karten entsprechend mit Spannung versorgst.

    Du kannst das Programm im Status auch das Programm online anschauen und Setzen von Eingängen simulieren

  9. #9
    Krma1985 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    07.04.2007
    Beiträge
    223
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    also das mit dem eingängen klappt soweit.habs versucht und es ging.
    aber wenn ich es auf die cpu spiele und auf run stelle springt der manchmal automatisch wieder auf stop also heißt das ja das da irgend ein fehler drauf ist aber kann den nicht finden oder an was liegt das noch?wenn ich die pufferbatterie und den eprom rausnehme und das neu auf die cpu spiele gehts manchmal.
    für was ist das eprom eigentlich so richtig?

    wenn wir gleich dabei sind.hab im inet gesucht nach einem handbuch für die cpu100u aber leider nix gefunden.habt ihr ne idee wo ich sowas finde?

    mit dem simulieren klappt auch im programm soweit
    Zitieren Zitieren SPS S5 Adressierung  

  10. #10
    Registriert seit
    28.10.2005
    Ort
    Ottweiler, Saar
    Beiträge
    940
    Danke
    259
    Erhielt 124 Danke für 109 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Krma1985 Beitrag anzeigen
    hab im inet gesucht nach einem handbuch für die cpu100u aber leider nix gefunden.habt ihr ne idee wo ich sowas finde?
    Schau mal in die FAQ des Forums. Dort gibts einen Link auf die Supportseite
    von Siemens. Da gibts auch das Handbuch zur 100U.
    Zitieren Zitieren Handbuch 100U  

Ähnliche Themen

  1. Adressierung?
    Von McNugget im Forum CODESYS und IEC61131
    Antworten: 12
    Letzter Beitrag: 13.10.2009, 10:22
  2. Adressierung
    Von bubu im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 11.11.2008, 18:37
  3. MPI-Adressierung
    Von Reto im Forum Simatic
    Antworten: 16
    Letzter Beitrag: 16.02.2007, 15:40
  4. adressierung
    Von lister67 im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 27.12.2006, 17:16
  5. S7 200 ASI-Bus Adressierung
    Von Friedrich-Alexander im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 26.09.2006, 14:58

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •