Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 11

Thema: PZD-Haupt/Sollwert Micromaster

  1. #1
    Registriert seit
    14.02.2006
    Beiträge
    61
    Danke
    21
    Erhielt 4 Danke für 3 Beiträge

    Unglücklich


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    habe da ein Problem mit dem MM420!
    Gegeben CPU 315DP als Master
    MM420 mit DP Modul

    soweit kann ich den MM420 über das PZD ansteuern aber nur stimmt es nicht mit der Vorgabeliste von Siemens überein- habe mich ein wenig mit den Parametern gespielt usw... konnte mich auch mit dem Starter über die CPU (Profibus) mit dem MM420 verbinden und den MM bedienen. Aber seit kurzem komme ich mit dem Starter nicht mehr auf den MM420??? Verbindungsfehler, bei den Einstellungen im Programm und DP wurde nichts geändert!
    Habe auch schon des öfteren den MM420 auf Werkseinstelung zurückgesetzt - aber??? Keine Ahnung, mit dem Starter komme ich nicht mehr drauf weil da könnte man das Steuerwort ansehen usw... leider

    im pdf Anhang ist mein Programm mit allem was ich eingestellt habe usw...

    ist da das Bitmuster falsch???
    habe mich an die Vorgaben von Siemens gehalten ... aber wie es aussieht habe ich irgendetwas übsehen oder... mal schauen

    Zusatz
    =====

    4. Steuerung des MICROMASTER mit der PLC
    Wenn PP03 gewählt wirde, haben Sie 2 Ausgabewörter (PZD1 und PZD2) von der PLC, die dem MICROMASTER Steuerwort und Frequenz-Sollwert entsprechen, und 2 Eingabewörter, nämlich das MICROMASTER Statuswort und die Ist-Frequenz.
    Wenn Sie PP01 wählen, beziehen sich die ersten 4 Eingabe- und Ausgabewörter auf Parameter Lesen/Schreiben-Daten (PKW Daten). Die PKW Ausgabewörter können jetzt auf Null gesetzt werden.
    Frequenz-Sollwert und Ist-Wert werden so normalisiert, dass 4000hex 50Hz entspricht. Der Höchstwert, der gesendet werden sollte, ist 7FFF.
    Die Normalisierungsfrequenz kann in P2000 geändert werden.
    Es folgen einige typische Steuer- und Statuswörter. Die Statuswörter setzen voraus, dass der Steuerwort, Frequenz-Sollwert angestiegen ist (wo zutreffend). Die Datensequenz ist Steuerwort, Frequenz-Sollwert, Statuswort, Ist-Frequenz.
    Gestartet wird der Antrieb durch Senden von Steuerwort 047E, gefolgt von 047F (Flanke des Bit 0: EIN)

    Antrieb fertig zum Vorwärtslauf:
    047E 0000 FA31 0000

    Antrieb bei 12.5Hz vorwärts laufen lassen:
    047F 1000 FB34 1000

    Antrieb bei 50Hz vorwärts laufen lassen:
    047F 4000 FB34 4000

    Antrieb bei 12.5Hz rückwärts laufen lassen:
    0C7F 1000 BB34 1000

    Antrieb bei Fehler abgeschaltet:
    0C7F 1000 FA38 0000

    Fehler zurücksetzen:
    04FE 0000 FA31 0000

    Das selbe Bitmuster wenn ich die Bits in der Variablentabelle setzt!!!
    Aber wie es aussieht müssen die Befehle (Steuerwort) in HEX gesendet werden, das kein Fehler Auftritt.
    Den bei Fehlerquittierung 04FE geht der Antrieb wieder in Bereitschaft und zeigt die gesendet Sollfrequenz an. Sobald ich das Steuerwortformat 047F schicke dreht sich der Antrieb.


    Die Struktur der Steuer- und Statuswörter ist im Abschnitt 3.3 des PROFIBUS-Handbuchs beschrieben ==>>> das sind die PDF.Files Steuerwort/Zustandword
    Geändert von taucherd (13.03.2008 um 15:24 Uhr)
    Zitieren Zitieren PZD-Haupt/Sollwert Micromaster  

  2. #2
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.726
    Danke
    398
    Erhielt 2.401 Danke für 2.001 Beiträge

    Standard

    Hallo,
    so wie du das Problem beschreibst, hört es sich für mich an, als wenn dein Umrichter nicht mehr über den PB zu erreichen ist. Hierfür sind am Umrichter die Parameter 0918 (PB-Adresse), P1000 (Sollwertquelle) - 6 (?), 0927 (wer darf Parameter ändern) zuständig.
    Nach dem Rückstellen des Reglers hast du diese Parameter bestimmt wieder zurück-gesetzt ...

  3. #3
    Registriert seit
    14.02.2006
    Beiträge
    61
    Danke
    21
    Erhielt 4 Danke für 3 Beiträge

    Standard

    Hallo Larrry, das stimmt nicht ich kann den Umrichter schon über die PLC ansprechen und auch fahren - Frequenz verändern, Drehrichtung alles. Aber beim Steuerwort und Zustandswort stimmen die Bits nicht!!!

    DP Adresse habe ich beim Profibusmodul mit den Tippschaltern fix eingestellt - Teilnehmer 10.
    Die Parameter, damit ich die Steuerhoheit über die PLC habe wurden wieder eingestellt (P1000=6 und P700=6)

    Nur mit dem Starter komme ich nicht mehr drauf -> Verbindungsfehler (steuerhoheit PC geht net mehr, der MM420 hat aber keine RUN Befehl)

    Siehe Zusatz, habe ich gerade von der Siemensseite.
    Geändert von taucherd (25.04.2007 um 10:47 Uhr)

  4. #4
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.726
    Danke
    398
    Erhielt 2.401 Danke für 2.001 Beiträge

    Standard

    Hallo,
    leider komme ich erst jetzt wieder dazu, zu antworten ...

    Ich hatte bislang nie Schwierigkeiten mit Starter an einen Regler zu kommen, es sei denn er war von anderer Seite beschäftigt = kann es vielleicht sein, dass deine SPS ihn über die Schnittstelle ständig mit neuen (alten) Daten versorgt und das deshalb die Schnittstelle keine Zeit mehr für Starter hat ?

    Ach ja - Vorraussetzung war natürlich immer, dass im Regler der Fernsteuerweg freigegeben war - aber das ist ja bei dir auf jeden Fall OK ...

  5. Folgender Benutzer sagt Danke zu Larry Laffer für den nützlichen Beitrag:

    taucherd (26.04.2007)

  6. #5
    Registriert seit
    14.02.2006
    Beiträge
    61
    Danke
    21
    Erhielt 4 Danke für 3 Beiträge

    Standard

    hallo,

    auch wenn ich sie plc urlösche und ohne flashkarte betreibe und nur die hardware lade, sodass ich über die plc den mm ansprechen kann funktuioiniert es nicht mehr? was soll's fahr mit dem motor eh über die plc!!!

    aber trotzdem verstehe ich noch immer nicht, weiso die bitsetzung nicht mit der liste von siemens übereinstimmt. werde da siemens mal ein mail schreiben.

  7. #6
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.726
    Danke
    398
    Erhielt 2.401 Danke für 2.001 Beiträge

    Standard

    Hallo,
    ich habe dir mal ein Beispiel mit 'reingepackt.
    Ich habe die Steuer-Bits /-Worte in den DB50 hinterlegt ab DBB62. In dem Projekt gibt es 2 Umrichter. Das sollte dich aber nicht stören. Den 1. Umrichter habe ich auf dem Perepherie-Bereich 284 - 287. Das findest du im FC202 dann auch wieder. Erst lade ich die PEW's in den DB. Dann kommen Zuweisungen und schließlich übertrage ich die Steuerworte mit dem SFC15 zurück. Das Schreiben auf PAW's (siehe letztes Netzwerk) hatte nicht korrekt funktioniert. Deshalb das BEA ...

    Das Beispiel ist bestimmt nicht eins meiner elegantesten Prg-Teile, aber ich glaube, das was du suchst kannst du darin sehen ...

    Gruß und viel Erfolg ...

  8. Folgender Benutzer sagt Danke zu Larry Laffer für den nützlichen Beitrag:

    taucherd (05.05.2007)

  9. #7
    Registriert seit
    14.02.2006
    Beiträge
    61
    Danke
    21
    Erhielt 4 Danke für 3 Beiträge

    Lächeln

    Habe es so nachbearbeitet wie du es hast!!! und jetzt stimmt auch der Bitzustand mit der Beschreibung überein. aber wieso wird zuerst das Byte 2 und dann das Byte 1 eingelsen - davon habe ich in der Beschreibung nichts gelesen?

    Ist das normal bei Siemens?!?! aber jetzt funktioniert es ohne Probleme!

  10. #8
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.726
    Danke
    398
    Erhielt 2.401 Danke für 2.001 Beiträge

    Standard

    Leider kann ich dir dazu keine hoch-professionelle Erklärung anbieten. Vielleicht ist "Das ist eben so bei Soemens" ganz gut. Es stammt noch aus der guten alten S5-Zeit gilt aber nicht für alle Datentypen.
    In der SPS-Hilfe (und bestimmt auch hier im Forum) gibt es bestimmt eine Anleitung dazu - ein warum kann ich dir aber leider nicht liefern ...

    In jedem Fall freue ich mich, das es jetzt funktioniert ...

  11. Folgender Benutzer sagt Danke zu Larry Laffer für den nützlichen Beitrag:

    taucherd (10.05.2007)

  12. #9
    Registriert seit
    08.11.2006
    Beiträge
    76
    Danke
    27
    Erhielt 0 Danke für 0 Beiträge

    Standard

    zu diesem Thema hätte ich noch eine Frage.

    Sollwert 4000hex = 50Hz
    Sollwert 1000hex = 12,5Hz

    Was für einen Hexwert muss man vorgeben um 5 Hz zu erreichen?
    Zitieren Zitieren Frage  

  13. #10
    Registriert seit
    20.06.2003
    Ort
    Sauerland.NRW.Deutschland
    Beiträge
    4.850
    Danke
    78
    Erhielt 800 Danke für 543 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    4000 hex = 16384 dez -> 50hz
    1000 hex = 4096 dez -> 12.5 hz

    Dreisatz solltest du doch wohl können

    baustein für einen mm4
    http://lischis-home.dyndns.org/php4/...i=MM4_stds.zip
    .
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download

    Meine Definition von TIA: Total Inakzeptable Applikation

Ähnliche Themen

  1. Kurve als Sollwert...
    Von AndreK im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 05.04.2010, 20:55
  2. Sollwert ermitteln
    Von M.R. im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 30.04.2009, 18:42
  3. Micromaster 440 gibt falschen Sollwert an Motor aus
    Von extra im Forum Antriebstechnik
    Antworten: 8
    Letzter Beitrag: 15.09.2008, 20:09
  4. OP7-Sollwert ==> SFB41
    Von Andi_W im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 26.04.2008, 15:10
  5. FM 350 Sollwert/Istwertvergleich
    Von Martin L. im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 11.07.2007, 08:40

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •