Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Results 1 to 9 of 9

Thread: Analogeingabe / Widerstandsauswertung

  1. #1
    Join Date
    25.05.2004
    Posts
    194
    Danke
    0
    Erhielt 46 Danke für 7 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo gemeinsam,

    ich werte mit SM 331 Karten Widerstandsrückmeldungen von verschiedenen Stellantrieben aus. Diejenigen Antriebe, die hierzu mit Leitplastikpotis ausgestattet sind, machen hierbei Ärger. Während des verfahrens, und ca. 2-3 Sekunden nach Stop ist der gemessene Widerstandswert um ca 10-20 % zu hoch, anschließend pendelt er sich wieder auf den richtigen Wert ein. Der Hersteller der Antriebe meint hierzu lapidar, der Wert ließe sich halt so nicht sauber messen.
    Welche Erfahrung habt Ihr. Zur Lösung böten sich hier zwei Möglichkeiten an:
    - Tausch der Potis (dann funktionierts, der Gewährleistungsanspruch gegen den Hersteller der Antriebe ist aber im Eimer)
    - Messung ändern (Potienden mit 1VDC beschalten, am Schleifer Hochohmig messen), da ist der Aufwand doch recht hoch.

    Welche Erfahrung habt Ihr? / Schon mal sowas gehört?

    Gruß

    Ralf
    Reply With Quote Reply With Quote Analogeingabe / Widerstandsauswertung  

  2. #2
    Join Date
    19.06.2003
    Posts
    2,299
    Danke
    85
    Erhielt 274 Danke für 179 Beiträge

    Default

    Quote Originally Posted by Ralf
    Hallo gemeinsam,

    - Tausch der Potis (dann funktionierts, der Gewährleistungsanspruch gegen den Hersteller der Antriebe ist aber im Eimer)
    Ist das so (ausprobiert) ?
    Was ist an den amderen Potis anders/besser?
    Wenn andere Potis besser sind, verlange, daß der Hersteller sie einbaut.
    Quote Originally Posted by Ralf
    - Messung ändern (Potienden mit 1VDC beschalten, am Schleifer Hochohmig messen), da ist der Aufwand doch recht hoch.
    Alle Potis parallel schalten, ca 1V (oder was zum Eingang passt) durch passenden Vorwiderstand einstellen, die unstabilisierten 1V auf einen zusätzlichen Eingang führen, Spannungen an den Schleifern durch Wert der Versorgung teilen.

    Wie sind die Potis angekuppelt? Ist Spiel drin? Ist irgenetwas elastisch, so dass das Poti zunächst nur einen Teil des Weges mitläuft und dann z.B. durch Vibration das letzte Stück Weg zurücklegt?
    Reply With Quote Reply With Quote Re: Analogeingabe / Widerstandsauswertung  

  3. #3
    Ralf is offline Erfahrener Benutzer
    Themenstarter
    Join Date
    25.05.2004
    Posts
    194
    Danke
    0
    Erhielt 46 Danke für 7 Beiträge

    Default

    Hi Zottel,
    Da´nke für die schnelle AW!
    Ist das so (ausprobiert)
    Ja, in der anlage sind zwei unterschiedliche Stellantriebe (Typ 1 für Gasklappen / Typ 2 für Luftklappen) verarbeitet. Beide vom gleichen Hersteller. Typ 1 ist (Herstellerseitig) mit Kohlefadenpotis augestattet, Typ 2 mit Leitplastikpotis.
    Typ 2 zeigt das beschriebene Verhalten, der Hersteller bestreitet das auch nicht, er ist der Meinung die Leitplastikpotis seien 'Stand der Technik' und kämen zum einsatz, da sie beständiger seien, man könne sie nur nicht mit Widerstandsmessung (Strom - spg) sondern ausschließlich hochomig Spannungsteiler auswerten.
    Bei Typ 1 funzt die Auswertung wunderbar.
    Ankopplung über Zahnrädchen (keine 1% Spiel) daran liegts nicht

    Gruß

    Ralf

    P.S. Schreibe gerade im Auftrag meines Bosses schon den Hersteller an

  4. #4
    Join Date
    19.06.2003
    Posts
    2,299
    Danke
    85
    Erhielt 274 Danke für 179 Beiträge

    Default

    Wie hoch sind denn bei deiner Widerstandsmessung Spannung und Strom? Auf welche Weise beeinflussen sie das Poti? Erwärmung?

  5. #5
    Ralf is offline Erfahrener Benutzer
    Themenstarter
    Join Date
    25.05.2004
    Posts
    194
    Danke
    0
    Erhielt 46 Danke für 7 Beiträge

    Default

    Die Karte gibt wohl (Siemens Hotline) jeweils kurze konstantspannungs- und Konstantstromimpulse ab. Zur Spg. / Stromstärke gebe ich jetzt die gleiche kluge Antwort, die mir auch der Siemens supporter gab
    Keine Ahnung (wie gesagt Zitat siemens 01805050222)
    Da das ganze gepulst Abläuft ist mit Multimeter und Co auch nichts zu reißen.
    Wir haben den Effekt auf der Visualisierung nachgezeichnet.
    z.B. Klappenstellung 30% Poti zeigt 300 Ohm (richtig)
    3 Sekunden Inpuls für Fahren auf 40% (Poti zeigt vom Fahrbeginn an ca. 500 Ohm (falsch sollte eigendlich in irgendeiner Kurve Richtung 400 Ohm laufen)
    Klappe stoppt - Poti zeigt weitere 2 Sekunden ca 500 Ohm an, und kruselt sich in den nächsten 3 Sekunden an die 400 Ohm (40% Klappe) an.

    Witzigerweise nur bei den Stellantrieben mit Leitplastikpoti (Luft), nicht aber bei denen mit Kohlefadenpoti....bin ein bischen ratlos ... und Sauer ... Fahre gleich nach Osnabrück, dem Hersteller aufs Maul hauen....ne doch nicht.

    Gruß

    Ralf

  6. #6
    Join Date
    29.01.2004
    Posts
    328
    Danke
    11
    Erhielt 23 Danke für 23 Beiträge

    Default

    Hallo Ralf
    Wenn man so im Internet stöbert sind Leitplastikpotis schon eine ultragenaue Sache. Deshalb denke ich, das die SM331 bzw die Spannungsversorgung für die Potis das Problem sind. Mein Vorschlag ist, die Potis mit einer eigenen Spannungsversorgung und ohne SM331 zu testen, um zu sehen ob das Problem die Potis sind, oder die SM331 mit ihrer gepulsten Spannung. Also einfach mal Kennlinie aufnehmen.
    Gruß

    Znarf

  7. #7
    Ralf is offline Erfahrener Benutzer
    Themenstarter
    Join Date
    25.05.2004
    Posts
    194
    Danke
    0
    Erhielt 46 Danke für 7 Beiträge

    Default

    Hi Znarf,

    mag alles ja sein, so ähnlich (und vermutlich auch richtig) argumentiert der Hersteller ja auch.

    Nur ...
    ... die blöden Potis lassen sich mit der Siemens Karte nict so einfach auslesen (wenn, dann nur mit Karte als hochohmige Spannungsmessung). Die Potis verkraften offebsichtlich den zur Messung ausgeschickten Strom icht. Muß ich jetzt da ein Hersteller meint besonderstolle Potis einzubauen, dies aber nicht dokumentiert, meine gesamte Anlage umstricken?

    Gruß

    Ralf

  8. #8
    Join Date
    29.01.2004
    Posts
    328
    Danke
    11
    Erhielt 23 Danke für 23 Beiträge

    Default

    Hi Ralf
    Die Anlage großartig umstricken ist sicherlich die allerletzte Möglichkeit.
    Mein Vorschlag sollte auch nur dazu dienen, die Fehlerquelle zu lokalisieren (Poti, SM331, das Zusammenspiel von beiden).
    Eine weitere Idee wäre die Potis als Zweidrahtmeßsystem an die Karte anzuschließen mit einer externen nicht gepulsten Spannungsversorgung.
    Welche SM331 nutzt du eigentlich und wie ist die Verschaltung?
    Sind die genannten Ohmwerte der Potis real (300, 400Ohm)?

    Ich schau nachher mal im Netz, vielleicht gibt es ja infos zum physikalischen Aufbau dieser Potis und deren verhalten.

    Znarf

    Ich kann dein Frust verstehen und bin bereit mit nach Osnabrück zu fahren

  9. #9
    Ralf is offline Erfahrener Benutzer
    Themenstarter
    Join Date
    25.05.2004
    Posts
    194
    Danke
    0
    Erhielt 46 Danke für 7 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Sind jetzt dabei andere Potis einzubauen (Fehlerursache sind eindeutig die Potis)
    Die Karte ist eine 1KF01-0AB0

    Versuche mich jetzt weiter mit dem Zulieferer zu einigen (geht ja doch um viel Geld)

    Drückt mir mal die Daumen

    Gruß

    Ralf

Similar Threads

  1. Potentiometer - Widerstandsauswertung
    By flobey311 in forum CODESYS und IEC61131
    Replies: 6
    Last Post: 22.03.2016, 17:06
  2. Biete 2x S7-1200, ANALOGEINGABE SM 1231 TC, 8 AI
    By Maj.Winters in forum Suche - Biete
    Replies: 3
    Last Post: 29.07.2014, 13:43
  3. [SUCHE] S7-200 Analogeingabe-Baugruppe
    By lordtalon in forum Suche - Biete
    Replies: 2
    Last Post: 26.06.2012, 14:41
  4. Analogeingabe Massefehler ?! .....
    By Shettyman in forum Simatic
    Replies: 2
    Last Post: 10.12.2009, 09:07
  5. Überlauf PT100 an Analogeingabe
    By Bernie in forum Simatic
    Replies: 9
    Last Post: 24.01.2007, 14:33

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •