Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: MPI Verb. PG - CPU

  1. #1
    Registriert seit
    23.10.2006
    Beiträge
    22
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen

    kann man über ein PG mit einem normalen seriellen Kabel Sub D eine
    Verbindung zu einer S7 CPU auf den MPI Steckplatz herstellen (ohne Adapter)?
    Muss ich hierfür die Adern 3 und 8 kreuzen?


    Grüße
    Zitieren Zitieren MPI Verb. PG - CPU  

  2. #2
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.726
    Danke
    314
    Erhielt 1.519 Danke für 1.282 Beiträge

    Standard

    Ein klares eindeutiges:

    N E I N


    Und wenn du noch länger was von deiner CPU haben willst solltest du das auch sein lassen.

    Siehe z.B. hier:
    http://www.sps-forum.de/showthread.php?t=13613
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  3. #3
    Registriert seit
    16.07.2004
    Beiträge
    42
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ein klares und eindeutiges: JA !
    weil das steht 'PG'
    kann man über ein PG mit einem normalen seriellen Kabel Sub D eine
    Normalerweise haben die Simatic-PG's eine eingebaute MPI Schnittstelle (in Form der MPI Karte im PC CP56xx) - an dieser MPI-Schnitstelle läßt sich sehrvohl die CPU per 'einfachem' seriellem Kabel mit 1:1 Belegung anschliessen. Eine Kreuzung von 'Bahn 3' und 'Bahn 8' ist da nicht notwendig. Jedenfalls läßt sich bei mir das Siemens MPI-Kabel durch normale 9-Ader-serielle Kabel ersetzen.

    Doch: Es muss sich definitiv um eine MPI-Schnittstelle am PG handeln, sonst gehen PC und CPU in den Himmel

  4. #4
    Registriert seit
    04.08.2006
    Ort
    Unterfranken
    Beiträge
    94
    Danke
    3
    Erhielt 34 Danke für 18 Beiträge

    Standard

    Die Rede ist von einem PG, also vermutlich ein Siemens-PG mit MPI-Schnittstelle. An der MPI-Schnittstelle ist der Anschluss eines seriellen Kabels ohne Adapter möglich, das orginal Siemens-Kabel hat die Bestellnummer 6ES7901-0BF00-0AA0. Wenn ich mich recht erinnere ist die Belegung einfach 1 zu 1.

    Das geht aber nur wenn es wirklich eine MPI-Schnittstelle ist!


    edit: etwas zu spät, aber gleiche Aussage
    Wirkich innovativ ist man nur dann, wenn mal was daneben gegangen ist.
    (Woody Allen)

  5. #5
    Registriert seit
    15.12.2007
    Beiträge
    8
    Danke
    0
    Erhielt 5 Danke für 3 Beiträge

    Standard

    Ich verwende (noch) das originale Siemenskabel mit meinem PG. Prinzipiell sollte die Verbindung mit einem seriellen 1:1-Kabel funktionieren, ich wäre aber vorsichtig, da Pin 6 max 10mA aushält und dieser Wert schnell überschritten wird -> Schnittstelle defekt. Desweiteren ist doch im originalen Kabel eine Elektronik (Repeater o.ä.) zur Verhinderung von Reflexionen ect. bei Stichleitung.

    Hat jemand schon Langzeiterfahrung mit einem solchen 1:1-Kabel?

  6. #6
    Registriert seit
    20.10.2003
    Ort
    Biberach
    Beiträge
    5.068
    Danke
    959
    Erhielt 1.458 Danke für 922 Beiträge

    Standard

    Zitat Zitat von sps.net.tc Beitrag anzeigen
    Ich verwende (noch) das originale Siemenskabel mit meinem PG. Prinzipiell sollte die Verbindung mit einem seriellen 1:1-Kabel funktionieren, ich wäre aber vorsichtig, da Pin 6 max 10mA aushält und dieser Wert schnell überschritten wird -> Schnittstelle defekt. Desweiteren ist doch im originalen Kabel eine Elektronik (Repeater o.ä.) zur Verhinderung von Reflexionen ect. bei Stichleitung.
    Da hast Du ja eine alten Beitrag hochgezogen. Falls der Erisch
    wirklich die Leitungen nicht gekreuzt hat, sollte sich der Rauch
    zwischenzeitlich verzogen haben

    Nun zu Deiner Frage. Für MPI mit 187 Kbit/s sollte ein nacktes
    Kabel mit zwei Adern 3 <-> 8 und 8 <-> 3 schon funktionieren
    (die anderen Pins sind nicht belegt).

    Siemens bietet ja auch zwei Kabel an:
    6ES7901-0BF00-0AA0 bis 187,5 Kbit/s und
    6ES7901-4BD00-0XA0 ab 1,5 Mbit/s bis 12 Mbit/s
    Geändert von Gerhard Bäurle (08.02.2008 um 09:11 Uhr) Grund: inhaltliche Fehler beseitigt, danke Zottel
    Beste Grüße Gerhard Bäurle
    _________________________________________________________________
    Hardware: the parts of a computer that can be kicked. – Jeff Pesis

  7. #7
    Registriert seit
    19.06.2003
    Beiträge
    2.200
    Danke
    85
    Erhielt 259 Danke für 175 Beiträge

    Standard

    Zitat Zitat von sps.net.tc Beitrag anzeigen

    Hat jemand schon Langzeiterfahrung mit einem solchen 1:1-Kabel?
    Nein, aber zwischen einer eingebauten MPI/Profibus-Karte und dem Anschluß der CPU sollte ein Kabel reichen, bei dem lediglich die Pins 3 und 8 1:1 verbunden sind, wie beim Profibus-Kabel. Dann bekommst du auch keine Schwierigkeiten mit Pin 6...

  8. Folgender Benutzer sagt Danke zu Zottel für den nützlichen Beitrag:

    Gerhard Bäurle (08.02.2008)

  9. #8
    Registriert seit
    15.12.2007
    Beiträge
    8
    Danke
    0
    Erhielt 5 Danke für 3 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ja 3-8-Leitung würde zur reinen Datenübertragung zw. PG und CPU reichen, nicht aber zur Übertragung auf ältere OPs. Und da ich aus Platzgründen nur ein Kabel mitführen möchte, wäre ein solches Universalkabel natürlich super. Was meint ihr könnte es mit Pin 6 und 7 Probleme geben?
    Hier nochmal die komplette Pinbelegung der MPI-Schnittstelle:
    Pin 1: Nicht angeschlossen (NC)
    Pin 2: Masse 24V (M24V)
    Pin 3: Datenleitung B (Ltg_B)
    Pin 4: Sendeanforderung von AS (RTS-AS)
    Pin 5: Masse 5V (M5V)
    Pin 6: 5V Ausgang (P5V)
    Pin 7: 24V Ausgang (P24V)
    Pin 8: Datenleitung A (Ltg_A)
    Pin 9: Sendeanforderung an AS (RTS-PG)
    Grüsse
    Peter

Ähnliche Themen

  1. Bosch-Rexroth Indradrive, Profibus Verb.
    Von Martin L. im Forum Antriebstechnik
    Antworten: 8
    Letzter Beitrag: 02.07.2013, 07:54
  2. S7-400 alle LED blinken keine Verb. MPI
    Von Kieler im Forum Simatic
    Antworten: 23
    Letzter Beitrag: 11.08.2009, 11:37
  3. S7 Verb nach CP Tausch
    Von tuneit im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 28.04.2009, 16:14
  4. libnodave keine Verb. mehr nach 3. Versuch
    Von noeppkes im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 15.04.2009, 18:23
  5. Antworten: 6
    Letzter Beitrag: 12.09.2006, 15:24

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •