Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 14

Thema: Analogwert flattert

  1. #1
    Registriert seit
    07.07.2005
    Beiträge
    262
    Danke
    7
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    ich hab hier an meiner SPS einen Analogwert mit dem Bereich 0-5V dieser flattert seid kurzem. Lief vorher Einwandfrei, jetzt flattert er hin und her. Gibt sogar bei 0V 32767 heraus, erst wenn ich bei 0.5V schreibt er mir nen richigen Wert von 5000 oder so ähnlich.

    Was kann das sein? Hab mal am Eingang der SPS gemessen, der Spannungswert ist stabil und ruhig.
    Zitieren Zitieren Analogwert flattert  

  2. #2
    Registriert seit
    28.02.2007
    Beiträge
    86
    Danke
    3
    Erhielt 6 Danke für 6 Beiträge

    Standard

    wenn du sagst, das du die spannung an der analogen eingangsbaugrubbe gemessen hast, kann es eigenlich doch nur sein, das was mit deiner skalierung der eingangsspannung nicht stimmt. hast du da vielleicht irgendetwas geändert?

    bis denne

  3. #3
    Registriert seit
    04.02.2007
    Beiträge
    2.544
    Danke
    167
    Erhielt 731 Danke für 528 Beiträge

    Standard

    Hallo,

    was für ne Karte.

    Sind die Massen alle angeschlossen, und vor allen Dingen ;
    sind die unbelegten Analogeingänge auf Masse gelegt.
    Das sieht genau danach aus .
    „Wenn du ein Problem hast, versuche es zu lösen. Kannst du es nicht lösen, dann mache kein Problem daraus.“
    Siddhartha Gautama

  4. #4
    BastiMG ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    07.07.2005
    Beiträge
    262
    Danke
    7
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Nein, ich hab nichts geändert. Hab auch den Eingangsbereich von der Karte nochmal umgestellt auf 1-5V, aber trotzdem flattert der!

  5. #5
    BastiMG ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    07.07.2005
    Beiträge
    262
    Danke
    7
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von jabba Beitrag anzeigen
    Hallo,

    was für ne Karte.

    Sind die Massen alle angeschlossen, und vor allen Dingen ;
    sind die unbelegten Analogeingänge auf Masse gelegt.
    Das sieht genau danach aus .

    Wie unbedlegte müssen auf Masse gezogen werden? Ist mir neu!

    Analog - Eingangskarte 8X12 Bit und ich brauch genau einen Eingang

  6. #6
    Registriert seit
    04.02.2007
    Beiträge
    2.544
    Danke
    167
    Erhielt 731 Danke für 528 Beiträge

    Standard

    Dann les mal das Handbuch von Siemens durch, da steht das auch drin.

    Brücke einfach alle nicht belegten Eingänge mit MAna, bzw 0V
    „Wenn du ein Problem hast, versuche es zu lösen. Kannst du es nicht lösen, dann mache kein Problem daraus.“
    Siddhartha Gautama

  7. #7
    BastiMG ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    07.07.2005
    Beiträge
    262
    Danke
    7
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Wie alle?

    Qusi jeden Pin oder nur einen aus jedem Eingang? Also 2 auf 5 usw oder 1,2,3,4 auf 5 ?

  8. #8
    Registriert seit
    04.02.2007
    Beiträge
    2.544
    Danke
    167
    Erhielt 731 Danke für 528 Beiträge

    Standard

    Laut Handbuch :
    Nichtbeschaltete Kanäle der SM 331; AI 8
     12Bit müssen Sie kurzschließen und
    sollten sie mit M
    ANA verbinden. So erreichen Sie für die Analogeingabebaugruppe
    eine optimale Störfestigkeit. Deaktivieren Sie auch die nichtbeschalteten Kanäle
    bei der Parametrierung mit STEP 7 (siehe Kapitel 4.3.4), um die Zykluszeit der
    Baugruppe zu verkürzen.
    Wenn Sie den COMP-Eingang nicht beschalten, müssen Sie diesen ebenfalls
    kurzschließen.
    .... aus dem Siemens Handbuch

    In deinem Fall heist das
    4,5,6,7,8,9,12,13,14,15,16,17,18,19 mit Pin 20 verbinden,
    bei der Annahme das du den ersten kanal benutzt.

    Das hat aber nix speziell mit Siemens zu tun, sondern liegt in der Besonderheit eines Analogeingangs mit Spannunsgsignal. Alle offenen Eingänge bei Spannungsmessungen müßen immer auf 0V geschaltet werden.
    „Wenn du ein Problem hast, versuche es zu lösen. Kannst du es nicht lösen, dann mache kein Problem daraus.“
    Siddhartha Gautama

  9. #9
    BastiMG ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    07.07.2005
    Beiträge
    262
    Danke
    7
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ich mess aber Spannung auf Pin 6 z.B.

    Jepp Kanal 1 genutz ich die anderen sind alle deaktiv

  10. #10
    BastiMG ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    07.07.2005
    Beiträge
    262
    Danke
    7
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Den Wert Null kann ich nicht ansteuern, dann gibt die SPS mir voll 32767 raus.

Ähnliche Themen

  1. s7-300 analogausgang flattert
    Von volker im Forum Simatic
    Antworten: 22
    Letzter Beitrag: 07.07.2007, 23:08
  2. S7 200 Analogwert
    Von Hugo-Soft im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 24.04.2007, 09:53
  3. Analogwert in nicht gleich Analogwert aus ?
    Von Dilbert im Forum Simatic
    Antworten: 13
    Letzter Beitrag: 16.03.2007, 08:24
  4. Analogwert
    Von Hobbyler im Forum Sonstige Steuerungen
    Antworten: 2
    Letzter Beitrag: 10.10.2006, 11:30
  5. Analogwert und FU
    Von Suschi-S7 im Forum Antriebstechnik
    Antworten: 6
    Letzter Beitrag: 01.08.2006, 22:41

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •